Professional Web Applications Themes

phpmyadmin on FreeBSD 5.3 - FreeBSD

Hello, Im trying to install apache, php4, mysql and phpmyadmin on my computer. Firstly I installed the packages for apache and php. Then I did "cd /usr/ports/databases/phpmyadmin && make install distclean" but that returns with the following error bash-3.00# cd /usr/ports/databases/phpmyadmin && make install distclean You may use the following additional build option: WITH_SUPHP=yes Install appropriately for use with the www/suphp port [default: no] Unknown extension mysqli for PHP 4. *** Error code 1 Stop in /usr/ports/databases/phpmyadmin. bash-3.00# After this I installed the package php4-mysql I tried it again and got the same error. Can anyone tell me wich things ...

  1. #1

    Default phpmyadmin on FreeBSD 5.3

    Hello,

    Im trying to install apache, php4, mysql and phpmyadmin on my computer.
    Firstly I installed the packages for apache and php. Then I did "cd
    /usr/ports/databases/phpmyadmin && make install distclean" but that
    returns with the following error

    bash-3.00# cd /usr/ports/databases/phpmyadmin && make install distclean

    You may use the following additional build option:

    WITH_SUPHP=yes Install appropriately for use with
    the www/suphp port [default: no]

    Unknown extension mysqli for PHP 4.
    *** Error code 1

    Stop in /usr/ports/databases/phpmyadmin.
    bash-3.00#

    After this I installed the package php4-mysql I tried it again and got
    the same error.

    Can anyone tell me wich things I need to do in order to get phpmyadmin
    installed and working?

    Thanks in advance,

    Roeland
    Roeland Guest

  2. #2

    Default Re: phpmyadmin on FreeBSD 5.3

    > Hello,
     
     
     
     
     
     
     
     
     
     


    Hi,

    please provide us with the output of
    pkg_info
    when was the last time you updated your ports tree?

    as a quick workaround I would suggest installing phpmyadmin directly.

    regards

    Sebastian Steenbuck

    X3K6A2 Guest

  3. #3

    Default Re: phpmyadmin on FreeBSD 5.3

    of wich package should I provide the output of pkg_info? also I
    installed everything on this computer today including the ports list
    and such so thats up to date


    On Mon, 21 Mar 2005 23:32:02 +0100, X3K6A2 <net> wrote: 










    >
    > Hi,
    >
    > please provide us with the output of
    > pkg_info
    > when was the last time you updated your ports tree?
    >
    > as a quick workaround I would suggest installing phpmyadmin directly.
    >
    > regards
    >
    > Sebastian Steenbuck
    >
    > _______________________________________________
    > org mailing list
    > http://lists.freebsd.org/mailman/listinfo/freebsd-questions
    > To unsubscribe, send any mail to "org"
    >[/ref]
    Roeland Guest

  4. #4

    Default Re[2]: phpmyadmin on FreeBSD 5.3

    > of wich package should I provide the output of pkg_info? also I 

     
    >> 
    >> 
    >> 
    >> 
    >> 
    >> 
    >> 
    >> 
    >> 
    >> 
    >>
    >> Hi,
    >>
    >> please provide us with the output of
    >> pkg_info
    >> when was the last time you updated your ports tree?
    >>
    >> as a quick workaround I would suggest installing phpmyadmin directly.
    >>
    >> regards
    >>
    >> Sebastian Steenbuck
    >>[/ref][/ref]

    Hi,

    I meaned pkg_info without any arguments.

    regards

    Sebastian Steenbuck

    X3K6A2 Guest

  5. #5

    Default Re: Re[2]: phpmyadmin on FreeBSD 5.3

    bash-3.00# pkg_info
    apache-2.0.53_1 Version 2 of Apache web server with prefork MPM.
    autoconf-2.53_3 Automatically configure source code on many Un*x platforms
    autoconf-2.59_2 Automatically configure source code on many Un*x platforms
    automake-1.5_2,1 GNU Standards-compliant Makefile generator (version 1.5)
    bash-3.0_5 The GNU Project's Bourne Again SHell
    bison-1.75_2 A pr generator from FSF, (mostly) compatible with Yacc
    cracklib-2.7_2 Password-checking library
    curl-7.13.1_1 Non-interactive tool to get files from FTP, GOPHER, HTTP(S)
    cvsup-without-gui-16.1h General network file distribution system
    optimized for CVS
    expat-1.95.8 XML 1.0 pr written in C
    gettext-0.13.1_1 GNU gettext package
    gmake-3.80_2 GNU version of 'make' utility
    help2man-1.35.1 Automatically generating simple manual pages from program o
    ispell-3.2.06_11 An interactive spelling checker for multiple languages
    libiconv-1.9.2_1 A character set conversion library
    libtool-1.3.5_2 Generic shared library support script (version 1.3)
    libtool-1.5.10_1 Generic shared library support script (version 1.5)
    libxml2-2.6.18 XML pr library for GNOME
    libxslt-1.1.13 The XSLT C library for GNOME
    linux_base-7.1_7 The base set of packages needed in Linux mode
    m4-1.4.1 GNU m4
    mysql-client-4.0.24 Multithreaded SQL database (client)
    nmap-3.81 Port scanning utility for large networks
    p5-gettext-1.03 Message handling functions
    pcre-5.0 Perl Compatible Regular Expressions library
    perl-5.8.5 Practical Extraction and Report Language
    php4-bcmath-4.3.10_2 The bcmath shared extension for php
    php4-bz2-4.3.10_2 The bz2 shared extension for php
    php4-calendar-4.3.10_2 The calendar shared extension for php
    php4-cgi-4.3.9 PHP Common Gateway Interface
    php4-crack-4.3.10_2 The crack shared extension for php
    php4-ctype-4.3.10_2 The ctype shared extension for php
    php4-curl-4.3.10_2 The curl shared extension for php
    php4-dba-4.3.10_2 The dba shared extension for php
    php4-dbase-4.3.10_2 The dbase shared extension for php
    php4-dbx-4.3.10_2 The dbx shared extension for php
    php4-dio-4.3.10_2 The dio shared extension for php
    php4-domxml-4.3.10_2 The domxml shared extension for php
    php4-exif-4.3.10_2 The exif shared extension for php
    pico-4.61 PIne's message COmposition editor
    pkgconfig-0.15.0_1 A utility used to retrieve information about installed libr
    suphp-0.5.2_1 Securely execute ~user PHP scripts
    bash-3.00#



    On Mon, 21 Mar 2005 23:39:12 +0100, X3K6A2 <net> wrote: 
    > [/ref]
    >
    > Hi,
    >
    > I meaned pkg_info without any arguments.
    >
    > regards
    >
    > Sebastian Steenbuck
    >
    > _______________________________________________
    > org mailing list
    > http://lists.freebsd.org/mailman/listinfo/freebsd-questions
    > To unsubscribe, send any mail to "org"
    >[/ref]
    Roeland Guest

  6. #6

    Default Re[4]: phpmyadmin on FreeBSD 5.3


     


     
    >> 
    >>
    >> Hi,
    >>
    >> I meaned pkg_info without any arguments.
    >>
    >> regards
    >>
    >> Sebastian Steenbuck
    >>[/ref][/ref]
    Hi,

    this is only a guess.

    I think that the port misses a php extension. (not a port)
    Try adding
    extension=mysql.so
    (extension=mysqli.so)
    to your
    /usr/local/etc/php/extensions.ini

    if you add mysqli.so you should also add a symbolic link with this
    name in
    /usr/local/lib/php/[some numbers here]/*.so
    pointing to mysql.so in the same directory. (also note that mysql.so
    should be in this directory)

    Try this at your own risk. (Any of this things can be removed, so
    there is not much risk)

    regards

    Sebastian Steenbuck

    X3K6A2 Guest

  7. #7

    Default Re: phpmyadmin on FreeBSD 5.3

    I have the same problem, however, I want to use php4 (on FreeBSD 4.8).
    My understanding is that mysqli shared library/extension only applies
    to php5 installs.

    Is there a way for phpmyadmin to NOT use mysqli in the FreeBSD port ?
    Thanks!

    googledude@hotmail.com Guest

  8. #8

    Default Re: phpmyadmin on FreeBSD 5.3

    On Mon, Mar 21, 2005 at 11:01:59PM +0100, Roeland Hemsteede wrote: 

    You need to run:

    # make config

    in the databases/phpmyadmin directory and *uncheck* the option for
    MYSQLI. Then you should be able to install successfully. Like it
    clearly says, you can only use the php mysqli extension with PHP5 and
    MySQL 4.1.x

    Cheers,

    Matthew

    --
    Dr Matthew J Seaman MA, D.Phil. 8 Dane Court Manor
    School Rd
    PGP: http://www.infracaninophile.co.uk/pgpkey Tilmanstone
    Tel: +44 1304 617253 Kent, CT14 0JL UK

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.0 (FreeBSD)

    iQCVAwUBQkC3AJr7OpndfbmCAQLreAQAi6xTTGWGTDGi2Pn0ez slboyfaI7taD/m
    gtyF7/F0FDGihSJBMuMtNm/uM6Ldb0j0vkzNx7xpKNxVX5gbuXaMI+XoW20KfXpl
    bcIkyxgohsnLAWGfEBx4iOtGhu7Jsajw5xRCeMnmkMvOClakCz bbJJtZLCMoG70Y
    SBGAdjF4l+U=
    =dcl9
    -----END PGP SIGNATURE-----

    Matthew Guest

Similar Threads

  1. phpMyadmin
    By NA in forum MySQL
    Replies: 5
    Last Post: February 17th, 07:09 PM
  2. phpMyAdmin - how big is too big?
    By deko in forum MySQL
    Replies: 3
    Last Post: June 7th, 11:08 AM
  3. Compile FreeBSD RELENG_5 on FreeBSD 4-STABLE
    By Brovo Karokin in forum FreeBSD
    Replies: 1
    Last Post: February 25th, 09:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139