Professional Web Applications Themes

postfix on FreeBSD - FreeBSD

Hi people i don't know where to post this message because this is not a problem of the FreeBSD OS but it's a problem of his web site . i am using thunderbird to read rss news from freebsd website but there is a problem with the news.rdf file because links in this file are in this format http://www.FreeBSD.org/news/newsflash.html#event200537:0 but in the real page(in the source code) has this format name="event20050307:0" have two digit for month and day and for the number of news too and the link does not work correctly i don't want think that i am the ...

  1. #1

    Default rss news.rdf

    Hi people
    i don't know where to post this message because this is not a problem
    of the FreeBSD OS but it's a problem of his web site . i am using
    thunderbird to read rss news from freebsd website but there is a problem
    with the news.rdf file because links in this file are in this format

    http://www.FreeBSD.org/news/newsflash.html#event200537:0

    but in the real page(in the source code) has this format

    name="event20050307:0"

    have two digit for month and day and for the number of news too and the link does not work correctly
    i don't want think that i am the only one that use the rss news from freebsd :-)

    Thanks

    Osmany











    Osmany Guest

  2. #2

    Default postfix on FreeBSD

    I'm trying to set up postfix to reject messages to two specific
    usernames on our domains. The FreeBSD server is taking the messages,
    checking them for spam and viruses, then forwarding them on to our
    internal mail server.

    In the /usr/local/etc/postfix/main.cf file, I added the line:
    smtpd_recipient_restrictions = check_recipient_access
    hash:/usr/local/etc/postfix/access

    I then added to the file /usr/local/etc/postfix/access:
    username1 REJECT
    username2 REJECT

    I then ran the commands
    postmap /usr/local/etc/postfix/access
    postfix stop && postfix start

    Then using tail -f /var/log/maillog, I got the error:
    Mar 9 10:28:16 myserver postfix/postfix-script: stopping the Postfix
    mail system
    Mar 9 10:28:16 myserver postfix/master[66263]: terminating on signal 15
    Mar 9 10:28:17 myserver postfix/postfix-script: starting the Postfix
    mail system
    Mar 9 10:28:17 myserver postfix/master[73766]: daemon started --
    version 2.1.5
    Mar 9 10:28:48 myserver postfix/smtpd[73796]: fatal: parameter
    "smtpd_recipient_restrictions": specify at least one working instance
    of: check_relay_domains, reject_unauth_destination, reject, defer or
    defer_if_permit
    Mar 9 10:28:49 myserver postfix/master[73766]: warning: process
    /usr/local/libexec/postfix/smtpd pid 73796 exit status 1
    Mar 9 10:28:49 myserver postfix/master[73766]: warning:
    /usr/local/libexec/postfix/smtpd: bad command startup -- throttling

    I put in a hash mark for the smtpd_ line in main.cf and ran another
    postfix stop and start to get mail working again, but what am I doing
    wrong with the file?

    Bart Guest

  3. #3

    Default Re: postfix on FreeBSD

    --On Wednesday, March 09, 2005 10:43:05 AM -0500 Bart Silverstrim
    <com> wrote: 

    Should be:
    postmap hash:/usr/local/etc/postfix/access

    man (1) postmap

    Paul Schmehl (edu)
    Adjunct Information Security Officer
    The University of Texas at Dallas
    AVIEN Founding Member
    http://www.utdallas.edu
    Paul Guest

  4. #4

    Default Re: postfix on FreeBSD

    On Wed, March 9, 2005 10:43 am, Bart Silverstrim said: 

    Read the error message - currently you are configured to accept *any*
    message presented except those going to the specified users. That
    includes spam intended for completely unrelated domains. I would
    recommend using the following as a *bare* minimum:

    smtpd_recipient_restrictions = permit_mynetworks,
    reject_unauth_destination, check_recipient_access
    hash:/usr/local/etc/postfix/access

    I would also recommend looking at
    http://www.postfix.org/SMTPD_ACCESS_README.html and
    http://jimsun.linxnet.com/misc/postfix-anti-UCE.txt -- they will help you
    understand what should be in your smtpd_*_restrictions.

    Jim
    --
    Jim Trigg, Lord High Everything Else O- /"\
    Hostmaster, Huie Kin family website \ / ASCII RIBBON CAMPAIGN
    Verger and System Administrator, X HELP CURE HTML MAIL
    All Saints Church - Sharon Chapel / \


    Jim Guest

  5. #5

    Default Re: postfix on FreeBSD

    On 2005-03-09, Paul Schmehl scribbled these
    curious markings: 

    Really? I've updated hash files (not access, but canonical and
    transport) without the hash: prefix and they've worked fine. Taking a
    look at the top of those files even shows the usage without the hash:
    prefix (access included).

    Best Regards,
    Christopher Nehren
    --
    I abhor a system designed for the "user", if that word is a coded
    pejorative meaning "stupid and unsophisticated". -- Ken Thompson
    If you ask the wrong questions, you get answers like "42" and "God".
    Unix is user friendly. However, it isn't idiot friendly.

    Christopher Guest

  6. #6

    Default Re: postfix on FreeBSD

    On Wed, 9 Mar 2005 17:45:34 +0000 (UTC), Christopher Nehren
    <apeiron+info> wrote: 
    >
    > Really? I've updated hash files (not access, but canonical and
    > transport) without the hash: prefix and they've worked fine. Taking a
    > look at the top of those files even shows the usage without the hash:
    > prefix (access included).
    >
    > Best Regards,
    > Christopher Nehren[/ref]

    If you don't specify the database type, postfix will use the defined
    default_database_type
    Unless you are using multiple database types, you don't need to specify this.

    --
    Noel Jones
    Noel Guest

  7. #7

    Default Re: postfix on FreeBSD


    On Mar 9, 2005, at 10:56 AM, Paul Schmehl wrote:
     
    >
    > Should be:
    > postmap hash:/usr/local/etc/postfix/access
    >
    > man (1) postmap[/ref]

    I was running the command as was outlined in the access file...from
    that file, it says:
    # /usr/local/etc/postfix/main.cf:
    # smtpd_client_restrictions =
    # check_client_access hash:/usr/local/etc/postfix/access
    #
    # /usr/local/etc/postfix/access:
    # 1.2.3 REJECT
    # 1.2.3.4 OK
    #
    # Execute the command "postmap /usr/local/etc/postfix/access"
    after
    # editing the file.

    I think I know what was happening...the main.cf file didn't have the
    smtpd_recipient_restrictions directive in it, and postfix used
    reasonable defaults. When I set smtpd_recipient_restrictions, it
    overrode the defaults, and was complaining because it wanted some
    reasonable settings placed in there along with my customized settings.
    So my actual line to put in would be something like,

    smtpd_recipient_restrictions = check_recipient_access
    hash:/usr/local/etc/postfix/access, permit_mynetworks,
    reject_unauth_destination

    in main.cf, correct?

    Bart Guest

  8. #8

    Default Re: postfix on FreeBSD


    On Mar 9, 2005, at 11:26 AM, Jim Trigg wrote:
     
    >
    > Read the error message - currently you are configured to accept *any*
    > message presented except those going to the specified users. That
    > includes spam intended for completely unrelated domains. I would
    > recommend using the following as a *bare* minimum:
    >
    > smtpd_recipient_restrictions = permit_mynetworks,
    > reject_unauth_destination, check_recipient_access
    > hash:/usr/local/etc/postfix/access
    >
    > I would also recommend looking at
    > http://www.postfix.org/SMTPD_ACCESS_README.html and
    > http://jimsun.linxnet.com/misc/postfix-anti-UCE.txt -- they will help
    > you
    > understand what should be in your smtpd_*_restrictions.[/ref]

    I saw the errors and googled for it, but it just led to the man pages
    and site web pages for the postfix project (which I read); what was
    throwing me was the fact that it wasn't an open relay before and it
    didn't have the directive previously. I think it was using reasonable
    defaults before and my adding that line to my main.cf overrode them
    causing it to burp the error messages.

    Bart Guest

  9. #9

    Default Re: postfix on FreeBSD

    On Wed, March 9, 2005 3:39 pm, Bart Silverstrim said: 

    Exactly correct -- if you *don't specify* smtpd_recipient_restrictions, it
    defaults to "permit_mynetworks, reject_unauth_destination", but as soon as
    you specify something, you need to explicitly include that.

    Jim

    Jim Guest

Similar Threads

  1. Compile FreeBSD RELENG_5 on FreeBSD 4-STABLE
    By Brovo Karokin in forum FreeBSD
    Replies: 1
    Last Post: February 25th, 09:04 AM
  2. Panther, Postfix, PPP
    By Andre in forum Mac Networking
    Replies: 4
    Last Post: December 28th, 05:01 PM
  3. Postfix
    By Florian Ernst in forum Debian
    Replies: 1
    Last Post: July 30th, 12:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139