so i now try to preview... LOCALHOST ERROR... i end with a http://localhost/tempfile.shtml errrr! what i do now? i tryed that... i set "url prefix" = c:\test (putting another \ give a error ) so i now try to preview... the include is not working... the source show me nothing wrong... but the code is still there! he was not "interpreted" AND i have NO "ASP" mini icons in the preview like before creating a SITE... so what is going on? ive done everything humanly possible... AM i missing something!? a little stupid option somewhere? everything as been done well! as i said ... with DW4 ... you do that without creating a site and YEAH its working! so what is so dumb about MX? its simple as a picture... go read that $$%&@!!!! file and include it in the source! and preview it! :D hehe [allowsmilie] => 1 [showsignature] => 0 [ipaddress] => [iconid] => 0 [visible] => 1 [attach] => 0 [infraction] => 0 [reportthreadid] => 0 [isusenetpost] => 1 [msgid] => [ref] => [htmlstate] => on_nl2br [postusername] => Menta [ip] => "Menta" webforu [isdeleted] => 0 [usergroupid] => [membergroupids] => [displaygroupid] => [password] => [passworddate] => [email] => [styleid] => [parentemail] => [homepage] => [icq] => [aim] => [yahoo] => [msn] => [skype] => [showvbcode] => [showbirthday] => [usertitle] => [customtitle] => [joindate] => [daysprune] => [lastvisit] => [lastactivity] => [lastpost] => [lastpostid] => [posts] => [reputation] => [reputationlevelid] => [timezoneoffset] => [pmpopup] => [avatarid] => [avatarrevision] => [profilepicrevision] => [sigpicrevision] => [options] => [akvbghsfs_optionsfield] => [birthday] => [birthday_search] => [maxposts] => [startofweek] => [referrerid] => [languageid] => [emailstamp] => [threadedmode] => [autosubscribe] => [pmtotal] => [pmunread] => [salt] => [ipoints] => [infractions] => [warnings] => [infractiongroupids] => [infractiongroupid] => [adminoptions] => [profilevisits] => [friendcount] => [friendreqcount] => [vmunreadcount] => [vmmoderatedcount] => [socgroupinvitecount] => [socgroupreqcount] => [pcunreadcount] => [pcmoderatedcount] => [gmmoderatedcount] => [assetposthash] => [fbuserid] => [fbjoindate] => [fbname] => [logintype] => [fbaccesstoken] => [newrepcount] => [vbseo_likes_in] => [vbseo_likes_out] => [vbseo_likes_unread] => [temp] => [field1] => [field2] => [field3] => [field4] => [field5] => [subfolders] => [pmfolders] => [buddylist] => [ignorelist] => [signature] => [searchprefs] => [rank] => [icontitle] => [iconpath] => [avatarpath] => [hascustomavatar] => 0 [avatardateline] => [avwidth] => [avheight] => [edit_userid] => [edit_username] => [edit_dateline] => [edit_reason] => [hashistory] => [pagetext_html] => [hasimages] => [signatureparsed] => [sighasimages] => [sigpic] => [sigpicdateline] => [sigpicwidth] => [sigpicheight] => [postcount] => 7 [islastshown] => [isfirstshown] => [attachments] => [allattachments] => ) --> > > so i now try to preview... LOCALHOST ERROR... i end with a http://localhost/tempfile.shtml > > errrr! what i do now? > > i tryed that... > > i set "url prefix" = c:\test (putting another \ give a error ) > > so i now try to preview... the include is not working... the source show me nothing wrong... but the code is still there! he was not "interpreted" AND i have NO "ASP" mini icons in the preview like before creating a SITE... > > so what is going on? > > ive done everything humanly possible... AM i missing something!? a little stupid option somewhere? > > everything as been done well! > > > as i said ... with DW4 ... you do that without creating a site and YEAH its working! so what is so dumb about MX? its simple as a picture... go read that $$%&@!!!! file and include it in the source! and preview it! :D > > hehe > > > > > > > > >[/ref] AFAIK, you don't need to have a server at all. -- Dan Vendel - *GOF* http://www.vendel.info Contact me directly by clicking here: http://contact.vendel.info Formmail tutorial: http://www.vendel.info/tut/formmail.html Nested table demonstration: http://www.vendel.info/tabletut/ [allowsmilie] => 1 [showsignature] => 0 [ipaddress] => [iconid] => 0 [visible] => 1 [attach] => 0 [infraction] => 0 [reportthreadid] => 0 [isusenetpost] => 1 [msgid] => [ref] => [htmlstate] => on_nl2br [postusername] => Dan [ip] => see_my_signatur [isdeleted] => 0 [usergroupid] => [membergroupids] => [displaygroupid] => [password] => [passworddate] => [email] => [styleid] => [parentemail] => [homepage] => [icq] => [aim] => [yahoo] => [msn] => [skype] => [showvbcode] => [showbirthday] => [usertitle] => [customtitle] => [joindate] => [daysprune] => [lastvisit] => [lastactivity] => [lastpost] => [lastpostid] => [posts] => [reputation] => [reputationlevelid] => [timezoneoffset] => [pmpopup] => [avatarid] => [avatarrevision] => [profilepicrevision] => [sigpicrevision] => [options] => [akvbghsfs_optionsfield] => [birthday] => [birthday_search] => [maxposts] => [startofweek] => [referrerid] => [languageid] => [emailstamp] => [threadedmode] => [autosubscribe] => [pmtotal] => [pmunread] => [salt] => [ipoints] => [infractions] => [warnings] => [infractiongroupids] => [infractiongroupid] => [adminoptions] => [profilevisits] => [friendcount] => [friendreqcount] => [vmunreadcount] => [vmmoderatedcount] => [socgroupinvitecount] => [socgroupreqcount] => [pcunreadcount] => [pcmoderatedcount] => [gmmoderatedcount] => [assetposthash] => [fbuserid] => [fbjoindate] => [fbname] => [logintype] => [fbaccesstoken] => [newrepcount] => [vbseo_likes_in] => [vbseo_likes_out] => [vbseo_likes_unread] => [temp] => [field1] => [field2] => [field3] => [field4] => [field5] => [subfolders] => [pmfolders] => [buddylist] => [ignorelist] => [signature] => [searchprefs] => [rank] => [icontitle] => [iconpath] => [avatarpath] => [hascustomavatar] => 0 [avatardateline] => [avwidth] => [avheight] => [edit_userid] => [edit_username] => [edit_dateline] => [edit_reason] => [hashistory] => [pagetext_html] => [hasimages] => [signatureparsed] => [sighasimages] => [sigpic] => [sigpicdateline] => [sigpicwidth] => [sigpicheight] => [postcount] => 8 [islastshown] => [isfirstshown] => [attachments] => [allattachments] => ) -->Preview in Browser. Make sure there is a checkmark in the box for "create temporary file to preview" The TMP page dw creates will "include" the include- even though you don't have a server running locally. IF the page has ASP code, or IF you DO have a server running locally- then the answers would be different. [ref] > If i dont define a server it doesn't work... > > i got little tiny ASP icons in the preview(MEAN I DONT SEE THE INCLUDED > CONTENT) if i dont define a server... > > whatever i do i never see the include... > > is there someone here able to help me? > > im starting to get mad... really mad! > > > > >[/ref] -- Team Macromedia Volunteer for Dreamweaver Certified Dreamweaver MX Developer [allowsmilie] => 1 [showsignature] => 0 [ipaddress] => [iconid] => 0 [visible] => 1 [attach] => 0 [infraction] => 0 [reportthreadid] => 0 [isusenetpost] => 1 [msgid] => [ref] => [htmlstate] => on_nl2br [postusername] => Alan [ip] => blu@formdude.co [isdeleted] => 0 [usergroupid] => [membergroupids] => [displaygroupid] => [password] => [passworddate] => [email] => [styleid] => [parentemail] => [homepage] => [icq] => [aim] => [yahoo] => [msn] => [skype] => [showvbcode] => [showbirthday] => [usertitle] => [customtitle] => [joindate] => [daysprune] => [lastvisit] => [lastactivity] => [lastpost] => [lastpostid] => [posts] => [reputation] => [reputationlevelid] => [timezoneoffset] => [pmpopup] => [avatarid] => [avatarrevision] => [profilepicrevision] => [sigpicrevision] => [options] => [akvbghsfs_optionsfield] => [birthday] => [birthday_search] => [maxposts] => [startofweek] => [referrerid] => [languageid] => [emailstamp] => [threadedmode] => [autosubscribe] => [pmtotal] => [pmunread] => [salt] => [ipoints] => [infractions] => [warnings] => [infractiongroupids] => [infractiongroupid] => [adminoptions] => [profilevisits] => [friendcount] => [friendreqcount] => [vmunreadcount] => [vmmoderatedcount] => [socgroupinvitecount] => [socgroupreqcount] => [pcunreadcount] => [pcmoderatedcount] => [gmmoderatedcount] => [assetposthash] => [fbuserid] => [fbjoindate] => [fbname] => [logintype] => [fbaccesstoken] => [newrepcount] => [vbseo_likes_in] => [vbseo_likes_out] => [vbseo_likes_unread] => [temp] => [field1] => [field2] => [field3] => [field4] => [field5] => [subfolders] => [pmfolders] => [buddylist] => [ignorelist] => [signature] => [searchprefs] => [rank] => [icontitle] => [iconpath] => [avatarpath] => [hascustomavatar] => 0 [avatardateline] => [avwidth] => [avheight] => [edit_userid] => [edit_username] => [edit_dateline] => [edit_reason] => [hashistory] => [pagetext_html] => [hasimages] => [signatureparsed] => [sighasimages] => [sigpic] => [sigpicdateline] => [sigpicwidth] => [sigpicheight] => [postcount] => 10 [islastshown] => 1 [isfirstshown] => [attachments] => [allattachments] => ) --> Previewing A page with SSI. - Macromedia Dreamweaver

Previewing A page with SSI. - Macromedia Dreamweaver

Removed by Administrator...

  1. Moderated Post

    Default Previewing A page with SSI.

    Removed by Administrator
    Menta Guest
    Moderated Post

  2. Moderated Post

    Default Re: Previewing A page with SSI.

    Removed by Administrator
    Paul Guest
    Moderated Post

  3. #3

    Default Re: Previewing A page with SSI.

    How i do that?

    i'm not a pro!

    and im not on a network...

    how i do that?




    Menta Guest

  4. #4

    Default Re: Previewing A page with SSI.

    Check with your network people whether they have a webserver installed, and
    if so get them to set up a virtual directory to your site, and then
    reference it through you browser like this

    http://servername/websitename/filename

    --
    Regards

    Paul Whitham
    Valleybiz Internet Design
    www.valleybiz.net

    Team Macromedia Volunteer for Ultradev/Dreamweaver MX
    www.macromedia.com/support/forums/team_macromedia
    "Menta" <com> wrote in message
    news:bguims$5pv$macromedia.com... 


    Paul Guest

  5. #5

    Default Re: Previewing A page with SSI.

    "Menta" com wrote:
     


    What do you mean by this:
    "AND I DONT want to create a SITE."?

    You *must* have a folder defined as the local site to be able to preview
    correctly.

    --
    Dan Vendel - *GOF*
    http://www.vendel.info
    Contact me directly by clicking here:
    http://contact.vendel.info
    Formmail tutorial:
    http://www.vendel.info/tut/formmail.html
    Nested table demonstration:
    http://www.vendel.info/tabletut/

    Dan Guest

  6. #6

    Default Re: Previewing A page with SSI.

    "Menta" com wrote:
     


    1) As I wrote, you *must* have the page saved in a defined site, and the
    page you're including *must* reside in that site according to the path.
    The reason (AFAIK) is that DW creates a *temporary* file when you are
    previewing. So, you're not actually viewing the "real" page. To make
    links, etc in this "temporary" file work, it *must* origin from a page
    that's included in a defined site.

    Millions of DW have no problems with this, so I don't think it's
    "stupid". As a matter of fact, lots of DW's excellent features are based
    on this!

    2) What do you mean "I tried to define a site"? *Did* you define a site
    or did you *not*? If the former, did you put the file you are trying to
    include where it belongs?

    3) No, you don't have to re-install DW4 at all, because you will have
    the same issue there. You *must* define a site, and you *must* place the
    included file where it has to be, in which ever version of DW you like
    to work.

    --
    Dan Vendel - *GOF*
    http://www.vendel.info
    Contact me directly by clicking here:
    http://contact.vendel.info
    Formmail tutorial:
    http://www.vendel.info/tut/formmail.html
    Nested table demonstration:
    http://www.vendel.info/tabletut/

    Dan Guest

  7. #7

    Default Re: Previewing A page with SSI.

    argg!

    I tryed Using VIRTUAL ... nothing!

    YES my files is a .shtml as it supposed to be since i use SSI.

    so let me start from the beginning

    SITE... NEW SITE..


    LOCAL HOST TAB
    name = anything
    Local host = C:\test\
    rest is untouched


    remote = nothing


    TESTING SERVER TAB
    i choosed ASP- javascript (but i tryed them all)
    ACCESS = local/network
    testing server folder = C:\test\
    url prefix is untouched FOR NOW (see next text)

    i have 2 file... both in C:\test\

    the code included in index.shtml = <!--#include file="include.html" -->

    so i now try to preview... LOCALHOST ERROR... i end with a http://localhost/tempfile.shtml

    errrr! what i do now?

    i tryed that...

    i set "url prefix" = c:\test (putting another \ give a error )

    so i now try to preview... the include is not working... the source show me nothing wrong... but the code is still there! he was not "interpreted" AND i have NO "ASP" mini icons in the preview like before creating a SITE...

    so what is going on?

    ive done everything humanly possible... AM i missing something!? a little stupid option somewhere?

    everything as been done well!


    as i said ... with DW4 ... you do that without creating a site and YEAH its working! so what is so dumb about MX? its simple as a picture... go read that $$%&!!!! file and include it in the source! and preview it! :D

    hehe









    Menta Guest

  8. #8

    Default Re: Previewing A page with SSI.

    "Menta" com wrote:
     

    AFAIK, you don't need to have a server at all.

    --
    Dan Vendel - *GOF*
    http://www.vendel.info
    Contact me directly by clicking here:
    http://contact.vendel.info
    Formmail tutorial:
    http://www.vendel.info/tut/formmail.html
    Nested table demonstration:
    http://www.vendel.info/tabletut/

    Dan Guest

  9. #9

    Default Re: Previewing A page with SSI.

    If i dont define a server it doesn't work...

    i got little tiny ASP icons in the preview(MEAN I DONT SEE THE INCLUDED CONTENT) if i dont define a server...

    whatever i do i never see the include...

    is there someone here able to help me?

    im starting to get mad... really mad!




    Menta Guest

  10. #10

    Default Re: Previewing A page with SSI.

    Does this page have any serverside scripting? ASP or other stuff?

    When you entered info for a testing server---
    Do you have a SERVER running on your machine?

    If you don't- that feature won't work.
    Reason- Dreamweaver hands off the preview to the testing server location.
    SSI needs a server to assemble them.
    You have pointed dw to a simple file folder- NOT a server.

    What you should do, is IF the page has no ASP or server code- take all the
    info out of the "testing server" pane. change the top pulldown to NONE.

    And check this part of Dreamweaver Preferences-
    dw Prefs-->Preview in Browser.
    Make sure there is a checkmark in the box for "create temporary file to
    preview"

    The TMP page dw creates will "include" the include- even though you don't
    have a server running locally.

    IF the page has ASP code, or IF you DO have a server running locally- then
    the answers would be different.

     

    --
    Team Macromedia Volunteer for Dreamweaver
    Certified Dreamweaver MX Developer

    Alan Guest

Similar Threads

  1. previewing dreamweaver html page
    By happydreamweaver in forum Macromedia Dynamic HTML
    Replies: 3
    Last Post: December 1st, 09:18 PM
  2. Replies: 7
    Last Post: November 11th, 02:45 PM
  3. Image Previewing
    By Dawn M Pittman in forum Adobe Photoshop 7, CS, CS2 & CS3
    Replies: 3
    Last Post: August 28th, 12:32 PM
  4. Previewing in the browser
    By :::Kevin French::: in forum Macromedia Fireworks
    Replies: 1
    Last Post: August 11th, 03:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •