Professional Web Applications Themes

Problem in Web Service Authorization Mode - ASP.NET Web Services

Hi I just have a third party dll which does some custom functionality. The Dll have some apis which run only when the user is an administrator. I made a simple windows GUI application which makes use of the dll. Good it works fine when i am logged in as the Administrator. I made a Webservice which uses PInvoke thereby making use of the DLL. The DLL reported Error as the WebService is not running in the Administrator Authorization mode. SOo i went into Machine.config and changed the process model attributes to username :administrator password:MyPassword and it works VERY FINE.. ...

  1. #1

    Default Problem in Web Service Authorization Mode

    Hi
    I just have a third party dll which does some custom functionality.
    The Dll have some apis which run only when the user is an administrator.
    I made a simple windows GUI application which makes use of the dll. Good it
    works fine when i am logged in as the Administrator.

    I made a Webservice which uses PInvoke thereby making use of the DLL.
    The DLL reported Error as the WebService is not running in the Administrator
    Authorization mode.
    SOo i went into Machine.config and changed the process model attributes to
    username :administrator password:MyPassword
    and it works VERY FINE.. No problems at all.

    But i dont want to have the machine.config approach as it makes each and
    every webservice running on the system as an administrator mode.
    How can i have customized thing which works as an administrator mode only
    for that webservice and not for others.

    Is there any way????
    Expecting ur replies.
    Regards
    Shal





    Shalini Guest

  2. #2

    Default Problem in Web Service Authorization Mode

    Hi
    I just have a third party dll which does some custom functionality.
    The Dll have some apis which run only when the user is an administrator.
    I made a simple windows GUI application which makes use of the dll. Good it
    works fine when i am logged in as the Administrator.

    I made a Webservice which uses PInvoke thereby making use of the DLL.
    The DLL reported Error as the WebService is not running in the Administrator
    Authorization mode.
    SOo i went into Machine.config and changed the process model attributes to
    username :administrator password:MyPassword
    and it works VERY FINE.. No problems at all.

    But i dont want to have the machine.config approach as it makes each and
    every webservice running on the system as an administrator mode.
    How can i have customized thing which works as an administrator mode only
    for that webservice and not for others.

    Is there any way????
    Expecting ur replies.
    Regards
    Shal





    Shalini Guest

  3. #3

    Default Re: Problem in Web Service Authorization Mode

    I also tried
    doing in web.config to make it personalised only for one webservice but it
    did not work. I get an access denied message in the custom dll which says
    admin did not login. It only works if i modify the machine.config. Can this
    be done in some way?

    I modified web.config as follows by adding one line
    <identity impersonate="true" userName="Administrator" password="mypassword"
    />

    "Shalini" <kandukondeinNOSPAM> wrote in message
    news:OYjEc%23eAEHA.2040TK2MSFTNGP12.phx.gbl...
    > Hi
    > I just have a third party dll which does some custom functionality.
    > The Dll have some apis which run only when the user is an administrator.
    > I made a simple windows GUI application which makes use of the dll. Good
    it
    > works fine when i am logged in as the Administrator.
    >
    > I made a Webservice which uses PInvoke thereby making use of the DLL.
    > The DLL reported Error as the WebService is not running in the
    Administrator
    > Authorization mode.
    > SOo i went into Machine.config and changed the process model attributes
    to
    > username :administrator password:MyPassword
    > and it works VERY FINE.. No problems at all.
    >
    > But i dont want to have the machine.config approach as it makes each and
    > every webservice running on the system as an administrator mode.
    > How can i have customized thing which works as an administrator mode only
    > for that webservice and not for others.
    >
    > Is there any way????
    > Expecting ur replies.
    > Regards
    > Shal
    >
    >
    >
    >
    >

    Shalini Guest

  4. #4

    Default Re: Problem in Web Service Authorization Mode

    I also tried
    doing in web.config to make it personalised only for one webservice but it
    did not work. I get an access denied message in the custom dll which says
    admin did not login. It only works if i modify the machine.config. Can this
    be done in some way?

    I modified web.config as follows by adding one line
    <identity impersonate="true" userName="Administrator" password="mypassword"
    />

    "Shalini" <kandukondeinNOSPAM> wrote in message
    news:OYjEc%23eAEHA.2040TK2MSFTNGP12.phx.gbl...
    > Hi
    > I just have a third party dll which does some custom functionality.
    > The Dll have some apis which run only when the user is an administrator.
    > I made a simple windows GUI application which makes use of the dll. Good
    it
    > works fine when i am logged in as the Administrator.
    >
    > I made a Webservice which uses PInvoke thereby making use of the DLL.
    > The DLL reported Error as the WebService is not running in the
    Administrator
    > Authorization mode.
    > SOo i went into Machine.config and changed the process model attributes
    to
    > username :administrator password:MyPassword
    > and it works VERY FINE.. No problems at all.
    >
    > But i dont want to have the machine.config approach as it makes each and
    > every webservice running on the system as an administrator mode.
    > How can i have customized thing which works as an administrator mode only
    > for that webservice and not for others.
    >
    > Is there any way????
    > Expecting ur replies.
    > Regards
    > Shal
    >
    >
    >
    >
    >

    Shalini Guest

Similar Threads

  1. Problem using Authorization Manager
    By curry in forum ASP.NET Security
    Replies: 1
    Last Post: February 8th, 05:25 PM
  2. Authorization Problem
    By Andrew Davidson in forum ASP.NET Security
    Replies: 29
    Last Post: October 27th, 05:52 AM
  3. authorization problem for protected dir
    By amy liu in forum ASP.NET Security
    Replies: 0
    Last Post: August 25th, 05:01 AM
  4. Replies: 1
    Last Post: May 5th, 09:39 PM
  5. MySQL 4.1 authorization problem
    By Stas V. Shimov in forum PHP Development
    Replies: 1
    Last Post: August 16th, 06:08 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139