Hello.

I'm a perl newbie and am trying to install the Image::Imlib2 version
1.00 on my linux system. However, I am encountering problems during
the "Build" process. I first installed imlib2-1.1.0 on my system and
that went well. I then tried installing the Image::Imlib2 module.
The first two commands "perl Build.PL" and "./Build" proceeded
normally, but the "./Build test" failed. I am not sure why...
Here is a copy of what happened during my console sessions:

linux: # vim Build.PL
linux: # perl Build.PL
Found imlib2 1.1.0
Checking whether your kit is complete...
Looks good
Creating new 'Build' script for 'Image-Imlib2' version '1.00'
linux: # ./Build
lib/Image/Imlib2.pm -> blib/lib/Image/Imlib2.pm
lib/Image/Imlib2.xs -> lib/Image/Imlib2.c
cc -I./lib/Image -I/usr/lib/perl5/5.6.1/i586-linux/CORE
-DX_DISPLAY_MISSING -I/usr/local/include -I/usr/X11R6/include -c
-fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2
-pipe -o lib/Image/Imlib2.o lib/Image/Imlib2.c
ExtUtils::Mkbootstrap::Mkbootstrap('lib/Image/Imlib2')
lib/Image/Imlib2.bs -> blib/arch/auto/Image/Imlib2/Imlib2.bs
cc -shared -o blib/arch/auto/Image/Imlib2/Imlib2.so lib/Image/Imlib2.o
-L/usr/local/lib -lImlib2 -lfreetype -lm -ldl -lXext -lXext -lX11
-L/usr/X11R6/lib
Manifying blib/lib/Image/Imlib2.pm -> blib/libdoc/Image::Imlib2.3pm
linux: # ./Build test
t/signature....ok
1/1 skipped: - Cannot connect to the keyserver
t/simple.......dubious
Test returned status 0 (wstat 11, 0xb)
DIED. FAILED tests 1-7
Failed 7/7 tests, 0.00% okay
Failed Test Stat Wstat Total Fail Failed List of Failed
----------------------------------------------------------------------------
---
t/simple.t 0 11 7 14 200.00% 1-7
1 subtest skipped.
Failed 1/2 test scripts, 50.00% okay. 7/8 subtests failed, 12.50%
okay.
================================================== ===
I also tried examing the test file for more errors by typing in the
following:

linux: # perl -Mblib t/simple.t
Using Image-Imlib2-1.00/blib
1..7
Segmentation fault

I was wondering if anyone could help point me to suggestions as to why the
test failed and how to proceed from here...

Thanks in advance.