Professional Web Applications Themes

Problem installing Perl-RPM module on a RedHat 9.0 - PERL Modules

Hi. I've got some trouble installing Perl-RPM-0.40.tar.gz on a RedHat 9.0. I previously install it on a RedHat 7.3 without any problem. When I do the "make" Here's the result. gcc -c -I. -I/usr/include/rpm -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBUGGING -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -march=i386 -mcpu=i686 -g -DVERSION=\"0.40\" -DXS_VERSION=\"0.40\" -fPIC "-I/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE" RPM/Constants.c -o RPM/Constants.o Constants.xs: In function `constant': Constants.xs:19: `CHECKSIG_GPG' undeclared (first use in this function) Constants.xs:19: (Each undeclared identifier is reported only once Constants.xs:19: for each function it appears in.) Constants.xs:21: `CHECKSIG_MD5' undeclared (first use in this function) Constants.xs:23: `CHECKSIG_PGP' undeclared (first use in this function) Constants.xs:240: `RPMFILE_DONOTUSE' undeclared ...

  1. #1

    Default Problem installing Perl-RPM module on a RedHat 9.0

    Hi.

    I've got some trouble installing Perl-RPM-0.40.tar.gz on a RedHat 9.0.
    I previously install it on a RedHat 7.3 without any problem.

    When I do the "make"
    Here's the result.

    gcc -c -I. -I/usr/include/rpm -D_REENTRANT -D_GNU_SOURCE
    -DTHREADS_HAVE_PIDS -DDEBUGGING -fno-strict-aliasing -I/usr/local/include
    -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2
    -march=i386 -mcpu=i686 -g -DVERSION=\"0.40\" -DXS_VERSION=\"0.40\" -fPIC
    "-I/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE" RPM/Constants.c -o
    RPM/Constants.o
    Constants.xs: In function `constant':
    Constants.xs:19: `CHECKSIG_GPG' undeclared (first use in this function)
    Constants.xs:19: (Each undeclared identifier is reported only once
    Constants.xs:19: for each function it appears in.)
    Constants.xs:21: `CHECKSIG_MD5' undeclared (first use in this function)
    Constants.xs:23: `CHECKSIG_PGP' undeclared (first use in this function)
    Constants.xs:240: `RPMFILE_DONOTUSE' undeclared (first use in this function)
    Constants.xs:322: `RPMSIG_BAD' undeclared (first use in this function)
    Constants.xs:324: `RPMSIG_NOKEY' undeclared (first use in this function)
    Constants.xs:326: `RPMSIG_NOTTRUSTED' undeclared (first use in this
    function)
    Constants.xs:328: `RPMSIG_OK' undeclared (first use in this function)
    Constants.xs:330: `RPMSIG_UNKNOWN' undeclared (first use in this function)
    make: *** [RPM/Constants.o] Error 1


    That's all.

    What can I do ?

    Steve
    Steve Houle Guest

  2. #2

    Default Re: Problem installing Perl-RPM module on a RedHat 9.0

    That's where I download the source file.

    Ron Reidy wrote:
    > Build from the source (stable.tar.gz) from CPAN.
    >
    > Steve Houle wrote:
    >> Hi.
    >>
    >> I've got some trouble installing Perl-RPM-0.40.tar.gz on a RedHat
    >> 9.0.
    >> I previously install it on a RedHat 7.3 without any problem.
    >>
    >> When I do the "make"
    >> Here's the result.
    >>
    >> gcc -c -I. -I/usr/include/rpm -D_REENTRANT -D_GNU_SOURCE
    >> -DTHREADS_HAVE_PIDS -DDEBUGGING -fno-strict-aliasing -I/usr/local/include
    >> -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2
    >> -march=i386 -mcpu=i686 -g -DVERSION=\"0.40\" -DXS_VERSION=\"0.40\"
    >> -fPIC
    >> "-I/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE" RPM/Constants.c
    >> -o RPM/Constants.o
    >> Constants.xs: In function `constant':
    >> Constants.xs:19: `CHECKSIG_GPG' undeclared (first use in this function)
    >> Constants.xs:19: (Each undeclared identifier is reported only once
    >> Constants.xs:19: for each function it appears in.)
    >> Constants.xs:21: `CHECKSIG_MD5' undeclared (first use in this function)
    >> Constants.xs:23: `CHECKSIG_PGP' undeclared (first use in this function)
    >> Constants.xs:240: `RPMFILE_DONOTUSE' undeclared (first use in this
    >> function) Constants.xs:322: `RPMSIG_BAD' undeclared (first use in this
    >> function) Constants.xs:324: `RPMSIG_NOKEY' undeclared (first use in this
    >> function) Constants.xs:326: `RPMSIG_NOTTRUSTED' undeclared (first use in
    >> this function)
    >> Constants.xs:328: `RPMSIG_OK' undeclared (first use in this function)
    >> Constants.xs:330: `RPMSIG_UNKNOWN' undeclared (first use in this
    >> function) make: *** [RPM/Constants.o] Error 1
    >>
    >>
    >> That's all.
    >>
    >> What can I do ?
    >>
    >> Steve
    >
    >
    Steve Houle Guest

Similar Threads

  1. Installing DBD:Oracle module on Perl 5.8.4
    By szikria in forum PERL Modules
    Replies: 2
    Last Post: October 6th, 09:35 AM
  2. Installing DBI module for Perl 5.8.4
    By szikria in forum PERL Modules
    Replies: 2
    Last Post: October 5th, 06:01 PM
  3. Installing Perl InlineC module in Windows 2003
    By Sankaran in forum PERL Modules
    Replies: 1
    Last Post: August 14th, 09:06 AM
  4. Problem installing a perl module "File exists"
    By TheDD in forum PERL Modules
    Replies: 1
    Last Post: June 1st, 05:08 PM
  5. CGI.pm problem under Redhat Linux 9.0 (perl-5.8.0)
    By marmot101 in forum PERL Miscellaneous
    Replies: 5
    Last Post: July 28th, 11:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139