Professional Web Applications Themes

Problem with 3D acceleration - Ubuntu

Hi all, I have a problem with 3D acceleration. My card is an ATI Rage 128. Accordingly to all the doentation I could get, it should be supported without problems. This is not the case, but I don't know how to solve it, since the rage module is correctly loaded (after the X.log). Moreover, if I am not wrong, there is no driver from ATI for this card, so the only one I can use is the one which ships with ubuntu (I have 6.06). I am sure there is something wrong because I can compare with the old distribution ...

  1. #1

    Default Problem with 3D acceleration


    Hi all,

    I have a problem with 3D acceleration. My card is an ATI Rage 128.
    Accordingly to all the doentation I could get, it should be supported
    without problems. This is not the case, but I don't know how to solve it,
    since the rage module is correctly loaded (after the X.log). Moreover, if
    I am not wrong, there is no driver from ATI for this card, so the only one
    I can use is the one which ships with ubuntu (I have 6.06).

    I am sure there is something wrong because I can compare with the old
    distribution I still have on another partition (Mandriva LE 2005):
    tuxracer is horribly slow, which upsets a lot my little kids... :-((
    googleearth crashes and a lot of other problems...
    On mandriva, on the other hand, everything was parfect.


    I also compared the X configuration file with the old one and it looks the
    same, but for some minor changes.

    What can I do?

    Thanks for your attention

    Fabio
    Fabio Guest

  2. #2

    Default Re: Problem with 3D acceleration

    Fabio wrote:
     

    Works here.

    Relevant lines of /etc/X11/xorg.conf are these:
     

    and
     


    Running glxinfo shows this (again just the relevant lines):
     

    and
     





    EW Guest

  3. #3

    Default Re: Problem with 3D acceleration

    EW wrote:
     
    >
    > Works here.
    >
    > Relevant lines of /etc/X11/xorg.conf are these:

    >
    > and

    >
    >
    > Running glxinfo shows this (again just the relevant lines):

    >
    > and
    > [/ref]
    I have a similar situation with a Rage 128 card and Kubuntu: Very low
    acceleration. glxgears is glacially slow with Kubuntu, much faster with
    other distros on the same machine. Running glxinfo showed a difference in
    the output from yours. I have:
     [/ref]

    and
     [/ref]

    I suspect this may have some bearing on the matter, though I haven't yet run
    glxinfo on the other distros for comparison.

    On another note, all the other distros on my test machine (Debian testing,
    Mandriva 2006, SUSE 10.1, and Simply Mepis) use the correct video driver
    for that card, "r128", rather than "ati". I did try changing the driver to
    r128, but found it did not affect the acceleration problem. On to some
    more tests.....

    Al Preston
    Alastair Guest

  4. #4

    Default Re: Problem with 3D acceleration

    Alastair Preston wrote:
     [/ref][/ref]

    That tells the tale but is only the report, not the cause. Did
    your xorg.conf have
     [/ref]

    and
     [/ref]

    in it?
    EW Guest

  5. #5

    Default Re: Problem with 3D acceleration

    >> I have a problem with 3D acceleration. My card is an ATI Rage [/ref]
     

    Lucky guy!
     
    >
    > and

    >[/ref]

    Here are mine:

    Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "type1"
    Load "vbe"
    EndSection
    Section "Device"
    Identifier "ATI Technologies, Inc. Rage 128 PF/PRO AGP 4x TMDS"
    # Driver "ati"
    # BusID "PCI:1:0:0"
    VendorName "ATI"
    BoardName "ATI Rage 128"
    Driver "r128"
    Option "DPMS"
    Option "UseCCEFor2D" "true"
    EndSection
    Section "DRI"
    Mode 0666
    EndSection


    The commented line were from the original file, which didn't work either.
    The other lines are from the config file in mandriva-

     
    >
    > and
    > [/ref]

    As for glxinfo:

    name of display: :0.0
    display: :0 screen: 0
    direct rendering: Yes
    server glx vendor string: SGI
    server glx version string: 1.2
    ....
    OpenGL vendor string: VA Linux Systems, Inc.
    OpenGL renderer string: Mesa DRI Rage 128 Pro 20041026 AGP 1x
    OpenGL version string: 1.2 Mesa 6.4.1


    I can't see a lot of difference. What then?

    Thanks

    Fabio

    Fabio Guest

  6. #6

    Default Re: Problem with 3D acceleration

    Fabio wrote:
     [/ref]

    >
    > Lucky guy!

    >>
    >> and
    >> 
    >>[/ref]
    >
    > Here are mine:
    >
    > Section "Module"
    > Load "dbe" # Double-Buffering Extension
    > Load "bitmap"
    > Load "ddc"
    > Load "dri"
    > Load "extmod"
    > Load "freetype"
    > Load "glx"
    > Load "int10"
    > Load "type1"
    > Load "vbe"
    > EndSection
    > Section "Device"
    > Identifier "ATI Technologies, Inc. Rage 128 PF/PRO
    > AGP 4x TMDS"
    > # Driver "ati"
    > # BusID "PCI:1:0:0"
    > VendorName "ATI"
    > BoardName "ATI Rage 128"
    > Driver "r128"
    > Option "DPMS"
    > Option "UseCCEFor2D" "true"
    > EndSection
    > Section "DRI"
    > Mode 0666
    > EndSection
    >
    >
    > The commented line were from the original file, which didn't
    > work either. The other lines are from the config file in
    > mandriva-
    >

    >>
    >> and
    >> [/ref]
    >
    > As for glxinfo:
    >
    > name of display: :0.0
    > display: :0 screen: 0
    > direct rendering: Yes
    > server glx vendor string: SGI
    > server glx version string: 1.2
    > ...
    > OpenGL vendor string: VA Linux Systems, Inc.
    > OpenGL renderer string: Mesa DRI Rage 128 Pro 20041026 AGP 1x
    > OpenGL version string: 1.2 Mesa 6.4.1
    >
    >
    > I can't see a lot of difference. What then?
    >
    > Thanks
    >
    > Fabio[/ref]

    It looks like your 3D acceleration is working. There must be
    sonme other aspect of your system that is very slow.


    EW Guest

  7. #7

    Default Re: Problem with 3D acceleration

    EW wrote:
     [/ref]
    >
    > That tells the tale but is only the report, not the cause. Did
    > your xorg.conf have
    > [/ref][/ref]

    No. 

     [/ref][/ref]

    Yes. 

    Here's the relevant part of my Kubuntu xorg.conf:

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "extmod"
    Load "freetype"
    Load "int10"
    Load "type1"
    Load "vbe"
    load "glx"
    load "GLcore"
    load "v4l"
    EndSection

    Section "Device"
    identifier "ATI Technologies, Inc. Rage 128 RF/SG AGP"
    boardname "r128"
    busid "PCI:1:0:0"
    driver "r128"
    screen 0
    # option "MergedFB" "off"
    EndSection

    Adding in the line Load "dri" did turn direct rendering on and sped things
    up quite a bit, but I don't know how much, since for some reason, glxgears
    on Kubuntu does not report the frame rate as it does in every other distro
    on my machines. (most of the distros on my test machine run it at about
    374-377 fps, but one, Mepis, runs it at 704fps - I'd like to figure what's
    causing the difference) Oddly, this wasn't the first time I'd tried adding
    Load "dri" to the Module section. On a previous try, the screen got messed
    up, so I reverted to the previous version of xorg.conf.

    Al Preston

    Alastair Guest

Similar Threads

  1. HW acceleration : ATI x800 and Dapper
    By Hadron in forum Ubuntu
    Replies: 9
    Last Post: July 14th, 11:52 AM
  2. engine acceleration
    By Roofy in forum Macromedia Director 3D
    Replies: 3
    Last Post: June 23rd, 01:56 AM
  3. OpenGL acceleration
    By Jos Herni in forum Ubuntu
    Replies: 3
    Last Post: February 16th, 05:31 PM
  4. D70 supports Write Acceleration (WA) on Compact Flash?
    By Randy Howard in forum Photography
    Replies: 11
    Last Post: December 28th, 10:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139