Professional Web Applications Themes

Problem with sendmail and mx records - Linux Setup, Configuration & Administration

Hi, We are using redhat linux 9. We have configured sendmail. We are able to send mails but not receiving them. When we cheked the log we came to know that there is an error "unknown host", "My unqualified host name (mailserver) unknown; sleeping for retry". Log file has been pasted in this message. We are not finding where we r doing wrong. Please give us a solution. mailserver ipop3d[3189]: Logout user=faiyazm host=[192.168.1.51] nmsgs=0 ndele=0 Jan 8 20:33:46 mailserver sendmail[3187]: i08F3kY9003187: to=root, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=61360, dsn=2.0.0, stat=Sent Jan 8 20:33:46 mailserver sendmail[3187]: i08F3kY9003187: to=<faiyazmmspli>, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=61360, relay=mailserver.mspli., ...

  1. #1

    Default Problem with sendmail and mx records

    Hi,

    We are using redhat linux 9. We have configured sendmail. We are able
    to send mails but not receiving them. When we cheked the log we came
    to know that there is an error "unknown host", "My unqualified host
    name (mailserver) unknown; sleeping for retry". Log file has been
    pasted in this message. We are not finding where we r doing wrong.
    Please give us a solution.



    mailserver ipop3d[3189]: Logout user=faiyazm host=[192.168.1.51]
    nmsgs=0 ndele=0
    Jan 8 20:33:46 mailserver sendmail[3187]: i08F3kY9003187: to=root,
    delay=00:00:00, xdelay=00:00:00, mailer=local, pri=61360, dsn=2.0.0,
    stat=Sent
    Jan 8 20:33:46 mailserver sendmail[3187]: i08F3kY9003187:
    to=<faiyazmmspli>, delay=00:00:00, xdelay=00:00:00, mailer=esmtp,
    pri=61360, relay=mailserver.mspli., dsn=5.3.5, stat=Local
    configuration error
    Jan 8 20:33:46 mailserver sendmail[3187]: i08F3kY9003187:
    i08F3kYA003187: return to sender: Local configuration error
    Jan 8 20:33:46 mailserver sendmail[3187]: i08F3kYA003187: to=root,
    delay=00:00:00, xdelay=00:00:00, mailer=local, pri=32384, dsn=2.0.0,
    stat=Sent
    Jan 8 20:33:50 mailserver ipop3d[3192]: pop3 service init from
    192.168.1.51
    Jan 8 20:33:50 mailserver ipop3d[3192]: Login user=faiyazm
    host=[192.168.1.51] nmsgs=0/0
    Jan 8 20:33:50 mailserver ipop3d[3192]: Logout user=faiyazm
    host=[192.168.1.51] nmsgs=0 ndele=0
    Jan 8 20:35:26 mailserver sendmail[3196]: My unqualified host name
    (mailserver) unknown; sleeping for retry
    Jan 8 20:36:46 mailserver sendmail[3196]: unable to qualify my own
    domain name (mailserver) -- using short name


    Thanks in advance
    Fai
    Fai Guest

  2. #2

    Default Re: Problem with sendmail and mx records

    In comp.os.linux.admin Fai <com> wrote: 

    Give yourself a correct hostname, with a domain part. And list it in
    /etc/hosts.
     

    You are not looking at the message. It says (1) the hostname is
    without a domain part, (2) it can't resolve your hostname to an IP
    address anyway.

    You fix (1) by giving it a hostname with a domain part or by letting
    the "hostname" be an alias for a FQDN resolved through, say, /etc/hosts.
    Anyway, you have to fix (2) the resolution issue, so you might as well
    edit /etc/hosts.
     

    Hire somebody (more) competent.

    Peter
    P.T. Guest

  3. #3

    Default Re: Problem with sendmail and mx records

    "Fai" <com> wrote in message
    news:google.com 
    [...] 

    Solution: Your /etc/hosts file should be similar to (localhost should be
    exactly like):

    127.0.0.1 localhost.localdomain localhost
    192.168.0.222 mailserver.example.net mailserver



    --
    use hotmail for any email replies


    -----= Posted via Newsfeeds.Com, Uncensored Usenet News =-----
    http://www.newsfeeds.com - The #1 Newsgroup Service in the World!
    -----== Over 100,000 Newsgroups - 19 Different Servers! =-----
    ynotssor Guest

Similar Threads

  1. get local sendmail to use MX records
    By Gerard Meijer in forum FreeBSD
    Replies: 12
    Last Post: February 25th, 11:43 AM
  2. SendMail Problem
    By jim in forum PERL Miscellaneous
    Replies: 9
    Last Post: October 27th, 09:05 AM
  3. php <-> sendmail problem
    By in forum PHP Development
    Replies: 3
    Last Post: August 2nd, 12:19 PM
  4. rpm -i sendmail problem
    By Wenjie in forum Linux Setup, Configuration & Administration
    Replies: 5
    Last Post: July 29th, 12:35 AM
  5. Sendmail problem in AIX 4.3.3
    By subhasbothra in forum AIX
    Replies: 1
    Last Post: July 19th, 08:09 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139