Professional Web Applications Themes

Problem with templates - Macromedia Dreamweaver

Hi - I've been using Dreamweaver for 4 and a half years and I just recently started trying out using templates. I am having the worst time, I've created a template and applied it to all of my pages and specified an editable region but when I try to change/update the template it's not working. I've been through the tutorial online and I still don't get it. Could someone please take a look at my template and tell me what I'm doing wrong? Thanks so much! :) the site is: http://www.epitomegirl.com and the template is: http://www.epitomegirl.com/epitomegirl.dwt Referring URLs http://www.epitomegirl.com http://www.epitomegirl.com/epitomegirl.dwt...

  1. #1

    Default Problem with templates

    Hi - I've been using Dreamweaver for 4 and a half years and I just recently started trying out using templates. I am having the worst time, I've created a template and applied it to all of my pages and specified an editable region but when I try to change/update the template it's not working. I've been through the tutorial online and I still don't get it. Could someone please take a look at my template and tell me what I'm doing wrong? Thanks so much! :)

    the site is:
    http://www.epitomegirl.com
    and the template is:
    http://www.epitomegirl.com/epitomegirl.dwt



    Referring URLs
    http://www.epitomegirl.com
    http://www.epitomegirl.com/epitomegirl.dwt



    epitomegirl Guest

  2. #2

    Default Re: Problem with templates

    "epitomegirl" com wrote:
     
    Works for me. Is your .dwt in the Templates folder of your site folder.

    I presume you know it wont update an editable region created in your
    main template? Example trying to put a heading of "Welcome" in the
    editable "body" region of the original template is not going to update
    to any child pages created from it. "Welcome" would have to go in a
    non-editable region.

    osgood Guest

  3. #3

    Default Re: Problem with templates

    Yeah it's in the templates section - and I'm not trying to update an editable region. I really can't figure out what's going on :(



    epitomegirl Guest

  4. #4

    Default Re: Problem with templates

    epitome:

    So formulate a list of steps that will allow me to see exactly what is
    happening for you. Start with creating a new template page, please. I can
    help you if you do this.

    --
    Murray --- ICQ 71997575
    Team Macromedia Volunteer for Dreamweaver MX
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    news://forums.macromedia.com/macromedia.dreamweaver - THE BEST WAY TO GET
    ANSWERS
    ==================
    http://www.dreamweavermx-templates.com - Template Triage!
    http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
    http://www.DreamweaverFAQ.com - DW FAQs, Tutorials & Resources
    http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
    ==================

    "epitomegirl" <com> wrote in message
    news:bgttv6$rqv$macromedia.com... 
    editable region. I really can't figure out what's going on :( 


    Murray Guest

  5. #5

    Default Re: Problem with templates

    "epitomegirl" com wrote:
     
    What are you trying to put in your original template that you want
    updated on your child pages?

    osgood Guest

  6. #6

    Default Re: Problem with templates

    thanks for your help!! Basically what I am doing is -

    (1) I created the template and defined an editable region

    (2) I opened an already existing page and cut out the part I want to go in the editable region of the template

    (3) I then deleted all the formatting on the page and did Modify - Templates - Apply Template to Page

    (4) Then, in the editable region I had defined previously (called "body") I pasted the stuff from the doent that I want in there. (It was a table)

    (5) I am then saving these pages as regular html pages, and when I open them in Dreamweaver I can tell the parts that I defined as the non-editable regions are such, because when I move my mouse over that section (when I'm editing the doent) I get the circle with the line through it - the "no" symbol showing me I can't edit that region.

    (6) I then wanted to add something to my template (a link in the navigation) so I did so and saved and re-uploaded it to both the main part of the site and also to the Templates folder, but the changes I made didn't take.

    There is a concern I have - when I view the code + design the code appears highlighted yellow - at first I thought that meant it was just showing me non-editable code but now I'm worried that means there is an error in the code? I did get one error message at one point that said my <body> tags weren't done right but that mysteriously went away.

    Again - thanks SOOOOO much for your help - I'm really stumped :)

    carrie


    epitomegirl Guest

  7. #7

    Default Re: Problem with templates

    "epitomegirl" com wrote:
     
    No 3, why dont you go in DW> File>New from template>choose the template
    you created>paste in the information you cut from your doent. Save as
    blah_blah.html

    Open your original template from the sites template folder. Make the
    changes to your navigation links. Save. If you do this correctly your
    changes will propogate to the child page you made from selecting>File 

    Applying template is not the way to do it I think, Murray will confim
    this. He is the templates expert.

    osgood Guest

  8. #8

    Default Re: Problem with templates

    OK I think I've figured out one problem - I opened the existing template and the code looked ok - no yellow indicating errors. However when I go into the file I want to paste onto the editable region of the template and select the stuff I want to put in the editable region and select File -> New From Template and select the one that previously looked perfect I all of a sudden get yellow in my code - indicating errors :(

    carrie


    epitomegirl Guest

  9. #9

    Default Re: Problem with templates

    epitome:

    It's really not magic. Look at the code. What are the errors you see
    there?

    --
    Murray --- ICQ 71997575
    Team Macromedia Volunteer for Dreamweaver MX
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    news://forums.macromedia.com/macromedia.dreamweaver - THE BEST WAY TO GET
    ANSWERS
    ==================
    http://www.dreamweavermx-templates.com - Template Triage!
    http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
    http://www.DreamweaverFAQ.com - DW FAQs, Tutorials & Resources
    http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
    ==================

    "epitomegirl" <com> wrote in message
    news:bgubar$mq0$macromedia.com... 
    and the code looked ok - no yellow indicating errors. However when I go into
    the file I want to paste onto the editable region of the template and select
    the stuff I want to put in the editable region and select File -> New From
    Template and select the one that previously looked perfect I all of a sudden
    get yellow in my code - indicating errors :( 


    Murray Guest

Similar Threads

  1. Templates and Spry pathname problem
    By LP15 in forum Macromedia Dynamic HTML
    Replies: 3
    Last Post: January 3rd, 04:38 PM
  2. Templates Problem
    By Dark-Cloud in forum Macromedia Dreamweaver
    Replies: 3
    Last Post: August 2nd, 12:44 PM
  3. Problem with behaviour in templates
    By cyberdao in forum Macromedia Dreamweaver
    Replies: 2
    Last Post: July 21st, 10:47 PM
  4. problem with templates..
    By remarkble in forum Adobe Photoshop 7, CS, CS2 & CS3
    Replies: 0
    Last Post: July 13th, 01:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139