Installing debian is giving me trouble on a Dell OptiPlex GXa (which has
previously run RH 6.2, 7.x and 8.0). I can't seem to install (or load
after installation) the kernel module for one of my ethernet interfaces.

Before I started the debian install, I booted from a knoppix CD; here
are the lines for the network interfaces when I ran lsmod:

module size used by not tainted
3c59x 25808 0
eepro100 19438 0
mii 2128 0 [eepro100]

The 3c590 is an integrated (on mobo) device, and the eepro100 is a pci card.

No matter what options I select for the 3c59x module, the debian
installer pops back with a failure message, claiming it cannot load the
module because of unresolved symbol 'debug'... whatever that means.

If I continue installation without selecting any modules, I am unable to
use either adapter - they do not autoload at bootup. So, on my second
try I selected the eepro100 module and installed it. This worked: the
eth0 interface was instantly recognized during reboot. However, running
ifconfig after logging in revealed that the working interface is
actually eth1... very strange.

After logging in I am still unable to load the 3c59x module; the error
message is as follows:

Using /lib/modules/2.2.20-idepci/net/3c59x.o
Warning: /lib/modules/2.2.20-idepci/net/3c59x.o symbol for parameter
debug not found
3c59x.c:v0.99V 1/28/2002 Donald Becker, [email]beckerscyld.com[/email]
[url]http://www.scyld.com/network/vortex.html[/url]
/lib/modules/2.2.20-idepci/net/3c59x.o: init_module: Device or
resource busy
Hint: insmod errors can be caused by incorrect module parameters,
including invalid IO or IRQ parameters

Sorry for the longish post, but this is truly puzzling; I find that in
cases like this more info is better. Thanks in advance for any advice!

jb