Professional Web Applications Themes

<processModel> - ASP.NET General

Hi, all. I was recently told about changing the <processModel> tag in the machine.config to allow the ASP.NET worker process to run as a system user. It was supposed to clear up a problem I was having. I didn't want to do this on a production server due to the security risks involved, but I did test the theory on my local development machine. The problem went away, as promised. However, I am now stuck with that change. I reverted the <processModel> userName attribute back to "machine". I restarted IIS. Yet, ASP.NET still runs as a system user. I can ...

  1. #1

    Default <processModel>

    Hi, all. I was recently told about changing the <processModel> tag in the
    machine.config to allow the ASP.NET worker process to run as a system user.
    It was supposed to clear up a problem I was having. I didn't want to do this
    on a production server due to the security risks involved, but I did test
    the theory on my local development machine. The problem went away, as
    promised. However, I am now stuck with that change.

    I reverted the <processModel> userName attribute back to "machine". I
    restarted IIS. Yet, ASP.NET still runs as a system user. I can even write to
    a file on the root of the C-drive from a web page. I've rebooted the
    computer as well. Still, my web apps have full priviledges.

    Can anyone tell me how I can revert my computer back to using the machine
    (ASPNET) user account, as it once did?

    Thank you in advance.

    --
    Matt Sollars
    net
    -------------------
    The Hypersite Network
    2002 N. Salisbury Blvd.
    Suite C
    Salisbury, Maryland 21801
    T: 410.749.2000
    F: 410.219.3400
    http://www.hypersite.net


    Matt Guest

  2. #2

    Default Re: <processModel>

    You may need to kill off the aspnet_wp process, which is independent of IIS,
    in order to get the changes to "take."

    --
    Chris Jackson
    Software Engineer
    Microsoft MVP - Windows XP
    Windows XP Associate Expert
    --
    "Matt Sollars" <net> wrote in message
    news:%phx.gbl... 
    user. 
    this 
    to 


    Chris Guest

  3. #3

    Default Re: <processModel>

    Hi, Chris:

    Thanks for the reply.

    Shouldn't rebooting the computer (several times) take care of that?

    Matt

    "Chris Jackson" <org> wrote in message
    news:phx.gbl...
    You may need to kill off the aspnet_wp process, which is independent of IIS,
    in order to get the changes to "take."

    --
    Chris Jackson
    Software Engineer
    Microsoft MVP - Windows XP
    Windows XP Associate Expert
    --


    Matt Guest

  4. #4

    Default Re: <processModel>

    Are you sure you are modifying the correct machine.config ??
    YES: If you have two frameworks 1.0 and 1.1 then each framework will have
    its own machine.config.
    check that out
    is it cached?
    doublicate your machine.config and name the old one machine.config
    rename the Copy of machine.config to machine.config
    what happens??


    "Matt Sollars" <net> wrote in message
    news:phx.gbl... 
    IIS, 


    MS Guest

  5. #5

    Default Re: <processModel>

    I've seen people mistake the syntax comments about processModel for the actual
    node. Not saying you changed it back in the wrong place, but it might be worth
    a check. Also, if you're running .Net 1.0 and 1.1 you'll want to be sure you
    dealing with the correct machine.config each time.


    --
    Microsoft MVPs have a question for *you*: Are you patched against the Worm?
    http://www.microsoft.com/security/security_bulletins/ms03-026.asp



    "Matt Sollars" <net> wrote in message
    news:%phx.gbl...
    Hi, all. I was recently told about changing the <processModel> tag in the
    machine.config to allow the ASP.NET worker process to run as a system user.
    It was supposed to clear up a problem I was having. I didn't want to do this
    on a production server due to the security risks involved, but I did test
    the theory on my local development machine. The problem went away, as
    promised. However, I am now stuck with that change.

    I reverted the <processModel> userName attribute back to "machine". I
    restarted IIS. Yet, ASP.NET still runs as a system user. I can even write to
    a file on the root of the C-drive from a web page. I've rebooted the
    computer as well. Still, my web apps have full priviledges.

    Can anyone tell me how I can revert my computer back to using the machine
    (ASPNET) user account, as it once did?

    Thank you in advance.

    --
    Matt Sollars
    net
    -------------------
    The Hypersite Network
    2002 N. Salisbury Blvd.
    Suite C
    Salisbury, Maryland 21801
    T: 410.749.2000
    F: 410.219.3400
    http://www.hypersite.net



    Ken Guest

Similar Threads

  1. Machine.Config -- ProcessModel vs Impersonation
    By Wm. Scott Miller in forum ASP.NET Security
    Replies: 1
    Last Post: May 26th, 07:20 AM
  2. <processModel>: Impersonation...?
    By TM in forum ASP.NET Security
    Replies: 1
    Last Post: May 18th, 12:46 AM
  3. machine.config <processModel> setting question
    By Tim in forum ASP.NET Security
    Replies: 0
    Last Post: February 6th, 07:01 PM
  4. Replies: 2
    Last Post: September 11th, 06:05 AM
  5. ProcessModel and Identity
    By Calvin in forum ASP.NET Security
    Replies: 0
    Last Post: August 19th, 10:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139