Professional Web Applications Themes

proxy account for sqlagent setup - Microsoft SQL / MS SQL Server

Hi all, I have an mssql server and sqlserver agent running with a local administrator id 'GCBAPU427\sqlrep01' instead of local system account. The id is not a domain id. It is only avaiable in the server. I try executing the below command EXEC master.dbo.xp_sqlagent_proxy_account N'SET', N'GCBAPU427', -- agent_domain_name N'sqlrep01', -- agent_username N'pwd' I get the below error, "Error executing extended stored procedure: Specified user can not login" The id has, Act as part of the Operating System. Increase Quotas. Replace a process level token. Log on as a batch job. policy permissions at the server level. ...

  1. #1

    Default proxy account for sqlagent setup

    Hi all, I have an mssql server and sqlserver agent running
    with a local administrator id 'GCBAPU427\sqlrep01' instead
    of local system account. The id is not a domain id. It is
    only avaiable in the server.

    I try executing the below command

    EXEC master.dbo.xp_sqlagent_proxy_account N'SET',
    N'GCBAPU427', -- agent_domain_name
    N'sqlrep01', -- agent_username
    N'pwd'

    I get the below error,
    "Error executing extended stored procedure: Specified user
    can not login"

    The id has,

    Act as part of the Operating System.
    Increase Quotas.
    Replace a process level token.
    Log on as a batch job.
    policy permissions at the server level.

    I am doing this because, I want my sql jobs to be run with
    an internal proxy account... Pls help

    ramakrishnan bharadhwaj Guest

  2. #2

    Default proxy account for sqlagent setup

    I think what you're missing here "Log on as a Service"
    rights for that account..

    Regards,
    Greg Linwood
    SQL Server MVP
    >-----Original Message-----
    >Hi all, I have an mssql server and sqlserver agent
    running
    >with a local administrator id 'GCBAPU427\sqlrep01'
    instead
    >of local system account. The id is not a domain id. It is
    >only avaiable in the server.
    >
    >I try executing the below command
    >
    >EXEC master.dbo.xp_sqlagent_proxy_account N'SET',
    > N'GCBAPU427', -- agent_domain_name
    > N'sqlrep01', -- agent_username
    > N'pwd'
    >
    >I get the below error,
    >"Error executing extended stored procedure: Specified
    user
    >can not login"
    >
    >The id has,
    >
    > Act as part of the Operating System.
    > Increase Quotas.
    > Replace a process level token.
    > Log on as a batch job.
    >policy permissions at the server level.
    >
    >I am doing this because, I want my sql jobs to be run
    with
    >an internal proxy account... Pls help
    >
    >.
    >
    Greg Linwood Guest

  3. #3

    Default proxy account for sqlagent setup

    hi greg,
    it is needed because, there are 2 servers which are
    participating in tion and if that is the case - u
    need to have this policy set for the id.
    >-----Original Message-----
    >Maybe there's a little mis-understanding here.. Your
    first
    >post said:
    >
    >The id has,
    > Act as part of the Operating System.
    > Increase Quotas.
    > Replace a process level token.
    > Log on as a batch job.
    >
    >What I'm saying is that the id should have "Log on as a
    >Service", not "Log on as a batch job.". I could be wrong,
    >but I think that "Log on as a batch job" serves no
    purpose.
    >
    >Regards,
    >Greg Linwood
    >SQL Server MVP
    >
    >>-----Original Message-----
    >>Hi Greg,
    >>
    >>Iam not missing the rights, because windows2000 assigns
    >>the rights when u start sqlserver agent and sql server
    >>with the windows admin id. So, I can confirm that this
    is
    >>not mssing. the sqlserver service and agent start
    >>properly. Only when, I try to configure, job proxy, i
    >have
    >>this problem...
    >>>-----Original Message-----
    >>>I think what you're missing here "Log on as a Service"
    >>>rights for that account..
    >>>
    >>>Regards,
    >>>Greg Linwood
    >>>SQL Server MVP
    >>>
    >>>>-----Original Message-----
    >>>>Hi all, I have an mssql server and sqlserver agent
    >>>running
    >>>>with a local administrator id 'GCBAPU427\sqlrep01'
    >>>instead
    >>>>of local system account. The id is not a domain id. It
    >>is
    >>>>only avaiable in the server.
    >>>>
    >>>>I try executing the below command
    >>>>
    >>>>EXEC master.dbo.xp_sqlagent_proxy_account N'SET',
    >>>> N'GCBAPU427', -- agent_domain_name
    >>>> N'sqlrep01', -- agent_username
    >>>> N'pwd'
    >>>>
    >>>>I get the below error,
    >>>>"Error executing extended stored procedure: Specified
    >>>user
    >>>>can not login"
    >>>>
    >>>>The id has,
    >>>>
    >>>> Act as part of the Operating System.
    >>>> Increase Quotas.
    >>>> Replace a process level token.
    >>>> Log on as a batch job.
    >>>>policy permissions at the server level.
    >>>>
    >>>>I am doing this because, I want my sql jobs to be run
    >>>with
    >>>>an internal proxy account... Pls help
    >>>>
    >>>>.
    >>>>
    >>>.
    >>>
    >>.
    >>
    >.
    >
    ramakrishnan bharadhwaj Guest

  4. #4

    Default proxy account for sqlagent setup

    ok - I'll opt out of this one as I don't think I can add
    much more.

    Regards,
    Greg Linwood
    SQL Server MVP
    >-----Original Message-----
    >hi greg,
    >it is needed because, there are 2 servers which are
    >participating in tion and if that is the case - u
    >need to have this policy set for the id.
    >>-----Original Message-----
    >>Maybe there's a little mis-understanding here.. Your
    >first
    >>post said:
    >>
    >>The id has,
    >> Act as part of the Operating System.
    >> Increase Quotas.
    >> Replace a process level token.
    >> Log on as a batch job.
    >>
    >>What I'm saying is that the id should have "Log on as a
    >>Service", not "Log on as a batch job.". I could be
    wrong,
    >>but I think that "Log on as a batch job" serves no
    >purpose.
    >>
    >>Regards,
    >>Greg Linwood
    >>SQL Server MVP
    >>
    >>>-----Original Message-----
    >>>Hi Greg,
    >>>
    >>>Iam not missing the rights, because windows2000 assigns
    >>>the rights when u start sqlserver agent and sql server
    >>>with the windows admin id. So, I can confirm that this
    >is
    >>>not mssing. the sqlserver service and agent start
    >>>properly. Only when, I try to configure, job proxy, i
    >>have
    >>>this problem...
    >>>>-----Original Message-----
    >>>>I think what you're missing here "Log on as a Service"
    >>>>rights for that account..
    >>>>
    >>>>Regards,
    >>>>Greg Linwood
    >>>>SQL Server MVP
    >>>>
    >>>>>-----Original Message-----
    >>>>>Hi all, I have an mssql server and sqlserver agent
    >>>>running
    >>>>>with a local administrator id 'GCBAPU427\sqlrep01'
    >>>>instead
    >>>>>of local system account. The id is not a domain id.
    It
    >>>is
    >>>>>only avaiable in the server.
    >>>>>
    >>>>>I try executing the below command
    >>>>>
    >>>>>EXEC master.dbo.xp_sqlagent_proxy_account N'SET',
    >>>>> N'GCBAPU427', -- agent_domain_name
    >>>>> N'sqlrep01', -- agent_username
    >>>>> N'pwd'
    >>>>>
    >>>>>I get the below error,
    >>>>>"Error executing extended stored procedure: Specified
    >>>>user
    >>>>>can not login"
    >>>>>
    >>>>>The id has,
    >>>>>
    >>>>> Act as part of the Operating System.
    >>>>> Increase Quotas.
    >>>>> Replace a process level token.
    >>>>> Log on as a batch job.
    >>>>>policy permissions at the server level.
    >>>>>
    >>>>>I am doing this because, I want my sql jobs to be run
    >>>>with
    >>>>>an internal proxy account... Pls help
    >>>>>
    >>>>>.
    >>>>>
    >>>>.
    >>>>
    >>>.
    >>>
    >>.
    >>
    >.
    >
    Greg Linwood Guest

  5. #5

    Default Re: proxy account for sqlagent setup

    The message returned by xp_sqlagent_proxy_account is generic so you need
    to check the Windows security event log for a related message with more
    information. The service account does not have the necessary
    permissions to switch security context or there is a problem with the
    specified proxy account (e.g. invalid password).

    Note that the service accounts are assigned the necessary user rights
    when specified during installation or when changed via Enterprise
    Manager. These rights are not assigned when the service account is
    changed via SCM.

    --
    Hope this helps.

    Dan Guzman
    SQL Server MVP

    -----------------------
    SQL FAQ links (courtesy Neil Pike):

    [url]http://www.ntfaq.com/Articles/Index.cfm?DepartmentID=800[/url]
    [url]http://www.sqlserverfaq.com[/url]
    [url]http://www.mssqlserver.com/faq[/url]
    -----------------------

    "ramakrishnan bharadhwaj" <ramakrishnan.bharadhwajcitigroup.com> wrote
    in message news:0a1301c34516$0f7615e0$a301280aphx.gbl...
    Hi all, I have an mssql server and sqlserver agent running
    with a local administrator id 'GCBAPU427\sqlrep01' instead
    of local system account. The id is not a domain id. It is
    only avaiable in the server.

    I try executing the below command

    EXEC master.dbo.xp_sqlagent_proxy_account N'SET',
    N'GCBAPU427', -- agent_domain_name
    N'sqlrep01', -- agent_username
    N'pwd'

    I get the below error,
    "Error executing extended stored procedure: Specified user
    can not login"

    The id has,

    Act as part of the Operating System.
    Increase Quotas.
    Replace a process level token.
    Log on as a batch job.
    policy permissions at the server level.

    I am doing this because, I want my sql jobs to be run with
    an internal proxy account... Pls help


    Dan Guzman Guest

  6. #6

    Default Re: proxy account for sqlagent setup

    Hi Dan,

    The windows id is an id with admin rights. What special
    rights are needed for changing security contexts? Also,
    the password cannot be wrong because, I successfully start
    sqlagent and sqlserver with that id!

    looking forward for more comments
    >-----Original Message-----
    >The message returned by xp_sqlagent_proxy_account is
    generic so you need
    >to check the Windows security event log for a related
    message with more
    >information. The service account does not have the
    necessary
    >permissions to switch security context or there is a
    problem with the
    >specified proxy account (e.g. invalid password).
    >
    >Note that the service accounts are assigned the necessary
    user rights
    >when specified during installation or when changed via
    Enterprise
    >Manager. These rights are not assigned when the service
    account is
    >changed via SCM.
    >
    >--
    >Hope this helps.
    >
    >Dan Guzman
    >SQL Server MVP
    >
    >-----------------------
    >SQL FAQ links (courtesy Neil Pike):
    >
    >[url]http://www.ntfaq.com/Articles/Index.cfm?DepartmentID=800[/url]
    >[url]http://www.sqlserverfaq.com[/url]
    >[url]http://www.mssqlserver.com/faq[/url]
    >-----------------------
    >
    >"ramakrishnan bharadhwaj"
    <ramakrishnan.bharadhwajcitigroup.com> wrote
    >in message news:0a1301c34516$0f7615e0$a301280aphx.gbl...
    >Hi all, I have an mssql server and sqlserver agent running
    >with a local administrator id 'GCBAPU427\sqlrep01' instead
    >of local system account. The id is not a domain id. It is
    >only avaiable in the server.
    >
    >I try executing the below command
    >
    >EXEC master.dbo.xp_sqlagent_proxy_account N'SET',
    > N'GCBAPU427', -- agent_domain_name
    > N'sqlrep01', -- agent_username
    > N'pwd'
    >
    >I get the below error,
    >"Error executing extended stored procedure: Specified user
    >can not login"
    >
    >The id has,
    >
    > Act as part of the Operating System.
    > Increase Quotas.
    > Replace a process level token.
    > Log on as a batch job.
    >policy permissions at the server level.
    >
    >I am doing this because, I want my sql jobs to be run with
    >an internal proxy account... Pls help
    >
    >
    >.
    >
    bharadhwaj Ramakrishnan Guest

  7. #7

    Default Re: proxy account for sqlagent setup

    Admin rights alone is not sufficient. Additional rights need to be
    granted to the service account in order to run processes under the proxy
    account security context. These are described in the Books Online
    <instsql.chm::/in_overview_6k1f.htm>. As I mentioned earlier, the
    easiest way to grant these is by changing the service accounts with
    Enterprise Manager.

    --
    Hope this helps.

    Dan Guzman
    SQL Server MVP


    "bharadhwaj Ramakrishnan" <ramakrishnan.bharadhwajcitigroup.com> wrote
    in message news:019001c345dd$c5a3ef50$a001280aphx.gbl...
    Hi Dan,

    The windows id is an id with admin rights. What special
    rights are needed for changing security contexts? Also,
    the password cannot be wrong because, I successfully start
    sqlagent and sqlserver with that id!

    looking forward for more comments
    >-----Original Message-----
    >The message returned by xp_sqlagent_proxy_account is
    generic so you need
    >to check the Windows security event log for a related
    message with more
    >information. The service account does not have the
    necessary
    >permissions to switch security context or there is a
    problem with the
    >specified proxy account (e.g. invalid password).
    >
    >Note that the service accounts are assigned the necessary
    user rights
    >when specified during installation or when changed via
    Enterprise
    >Manager. These rights are not assigned when the service
    account is
    >changed via SCM.
    >
    >--
    >Hope this helps.
    >
    >Dan Guzman
    >SQL Server MVP
    >
    >-----------------------
    >SQL FAQ links (courtesy Neil Pike):
    >
    >[url]http://www.ntfaq.com/Articles/Index.cfm?DepartmentID=800[/url]
    >[url]http://www.sqlserverfaq.com[/url]
    >[url]http://www.mssqlserver.com/faq[/url]
    >-----------------------
    >
    >"ramakrishnan bharadhwaj"
    <ramakrishnan.bharadhwajcitigroup.com> wrote
    >in message news:0a1301c34516$0f7615e0$a301280aphx.gbl...
    >Hi all, I have an mssql server and sqlserver agent running
    >with a local administrator id 'GCBAPU427\sqlrep01' instead
    >of local system account. The id is not a domain id. It is
    >only avaiable in the server.
    >
    >I try executing the below command
    >
    >EXEC master.dbo.xp_sqlagent_proxy_account N'SET',
    > N'GCBAPU427', -- agent_domain_name
    > N'sqlrep01', -- agent_username
    > N'pwd'
    >
    >I get the below error,
    >"Error executing extended stored procedure: Specified user
    >can not login"
    >
    >The id has,
    >
    > Act as part of the Operating System.
    > Increase Quotas.
    > Replace a process level token.
    > Log on as a batch job.
    >policy permissions at the server level.
    >
    >I am doing this because, I want my sql jobs to be run with
    >an internal proxy account... Pls help
    >
    >
    >.
    >

    Dan Guzman Guest

Similar Threads

  1. Flash in XP Admin Account not Limited Account
    By Graeb in forum Macromedia Flash Player
    Replies: 1
    Last Post: April 10th, 09:56 PM
  2. Replies: 0
    Last Post: August 31st, 04:57 PM
  3. Replies: 6
    Last Post: March 16th, 05:00 PM
  4. Page setup/paper setup
    By Opaliski in forum Macromedia Freehand
    Replies: 0
    Last Post: February 16th, 05:51 PM
  5. proxy account setting.. pls help
    By bharath in forum Microsoft SQL / MS SQL Server
    Replies: 0
    Last Post: July 6th, 09:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139