Professional Web Applications Themes

PureFTPd, OSX 10.2.8 - Mac Networking

Hi! First, I went to the System Preferences, Sharing, and clicked the little boxthat is supposed to make FTP access to your computer work. No luck. So I got PureFTPd Manager from http://jeanmatthieu.free.fr/pureftpd/ and installed that. Now I get [almos-computer:~] almo% ftp 192.168.1.50 Connected to 192.168.1.50. 421 Service not available, remote server has closed connection. ftp> Any ideas? I've been hunting for a solution to this for days now. :( -- Almo! Hard Core Game Design...

  1. #1

    Default PureFTPd, OSX 10.2.8

    Hi!

    First, I went to the System Preferences, Sharing, and clicked the little
    boxthat is supposed to make FTP access to your computer work. No luck.

    So I got PureFTPd Manager from http://jeanmatthieu.free.fr/pureftpd/ and
    installed that.

    Now I get

    [almos-computer:~] almo% ftp 192.168.1.50
    Connected to 192.168.1.50.
    421 Service not available, remote server has closed connection.
    ftp>


    Any ideas? I've been hunting for a solution to this for days now. :(

    --
    Almo!
    Hard Core Game Design
    Almo Guest

  2. #2

    Default Re: PureFTPd, OSX 10.2.8

    On 2004-06-05, Almo <com> wrote: 

    If you really need ftp, I suggest you try this again. Unless either
    your system is ed up in some way or you're running third-party
    firewall software, this should work. In the second case, the
    firewall is getting in your way and you'll have to reconfigure it to
    allow ftp.

    But why not use sftp? It's more secure and you get it for free when
    you enable "Remote Login" (ie ssh).




    noman Guest

  3. #3

    Default Re: PureFTPd, OSX 10.2.8

    Almo wrote:
     

    It could be blocked by your router firewall.
    George Guest

  4. #4

    Default Re: PureFTPd, OSX 10.2.8

    In article <com>, com wrote:
     
    >
    > It could be blocked by your router firewall.[/ref]

    I'm doing the

    ftp 192.168.1.50

    from a terminal on the mac with the server on it. That shouldn't go
    through the router, right?

    --
    Almo!
    Hard Core Game Design
    Almo Guest

  5. #5

    Default Re: PureFTPd, OSX 10.2.8

    Almo wrote:
     

    Right. If you don't have any software firewall, don't have
    Paranoid Android, don't have DefaultApp removing helper apps,
    don't have the security update 06/07/04 installed ....
    and you have repaired permissions, then it's a mystery.
    George Guest

  6. #6

    Default Re: PureFTPd, OSX 10.2.8

    On 2004-06-08, George Williams <com> wrote: 

    The last three are irrelevant, and firewalling should be irrelevant if
    the source and destination host are the same.

    The OP reported originally that enabling the ftp server through the
    System Preference doesn't work for him. Since it works fine for
    everyone else, I have to believe his system is misconfigured in some
    significant way. Without more information, there isn't much more to
    say than that. Introducing a different ftp server is very unlikely to
    make any difference.

    OP, you really have to describe your system more thoroughly,
    particularly the networking and firewall configuration.


    noman Guest

  7. #7

    Default Re: PureFTPd, OSX 10.2.8

    In article <com>, com wrote:
     
    >
    > Right. If you don't have any software firewall, don't have
    > Paranoid Android, don't have DefaultApp removing helper apps,
    > don't have the security update 06/07/04 installed ....
    > and you have repaired permissions, then it's a mystery.[/ref]

    Okay, no firewall, no PA, no DA that i'm aware of, and I repaired the
    permissions.

    I do have that security update though...

    But I tried setting PureFTPd to use standalone mode instead of OSX
    SuperServer. Now I get this:

    220---------- Welcome to Pure-FTPd [TLS] ----------
    220-You are user number 1 of 5 allowed.
    220-Local time is now 22:13. Server port: 21.
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    Name (192.168.1.50:almo):
    331 User almo OK. Password required
    Password:
    421 Unable to read the indexed puredb file (or old format detected) - Try
    pure-pw mkdb
    ftp: Login failed.

    --
    Almo!
    Hard Core Game Design
    Almo Guest

  8. #8

    Default Re: PureFTPd, OSX 10.2.8

    In article <de>, noman <net> wrote:
     

    Okay, as I'm relatively new to OSX, what information about my system would
    help you out?

    --
    Almo!
    Hard Core Game Design
    Almo Guest

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139