Professional Web Applications Themes

Radeon 7500 and AOC 17Klr monitor *almost* works... - Linux Setup, Configuration & Administration

I've got a dual boot system with a Radeon 7500 and AOC 7Klr monitor which works fine under XP. When I dual boot to Fedora (or even during the Fedora install process), the screen is very washed out, almost as if the brightness was too high and the contrast too low. Booting back to Windows without touching the monitor controls gives a great picture however. I installed Fedora using an IBM 2237 monitor and the picture was great during install and subsequent boot. Fedora does not know about the AOC 7Klr so I found the refresh rate settings on the ...

  1. #1

    Default Radeon 7500 and AOC 17Klr monitor *almost* works...

    I've got a dual boot system with a Radeon 7500 and AOC 7Klr monitor which
    works fine under XP. When I dual boot to Fedora (or even during the
    Fedora install process), the screen is very washed out, almost as if the
    brightness was too high and the contrast too low. Booting back to Windows
    without touching the monitor controls gives a great picture however.

    I installed Fedora using an IBM 2237 monitor and the picture was great
    during install and subsequent boot. Fedora does not know about the AOC
    7Klr so I found the refresh rate settings on the AOC web site and plugged
    them into MonitorsDB so I could select the monitor using
    redhat-config-xfree86 - didn't change a thing, still all washed out.

    Given that the IBM monitor works fine, I doubt that the Radeon 7500 is the
    culprit. That leaves the AOC 7Klr - however it works fine under Windows.

    Has anybody seen this sort of behavior? It's almost barely usable if I
    play with the monitor brightness/contrast (but still quite annoying). Of
    course, when I reboot to XP, I have to fiddle with the controls again to
    get the picture looking ok again.

    Any suggestions are welcome. I've done a ton of Linux installs but this
    is the first time I've seen this one.

    Thanks,

    Curtis
    Curtis Guest

  2. #2

    Default Re: Radeon 7500 and AOC 17Klr monitor *almost* works...

    Curtis Rempel wrote: 

    Backup your /etc/X11/XF86Config.

    Run /usr/X11R6/bin/xf86config, mainly to set your refresh rates low.
    Ignore most options (almost random entries) but when you get to
    selecting your monitor's rates, use the ones with the smallest ranges.

    Copy the new settings in the "Monitor" section to the backup. Restore
    backup.

    Run startx.


    Tell us what happens,
    --
    Ben M.

    ----------------
    What are Software Patents for?
    To protect the small enterprise from bigger companies.

    What do Software Patents do?
    In its current form, they protect only companies with
    big legal departments as they:
    a.) Patent everything no matter how general
    b.) Sue everybody. Even if the patent can be argued
    invalid, small companies can ill-afford the
    typical $500k cost of a law-suit (not to mention
    years of harassment).

    Don't let them take away your right to program
    whatever you like. Make a stand on Software Patents
    before its too late.

    Read about the ongoing battle at http://swpat.ffii.org/
    ----------------

    Ben Guest

  3. #3

    Default Re: Radeon 7500 and AOC 17Klr monitor *almost* works...

    On Fri, 30 Jan 2004 02:58:09 +0000, Ben Measures wrote:

    [snip]
     

    Apparently not much :-(

    I still get a washed out look on the screen. Very strange.
    Curtis Guest

  4. #4

    Default Re: Radeon 7500 and AOC 17Klr monitor *almost* works...

    Curtis Rempel wrote: 

    [snip]
     

    You might consider playing with the "Gamma" settings in your XF86Config
    file. 'man 5 xf86config' for detailed info, although I think adding
    "Gamma 0.5" to the "Monitor" section would be a good start.
    John-Paul Guest

Similar Threads

  1. HELP! Radeon 7500, emachines 17" and ATI Radeon 7500
    By Greg in forum Linux Setup, Configuration & Administration
    Replies: 3
    Last Post: October 12th, 10:34 PM
  2. 7500/OS 8.6 boot problems
    By D. in forum Mac Applications & Software
    Replies: 4
    Last Post: September 29th, 05:36 PM
  3. radeon 7500
    By jaroslaw_psikuta in forum Debian
    Replies: 0
    Last Post: July 7th, 02:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139