Professional Web Applications Themes

readhat can not login with root - Linux Setup, Configuration & Administration

I have installed RetHat Linux 9.0 on my Dell machine. I enabled the kerberos authentication module for enabling ftp server on my machine. Suddenly I can not login to sytem anymore. I can do a telnet with normal user but not with root admin. Anybody have idea how to disable this kerberos thing ?...

  1. #1

    Default readhat can not login with root

    I have installed RetHat Linux 9.0 on my Dell machine. I enabled the
    kerberos authentication module for enabling ftp server on my machine.

    Suddenly I can not login to sytem anymore. I can do a telnet with
    normal user but not with root admin.

    Anybody have idea how to disable this kerberos thing ?
    Abhijeet Guest

  2. #2

    Default Re: readhat can not login with root

    On 30 Oct 2003 22:37:20 -0800,
    Abhijeet <att.ne.jp> wrote: 

    su -

    and disable.

    Michael C.
    --
    com http://mcsuper5.freeshell.org/
    Registered Linux User #303915 http://counter.li.org/


    Michael Guest

  3. #3

    Default Re: readhat can not login with root

    On 30 Oct 2003 22:37:20 -0800, Abhijeet
    <att.ne.jp> wrote: 
    You shouldn't login as root. Use su or sudo.
     


    --
    You can go anywhere you want if you look serious and carry a clipboard.
    Bill Guest

  4. #4

    Default Re: readhat can not login with root


    "Abhijeet" <att.ne.jp> wrote in message
    news:google.com... 

    Well, given that you're running telnetd, you're already at a serious risk of
    having passwords stolen. You should be using OpenSSH, not telnet.

    Also, the network tty's can be configured to allow or disallow root logins
    with the "/etc/securetty" file. Perhaps your Kerberos installation tweaked
    that?

    In general, unless you *need* to use Kerberos, don't install it. The FTP
    client is broken, it's extremely complex to administer, it's a pretty big
    codebase, and for most users they're far better off with a simpler
    end-to-end encryption setup such as SSH. In big honking environments where
    centralized authentication is a big deal, such as a 20,000 user AFS
    home-directory system such as is used at MIT, Kerberos is appropriate. But
    any software that refuses to compile if you have you un-qualified as opposed
    to fully-qualified hostname first in /etc/hosts is, frankly, y.


    Nico Guest

  5. #5

    Default Re: readhat can not login with root

    Nico Kadel-Garcia <net> wrote: 

    Actually, that almost makes me like it :-).

    The first name on the line is the "canonical name". The process of
    resolution for your own domain goes by looking up the hostname to
    get the IP address, then looking up the IP address to get the canonical
    name, from which the domain name is taken as the trailing part.

    man resolver

    The res_ninit() / res_init() routine reads the configuration
    file (if any; see resolver(5)) to get the default domain
    name, search list and the Internet address of the local name
    server(s). If no server is con figured, the host running
    the resolver is tried. The current domain name is defined
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    by the hostname if not specified in the configuration file;
    ^^^^^^^^^^^^^^^^^
    it can be overridden by the environment variable
    LOCALDOMAIN. This environ ment variable may contain
    several blank-separated tokens if you wish to override the
    ``search list'' on a per-processserver address(es).

    man hostname

    You can't change the FQDN (as returned by hostname --fqdn)
    or the DNS domain name (as returned by dnsdomainname) with
    this command. The FQDN of the system is the name that the
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    resolver(3) returns for the host name.
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

    Technically: The FQDN is the name gethostbyname(2) returns
    for the host name returned by gethostname(2). The DNS
    domain name is the part after the first dot.

    Therefore it depends on the configuration (usually in
    /etc/host.conf) how you can change it. Usually (if the
    hosts file is pd before DNS or NIS) you can change it
    in /etc/hosts.

    man gethostbyname


    The domain name queries carried out by gethostbyname() and
    gethostbyaddr() use a combination of any or all of the
    name server named(8), a broken out line from /etc/hosts,
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    and the Network Information Service (NIS or YP), depending
    upon the contents of the order line in /etc/host.conf.
    (See resolv+(8)). The default action is to query
    named(8), followed by /etc/hosts.

    and more stuff like that.

    General conclusion - the FQDN must be first.


    Peter
    Peter Guest

Similar Threads

  1. ExpandPath evaluates to ColdFusion root instead ofvirtual web server root
    By _Tian_ in forum Coldfusion Server Administration
    Replies: 0
    Last Post: April 7th, 11:54 PM
  2. login error:cannot not find root directory
    By perikillo in forum FreeBSD
    Replies: 1
    Last Post: February 17th, 03:40 PM
  3. can't login as root
    By knocte in forum Linux Setup, Configuration & Administration
    Replies: 20
    Last Post: September 27th, 10:34 PM
  4. CDE login disabled for root - how to enable?
    By Chris Mattern in forum AIX
    Replies: 3
    Last Post: August 8th, 05:56 AM
  5. Root login on NIS Client
    By Fausto in forum Sun Solaris
    Replies: 5
    Last Post: July 25th, 06:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139