Professional Web Applications Themes

reading fat32 disk with spanish character filenames? - Linux Setup, Configuration & Administration

I have set up a redhat 9 machine to dual boot to win98. I want to access the win98 disk (fat32) from redhat, and I can, but there is a problem: some of my files on the windows disk have spanish filenames that have non-plain characters in them (e.g. ˝), and under linux these filenames appear uncorrectly, and the files cannot be accessed (their icon appears with a lock symbol on it and you can't open the file). I've found a way to rename the files (e.g. mv astr* astronomy.doc) but I don't want to have to do this for ...

  1. #1

    Default reading fat32 disk with spanish character filenames?

    I have set up a redhat 9 machine to dual boot to win98. I want to access
    the win98 disk (fat32) from redhat, and I can, but there is a problem:
    some of my files on the windows disk have spanish filenames that have
    non-plain characters in them (e.g. ˝), and under linux these filenames
    appear uncorrectly, and the files cannot be accessed (their icon appears
    with a lock symbol on it and you can't open the file). I've found a way
    to rename the files (e.g. mv astr* astronomy.doc) but I don't want to
    have to do this for hundreds of files, so can anyone advise a way to fix
    it so linux can read these filenames?

    thanks
    lindsay

    --
    to email me, please take out the cat!

    Lindsay Guest

  2. #2

    Default Re: reading fat32 disk with spanish character filenames?

    Victor Nazarov wrote: 
    > add the following to your fstab:
    > /dev/hd<??> /mnt/win vfat iocht=utf-8,codepage=437,<other settings>
    >
    > if it does't work check your LANG enviroment variable to find out what
    > locale is set. If it is not *.UTF-8 change `iocht=' to your locale
    > cht. Examine your MS(c) Windows(TM) system to find what codepage was
    > used in the `MS-DOS(TM) session' window.[/ref]

    (posting for Lindsay)

    Thanks for that info! Unfortuately, win98 is doing what it does best and
    is not booting now, so is there a way to examine the filesystem, without
    using win98, to determine what cht it is using?

    thanks
    alex


    Alex Guest

  3. #3

    Default Re: reading fat32 disk with spanish character filenames?

    Lindsay Martindale wrote: 
    add the following to your fstab:
    /dev/hd<??> /mnt/win vfat iocht=utf-8,codepage=437,<other settings>

    if it does't work check your LANG enviroment variable to find out what
    locale is set. If it is not *.UTF-8 change `iocht=' to your locale
    cht. Examine your MS(c) Windows(TM) system to find what codepage was
    used in the `MS-DOS(TM) session' window.

    Victor Guest

  4. #4

    Default Re: reading fat32 disk with spanish character filenames?

    On Tue, 07 Oct 2003 08:39:28 -0500,
    Victor Nazarov <ru> wrote:

     
    >>
    >>
    >> (posting for Lindsay)
    >>
    >> Thanks for that info! Unfortuately, win98 is doing what it does best and
    >> is not booting now, so is there a way to examine the filesystem, without
    >> using win98, to determine what cht it is using?
    >>
    >> thanks
    >> alex
    >>
    >>[/ref]
    >
    >Try to use the line showed before:
    >/dev/hd<??> /mnt/win vfat iocht=utf-8,codepage=437,<other settings>
    >
    >I think it should work. 437 is the default codepage for all west
    >European languages (I think Spanish too) in Windows and Dos.[/ref]


    No, the default code page is CP850. CP437 was for the US market.


    Villy


    Villy Guest

  5. #5

    Default Re: reading fat32 disk with spanish character filenames?

    Alex Hunsley wrote: 
    >> add the following to your fstab:
    >> /dev/hd<??> /mnt/win vfat iocht=utf-8,codepage=437,<other settings>
    >>
    >> if it does't work check your LANG enviroment variable to find out what
    >> locale is set. If it is not *.UTF-8 change `iocht=' to your locale
    >> cht. Examine your MS(c) Windows(TM) system to find what codepage
    >> was used in the `MS-DOS(TM) session' window.[/ref]
    >
    >
    > (posting for Lindsay)
    >
    > Thanks for that info! Unfortuately, win98 is doing what it does best and
    > is not booting now, so is there a way to examine the filesystem, without
    > using win98, to determine what cht it is using?
    >
    > thanks
    > alex
    >
    >[/ref]

    Try to use the line showed before:
    /dev/hd<??> /mnt/win vfat iocht=utf-8,codepage=437,<other settings>

    I think it should work. 437 is the default codepage for all west
    European languages (I think Spanish too) in Windows and Dos. Codepage
    setting doesn't have any effect to the appearance of filenames (I
    think). Windows long filenames are always stored in Unicode (UCS16) and
    can be converted to every other codepage.

    The codepage setting is used to point what codepage to use with short
    (8.3) filenames in windows (to generate short names from long ones)

    So if it doesn't work try to find out your current Linux locale codepage
    (It must be UTF8 on RH9 by default) and substitute iocht=utf-8 to
    iocht=<your codepage>. Also if codepage is not UTF8, set
    G_BROKEN_FILENAMES environment variable in any X startup file, so that
    GNOME2 will be able to understand your filenames.

    Victor Guest

  6. #6

    Default Re: reading fat32 disk with spanish character filenames?

    In comp.os.linux.misc Lindsay Martindale <feline.com> wrote: 

    They appear as correctly as you wish under linux and the character is
    whatever character it is. Honest! Use ls | od -a to confirm!

    You are confusing appearance with reality. It doesn't matter whether
    the chars in the name are printable or not.
     

    You are talking about some gui. Don't use a gui. And if you do, tell me
    which one it is. Then don't use it.
     

    Well, renaming them will solve your concern with appearance. But why
    are you concerned? If you want to see the names in some different way,
    set your current code page differently. Or mount the disk with that
    page. Man mount!

    codepage=value
    Sets the codepage for converting to shortname char
    acters on FAT and VFAT filesystems. By default, codepage
    437 is used.

    What's the problem? Set LANG too.
     

    It can read them just fine! Stop being annoying! Saying false things is
    annoying to those who know better. It's your perception that is wrong,
    not linux.

    Peter
    Peter Guest

  7. #7

    Default Re: reading fat32 disk with spanish character filenames?

    Peter T. Breuer wrote: 
    >
    >
    > You are talking about some gui. Don't use a gui. And if you do, tell me
    > which one it is. Then don't use it.[/ref]

    Arrogant twit.
    <plonk>

    Alex Guest

  8. #8

    Default Re: reading fat32 disk with spanish character filenames?

    Villy Kruse wrote: 
    >>
    >>Try to use the line showed before:
    >>/dev/hd<??> /mnt/win vfat iocht=utf-8,codepage=437,<other settings>
    >>
    >>I think it should work. 437 is the default codepage for all west
    >>European languages (I think Spanish too) in Windows and Dos.[/ref]
    >
    >
    >
    > No, the default code page is CP850. CP437 was for the US market.
    >
    >
    > Villy
    >
    >[/ref]
    So here is the line to past it into fstab (Change the device name):
    /dev/hd<??> /mnt/win vfat iocht=utf-8,codepage=850,<other settings>

    Victor Guest

  9. #9

    Default Re: reading fat32 disk with spanish character filenames?

    Victor Nazarov wrote: 
    >>
    >>
    >>
    >>
    >> No, the default code page is CP850. CP437 was for the US market.
    >>
    >>
    >> Villy
    >>
    >>[/ref]
    > So here is the line to past it into fstab (Change the device name):
    > /dev/hd<??> /mnt/win vfat iocht=utf-8,codepage=850,<other settings>[/ref]

    Ok, I've tried remounting the windows disk (fat32) with various
    combinations of iocht=utf-8 and codepage=850 and codepage=437, and
    in all combinations when I remount the windows disk, the characters in
    the filename are still not recognised....

    thanks
    alex


    Alex Guest

  10. #10

    Default Re: reading fat32 disk with spanish character filenames?

    Alex Hunsley wrote:
     

    So check your locale settings first.

    Where did you try to view filenames?
    If you see ? signes in console, it may be connected with the fonts, acm
    (Applications Charecter Map) and sfm (Screen Font Map).
    In GUI it may be effected by fonts.
    What GUI do you use?
    What distribution do you use? (This information is usefull to setup your
    console)

    Victor Guest

Similar Threads

  1. reading Disk space
    By Damien Inferno webforumsuser@macromedia.com in forum Macromedia Flash Actionscript
    Replies: 2
    Last Post: January 18th, 08:12 PM
  2. Replies: 6
    Last Post: October 9th, 06:30 PM
  3. Reading filenames in a folder
    By Steve Karnath in forum ASP
    Replies: 6
    Last Post: September 18th, 11:32 AM
  4. bash: for to, reading escaped spaces in filenames
    By David selby in forum Debian
    Replies: 5
    Last Post: July 13th, 03:10 PM
  5. Replies: 5
    Last Post: July 11th, 11:47 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139