I have Redhat 8 installed on a Dell laptop and I'm trying to upgrade
to Redhat 9.

As I understand it, I should get an upgrade option by simply booting
from the CD. I don't get that option, although all of the other
options are there. I searched the Redhat site and following it's
suggestion I tried entering 'linux upgradeany' at the prompt. That
did not change anything.

Then I tried using Kickstart for the upgrade. I got the ks.cfg file
made, specifying an upgrade, and it looks okay. I got the
installation bootdisk made (using bootdisk.img). It boots to the
floppy and I enter: ks (I've also tried 'linux ks' because I saw
doentation using both of those). It goes into what looks like the
same install procedure from the cd and there is still no upgrade
option.

The Redhat site says that if the /etc/redhat-release file has been
changed from the default the install procedure may have trouble
detecting the current installation. I found that file on my system
and looks okay. It has one line it it that reads: Red Hat Linux
release 8.0 (Psyche) I have not changed this file since the install
(and the timestamp seems to confirm that).

Any help on this is greatly appreciated.

David E. Thomas