Professional Web Applications Themes

restore does not restore auto increment fields - MySQL

I have a production server and testing server. Every so often i need to backup the production server and restore it for testing. I ran the mysql administrator backup on only the db i needed, and restored the db on the test server. It carried all of my tables over but all the auto-increment fields lost thier auto-increment status. How do i restore this stuff. Sorry if it is a simple question i am new to mysql....

  1. #1

    Default restore does not restore auto increment fields

    I have a production server and testing server. Every so often i need
    to backup the production server and restore it for testing.

    I ran the mysql administrator backup on only the db i needed, and
    restored the db on the test server. It carried all of my tables over
    but all the auto-increment fields lost thier auto-increment status.

    How do i restore this stuff.
    Sorry if it is a simple question i am new to mysql.

    lewis Guest

  2. #2

    Default Re: restore does not restore auto increment fields

    lewis wrote: 

    how do you restore the database? if you are not dropping tables i can
    see why this is happening.

    --
    lark -- net
    To reply to me directly, delete "despam".
    lark Guest

  3. #3

    Default Re: restore does not restore auto increment fields

    On May 11, 5:13 pm, lark <net> wrote: 


    >
    > how do you restore the database? if you are not dropping tables i can
    > see why this is happening.
    >
    > --
    > lark -- net
    > To reply to me directly, delete "despam".[/ref]

    I am restoring to a new (blank) database

    lewis Guest

  4. #4

    Default Re: restore does not restore auto increment fields

    lewis wrote: 
    >> how do you restore the database? if you are not dropping tables i can
    >> see why this is happening.
    >>
    >> --
    >> lark -- net
    >> To reply to me directly, delete "despam".[/ref]
    >
    > I am restoring to a new (blank) database
    >[/ref]


    when you backup make sure you have a couple of things done right in the
    advanced options tab:
    1-check add drop statements
    2-check complete inserts
    3-check comments (if need be)

    then take the backup

    when restoring make sure you select the file that was just backedup and
    make sure that the original schema is selected for target schema and
    that file type is sql, then just click the restore button and it should
    restore everything including the autoincrements
    lark Guest

  5. #5

    Default Re: restore does not restore auto increment fields

    On May 14, 3:23 pm, lark <net> wrote: [/ref]
    > [/ref]

    >
    > when you backup make sure you have a couple of things done right in the
    > advanced options tab:
    > 1-check add drop statements
    > 2-check complete inserts
    > 3-check comments (if need be)
    >
    > then take the backup
    >
    > when restoring make sure you select the file that was just backedup and
    > make sure that the original schema is selected for target schema and
    > that file type is sql, then just click the restore button and it should
    > restore everything including the autoincrements- Hide quoted text -
    >
    > - Show quoted text -[/ref]

    i did all that and it did not seem to work
    Here is what i have
    I selected my database (ips) and made sure that all the
    views,procedures,functions, and tables were selected
    on the advanced tab (these are selected)
    InnoDB online backup
    complete bakcup
    add drop statements
    complete inserts
    comments
    fully qualified identifiers
    compatibility mode
    disable keys
    backup type is sql files

    I run the backup
    copy the file

    to restore
    i select the file i just backed up
    backup type sql files
    original schema
    cht: utf8

    and start restore
    All my tables, procs .. seem to come over fine, i just don't see the
    autoinc flag.

    Thanks for you help.


    lewis Guest

  6. #6

    Default Re: restore does not restore auto increment fields

    lewis wrote: 
    >> when you backup make sure you have a couple of things done right in the
    >> advanced options tab:
    >> 1-check add drop statements
    >> 2-check complete inserts
    >> 3-check comments (if need be)
    >>
    >> then take the backup
    >>
    >> when restoring make sure you select the file that was just backedup and
    >> make sure that the original schema is selected for target schema and
    >> that file type is sql, then just click the restore button and it should
    >> restore everything including the autoincrements- Hide quoted text -
    >>
    >> - Show quoted text -[/ref]
    >
    > i did all that and it did not seem to work
    > Here is what i have
    > I selected my database (ips) and made sure that all the
    > views,procedures,functions, and tables were selected
    > on the advanced tab (these are selected)
    > InnoDB online backup
    > complete bakcup
    > add drop statements
    > complete inserts
    > comments
    > fully qualified identifiers
    > compatibility mode
    > disable keys
    > backup type is sql files
    >
    > I run the backup
    > copy the file
    >
    > to restore
    > i select the file i just backed up
    > backup type sql files
    > original schema
    > cht: utf8
    >
    > and start restore
    > All my tables, procs .. seem to come over fine, i just don't see the
    > autoinc flag.
    >
    > Thanks for you help.
    >
    >[/ref]
    one thing you may want to do is open up the backup file and see if your
    table definitions include the autoincrement flags on the fields where
    they should be set.

    --
    lark -- net
    To reply to me directly, delete "despam".
    lark Guest

  7. #7

    Default Re: restore does not restore auto increment fields

    On May 16, 10:05 am, lark <net> wrote: [/ref]
    > [/ref]
    > [/ref]
    > [/ref]





    >
    > one thing you may want to do is open up the backup file and see if your
    > table definitions include the autoincrement flags on the fields where
    > they should be set.
    >
    > --
    > lark -- net
    > To reply to me directly, delete "despam".- Hide quoted text -
    >
    > - Show quoted text -[/ref]

    my backup file does not include any identity statements.

    lewis Guest

Similar Threads

  1. Physical restore that doesn't require a logical restore
    By Christian Eriksson in forum Informix
    Replies: 6
    Last Post: September 24th, 11:30 AM
  2. Replies: 3
    Last Post: July 18th, 07:47 AM
  3. Sys Restore entries but no restore
    By Ed Calliott in forum Windows XP/2000/ME
    Replies: 0
    Last Post: June 28th, 08:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139