Professional Web Applications Themes

RH7.3 -> RH9, locales and UTF-8 trouble (i18n) - Linux Setup, Configuration & Administration

Hi group, I updated from RH7.3 to RH9. The scandinavian characters doesn't show up correctly everywhere (old files made with pico, emacs), those characters are also shown as '?' chars when reading news. Also xchat does trouble on others with those characters, not in my side though. Ok, it sounds like an UTF-8 trouble. I found information for RH8, but i think the things differ for RH9. I made some searches on comp.os.linux.* already. After this upgrade, my /etc/sysconfig/i18n contained: LANG="en_US" SUPPORTED="en_US:en" SYSFONT="lat0-sun16" SYSFONTACM="iso01" now i have set it like this: LANG="en_US.iso885901" SUPPORTED="en_US.iso885901:en_US:en" SYSFONT="lat0-sun16" SYSFONTACM="iso01" and /etc/sysconfig/keyboard contained: KEYBOARDTYPE="pc" KEYTABLE="fi" ...

  1. #1

    Default RH7.3 -> RH9, locales and UTF-8 trouble (i18n)


    Hi group,

    I updated from RH7.3 to RH9. The scandinavian characters doesn't show up
    correctly everywhere (old files made with pico, emacs), those characters
    are also shown as '?' chars when reading news. Also xchat does trouble on
    others with those characters, not in my side though. Ok, it sounds like an
    UTF-8 trouble. I found information for RH8, but i think the things differ
    for RH9. I made some searches on comp.os.linux.* already.

    After this upgrade, my /etc/sysconfig/i18n contained:
    LANG="en_US"
    SUPPORTED="en_US:en"
    SYSFONT="lat0-sun16"
    SYSFONTACM="iso01"

    now i have set it like this:

    LANG="en_US.iso885901"
    SUPPORTED="en_US.iso885901:en_US:en"
    SYSFONT="lat0-sun16"
    SYSFONTACM="iso01"

    and /etc/sysconfig/keyboard contained:
    KEYBOARDTYPE="pc"
    KEYTABLE="fi"

    i have set it like this:
    KEYBOARDTYPE="pc"
    KEYTABLE="fi-latin1"

    The fi-latin1 setting fixed some console trouble. I tested "service
    keytable restart" before permanent changes. I reloaded/restarted
    things, but still, in the X environment, the $LANG and $GDM_LANG gave out
    en_US.UTF-8. I selected system default as a language in gdm, after this
    change $LANG was en_US.iso885901 but $GDM_LANG not set, the same
    troubles still occur: The '?' characters placed at scand. characters.

    To UTF-8 or not to UTF-8, i can't find a good and clean solution to
    this. Any suggestions?

    --
    Agemixer/Skalaria - "First run, then load."
    fi Subject: 64 mailinkia
    Don't forget the subject line!

    Agemixer Guest

  2. #2

    Default Re: RH7.3 -> RH9, locales and UTF-8 trouble (i18n)


    "Agemixer" <the.sig> wrote in message
    news:japo.fi... 

    Yes. Throw out *ALL* internationalization, use LANG=POSIX, and stick to flat
    ASCII text. Seriously, I'd like to shoot the idiots in the head who have
    been trying to overlay this unreliable, broken, and never cross-compatible
    internationalization crap on top of our current code base.

    Don't get me *started* on how they broke the "sort" function in the "en.US"
    configuration. You do realize that you absolutely cannot do case-sensitive
    sorting in that setup, and need to preset your LANG to something reliable
    like POSIX in order to generate reliably cross-compatible sorting functions
    now?


    Nico Guest

  3. #3

    Default Re: RH7.3 -> RH9, locales and UTF-8 trouble (i18n)


    On Sun, 26 Oct 2003, Nico Kadel-Garcia wrote:
     

    [...]
     

    This didn't solve the scand problem. After this change the characters
    were displayed as '?'s, and the appropriate keys were disabled. Anyway, i
    think i found a partial solution to the problem, adding the settings
    below to /etc/sysconfig/i18n :

    LANG="en_US"
    LC_CTYPE="fi_FI"

    The sort and less searches really doesn't seem to work correctly with
    scands, but i think this doesn't matter me. Atleast this should help
    in finnish (and possibly other european) communication ;)

    Any other solutions?

    --
    Agemixer/Skalaria - "First run, then load."

    email: fi pass: "C64 mailinki" to the Subject: line
    Spam filter is on

    Agemixer Guest

  4. #4

    Default Re: RH7.3 -> RH9, locales and UTF-8 trouble (i18n)

    In article <japo.fi>,
    Agemixer wrote:
     

    See Arska's excellent Finnish HOWTO:
    http://www.arska.org/finnish-howto/html/ for info on this and other
    Finlandization issues. This issue pops up from time to time on
    sfnet.atk.linux, so it might be explained in the s.a.l. FAQ as well:
    http://sal-faq.sourceforge.net/ .

    --
    Juha Siltala
    http://www.edu.helsinki.fi/activity/people/jsiltala/
    Juha Guest

Similar Threads

  1. i18n
    By KONTRA Gergely in forum Ruby
    Replies: 2
    Last Post: November 11th, 04:19 PM
  2. to_s and locales in Gtk
    By Michael Neumann in forum Ruby
    Replies: 2
    Last Post: November 11th, 02:49 PM
  3. RDoc and i18n
    By KUBO Takehiro in forum Ruby
    Replies: 10
    Last Post: October 23rd, 05:17 AM
  4. sorting issue when using locales
    By Heinz Werntges in forum Ruby
    Replies: 0
    Last Post: September 25th, 09:52 PM
  5. Speaking of I18N...
    By gabriele renzi in forum Ruby
    Replies: 9
    Last Post: July 3rd, 10:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139