Professional Web Applications Themes

root device name w/kernel-image - Debian

With the kernel image from a disk (2.4.20-bf2.4) and the root device set to /dev/hda1 my "computer" boots up fine. With newer 2.4 kernel images (kernel-image-2.4-386, kernel-image-2.4.21-1-386 kernel-image-2.4.21-2-386) I can't seem to boot. I've tried: root=/dev/hda1 root=/dev/ide/host0/bus0/target0/lun0/part1 root=/dev/discs/disc0/part1 I tried these with and without the devfsd package installed and there didn't seem to be a difference. The kernel books but says it's unable to mount the root filesystem. Any hints? Drew Daniels -- To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email] with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]...

  1. #1

    Default root device name w/kernel-image

    With the kernel image from a disk (2.4.20-bf2.4) and the root device set
    to /dev/hda1 my "computer" boots up fine. With newer 2.4 kernel images
    (kernel-image-2.4-386, kernel-image-2.4.21-1-386
    kernel-image-2.4.21-2-386) I can't seem to boot.

    I've tried:
    root=/dev/hda1
    root=/dev/ide/host0/bus0/target0/lun0/part1
    root=/dev/discs/disc0/part1

    I tried these with and without the devfsd package installed and there
    didn't seem to be a difference.

    The kernel books but says it's unable to mount the root filesystem.

    Any hints?

    Drew Daniels


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Drew Scott Daniels Guest

  2. #2

    Default Re: root device name w/kernel-image

    On Wed, 2003-07-23 at 16:45, Drew Scott Daniels wrote:
    > With the kernel image from a disk (2.4.20-bf2.4) and the root device set
    > to /dev/hda1 my "computer" boots up fine. With newer 2.4 kernel images
    > (kernel-image-2.4-386, kernel-image-2.4.21-1-386
    > kernel-image-2.4.21-2-386) I can't seem to boot.
    >
    > I've tried:
    > root=/dev/hda1
    > root=/dev/ide/host0/bus0/target0/lun0/part1
    > root=/dev/discs/disc0/part1
    >
    > I tried these with and without the devfsd package installed and there
    > didn't seem to be a difference.
    >
    What filesystem is on your root and does the new kernel have built-in
    support for it ? I dont think having a module is adequate since the
    kernel wont be able to access the filesystem to load the module

    Shri

    --
    ------------------------------------------------------------------------
    Shri Shrikumar U R Byte Solutions Tel: 0845 644 4745
    I.T. Consultant Edinburgh, Scotland Mob: 0773 980 3499
    Web: [url]www.urbyte.com[/url] Email: [email]shriurbyte.com[/email]

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.1 (GNU/Linux)

    iD8DBQA/HrkOBqoC2HdbEIcRAkdrAKC8nlOnjtjUF+X23sRvuOFhUU0w2w Cfb1sT
    2ke57LO7ejGpPJenCH13unQ=
    =Tksb
    -----END PGP SIGNATURE-----

    Shri Shrikumar Guest

  3. #3

    Default Re: root device name w/kernel-image

    Hello

    Drew Scott Daniels wrote:
    > With the kernel image from a disk (2.4.20-bf2.4) and the root device set
    > to /dev/hda1 my "computer" boots up fine. With newer 2.4 kernel images
    > (kernel-image-2.4-386, kernel-image-2.4.21-1-386
    > kernel-image-2.4.21-2-386) I can't seem to boot.
    >
    > I've tried:
    > root=/dev/hda1
    > root=/dev/ide/host0/bus0/target0/lun0/part1
    > root=/dev/discs/disc0/part1
    >
    > I tried these with and without the devfsd package installed and there
    > didn't seem to be a difference.
    >
    > The kernel books but says it's unable to mount the root filesystem.
    Do the other kernels maybe come with an initrd, but your bootloader is not
    configured to use it?

    BTW, you can disable devfs support at boottime by passing the parameter
    "devfs=nomount" to the kernel.

    best regards
    Andreas Janssen

    --
    Andreas Janssen
    [email]andreas.janssenbigfoot.com[/email]
    PGP-Key-ID: 0xDC801674
    Registered Linux User #267976


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Andreas Janssen Guest

  4. #4

    Default Re: root device name w/kernel-image

    On Thu, 2003-07-24 at 17:23, Colin Watson wrote:
    > On Thu, Jul 24, 2003 at 08:52:52AM -0500, Drew Scott Daniels wrote:
    > > On 23 Jul 2003, Shri Shrikumar wrote:
    > > > On Wed, 2003-07-23 at 16:45, Drew Scott Daniels wrote:
    > > > > With the kernel image from a disk (2.4.20-bf2.4) and the root
    > > > > device set to /dev/hda1 my "computer" boots up fine. With newer
    > > > > 2.4 kernel images (kernel-image-2.4-386, kernel-image-2.4.21-1-386
    > > > > kernel-image-2.4.21-2-386) I can't seem to boot.
    > > > >
    > > > > I've tried:
    > > > > root=/dev/hda1
    > > > > root=/dev/ide/host0/bus0/target0/lun0/part1
    > > > > root=/dev/discs/disc0/part1
    > > > >
    > > > > I tried these with and without the devfsd package installed and
    > > > > there didn't seem to be a difference.
    > > >
    > > > What filesystem is on your root and does the new kernel have
    > > > built-in support for it ? I dont think having a module is adequate
    > > > since the kernel wont be able to access the filesystem to load the
    > > > module
    > >
    > > ext2. I would hope that the Debian distributed kernel would have built
    > > in support for ext2.
    >
    > It may well expect you to use an initrd for that.
    >
    > --
    > Colin Watson [cjwatsonflatline.org.uk]
    >
    If my memory serves me right the packaged debian 2.4 kernels (except the
    instelation disk kernel) all or most use an initrd.
    The ones I installed did, but I didn't use a stock kernel in a long
    time.
    This requires adding an initrd line to lilo or whatever bootmanager you
    use. I think its a boot option.
    If I remeber correctly when you install the kernel it gives you a
    message concerning what you need to do to get it working.



    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Micha Feigin Guest

Similar Threads

  1. kernel doesn't know about the loop device
    By John Smith in forum Linux Setup, Configuration & Administration
    Replies: 2
    Last Post: August 17th, 06:16 AM
  2. HELP (cannot open root device)
    By Nobody in forum Linux Setup, Configuration & Administration
    Replies: 15
    Last Post: August 4th, 08:18 AM
  3. Cannot open root device 00:00
    By Sandrine & Thierry AUGER in forum Debian
    Replies: 0
    Last Post: July 27th, 12:10 PM
  4. KERNEL PANIC: VFS: Unable to mount root fs on 01:00
    By Paul A Morgan in forum Linux Setup, Configuration & Administration
    Replies: 0
    Last Post: July 18th, 07:19 PM
  5. kernel panic on root
    By David M Noriega in forum Linux Setup, Configuration & Administration
    Replies: 3
    Last Post: July 15th, 12:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139