Hello,

first of all: I have setup a simple test case for my problem
here, with all my settings and the problem described:

[url]http://pref.dyndns.org:8080/live/live.html[/url]

And now to the problem: I'm run FMS 2.0.2 r51, dev.ed.
on Debian Linux 3.1r2 and have problems with the rtmps,
while rtmp and rtmpt work just fine. When I run the flash movie,
a window pops up "The Certificate Issuer for this site is
untrusted or unknown. Do you wish to proceed? Yes - No"

I click "Yes", but then get "NetConnection.Connect.Failed".

The netstat command only shows the server listening
at the port 443 (https), but no additional connections to
that port seem to be happening, so I am guessing that
the flash movie doesn't like the certficate and that is why
doesn't even try to connect:

$ netstat -a
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address
State
.......
tcp 0 0 *:https *:*
LISTEN

And here is how I've generated the certificate:

openssl req -x509 -days 365 -newkey rsa:1024 \
-out self-signed-certificate.pem -keyout pub-sec-key.pem

I've also tried to generate it another way, but with same result:

openssl genrsa -out server.key 1024
openssl req -new -key server.key -out server.csr
openssl x509 -req -days 365 -in server.csr -signkey server.key
-out server.crt

Can anybody please share his/her experiences here?
I don't want to buy a certificate from Verisign or Thatwe yet
(and I think it shouldn't be necessary with a correct self-signed
cert).

Thank you
Alex

PS: My movie flash simply publishes a stream and then plays it back:

function updateStatus(info) { status_txt.text += info.code + newline; }


var camera:Camera = Camera.get();
var micro:Microphone = Microphone.get();

local_video.attachVideo(camera);
nc = new NetConnection();
nc.onStatus = updateStatus;

nc.connect("rtmps://pref.dyndns.org/live");
status_txt.text += nc.uri + newline;

publish_ns = new NetStream(nc);
publish_ns.onStatus = updateStatus;
publish_ns.attachAudio(micro);
publish_ns.attachVideo(camera);
publish_ns.publish("live_test");

play_ns = new NetStream(nc);
play_ns.onStatus = updateStatus;
remote_video.attachVideo(play_ns);
play_ns.play("live_test");

PPS: My /var/log/messages show successful listening at port 443:
Service[2666]: Server starting...
Server[2666]: No primary license key found. Switching to Developer
Edition.
Service[2666]: Server started (/usr/local/fms/conf/Server.xml).
Server[2678]: No primary license key found. Switching to Developer
Edition.
Server[2675]: No primary license key found. Switching to Developer
Edition.
Adaptor[2675]: Listener started ( _defaultRoot__edge1 ) : 19350
Adaptor[2675]: Listener started ( _defaultRoot__edge1 ) : 443 (secure)
Adaptor[2675]: Listener started ( _defaultRoot__edge1 ) : 80
Adaptor[2675]: Listener started ( _defaultRoot__edge1 ) : 1935
Service[2824]: Server starting...
Server[2824]: No primary license key found. Switching to Developer
Edition.
Adaptor[2824]: Listener started ( FCSAdminIpcProtocol ) : 11110
Adaptor[2824]: Listener started ( FCSAdminAdaptor ) : 1111
Service[2824]: Server started (./conf/Server.xml).

--
[url]http://preferans.de[/url]