Hey everyone,

I'm trying to run a command-line application (PuTTY's PSCP, a secure
FTP client) from an ASP page. I can manually open up cmd.exe, type or
paste in the command, and transfer a file. I can check with a GUI FTP
program (with no command-line interface) and see that the file was
transferred. So far, no problem.

I am not allowed to give the IUSR permission to use cmd.exe. So, I
downloaded ASPExec, copied it to the system32 directory, and ran
regsvr32, which gave me the success message.

When I try to use ASPExec to run the command-line application, I get
.... nothing. No error message is returned, but the file is not
transferred. I have hardcoded the command so that it is exactly what I
used when manually typing in the command.

I write out the result of the call, after it runs, to the screen. It
shows the entire command that I supposedly executed. Anybody have a
clue what this means?

I have tried running the sample scripts that come with ASPExec, with
mixed results. When I run ASPEXEC.asp, which opens up a text file, I
can see Notepad is running, but it doesn't show up on the screen.
When I run ASPPing.asp, which just pings a server you specify, I get an
error: "Could not create process."

What should I do? Is ASPExec set up incorrectly? Is there
doentation for ASPExec out there somewhere?

Kris