Professional Web Applications Themes

SCO 5.0.5 - How do I set a network adapter to 100 Full duplex? - SCO

I have an IBM Netfinity 5500 running SCO 5.0.5. I am trying to set the network adapter to lock in at 100MB Full Duplex and am unsure of what I need to do. I have a built in ethernet adapter which shows up as an "AMD PCNet-PCI Adapter" and it uses the pnt network driver. Scanning for previous posts on the subject led me to try editting the file /etc/conf/pack.d/pnt/space.c. According to the posts, all I had to do was change the 'speed' and 'duplex' settings in the file, relink, and then reboot. Unfortnuately I could not find either entries ...

  1. #1

    Default SCO 5.0.5 - How do I set a network adapter to 100 Full duplex?

    I have an IBM Netfinity 5500 running SCO 5.0.5. I am trying to set the
    network adapter to lock in at 100MB Full Duplex and am unsure of what
    I need to do. I have a built in ethernet adapter which shows up as an
    "AMD PCNet-PCI Adapter" and it uses the pnt network driver.

    Scanning for previous posts on the subject led me to try editting the
    file /etc/conf/pack.d/pnt/space.c. According to the posts, all I had
    to do was change the 'speed' and 'duplex' settings in the file,
    relink, and then reboot. Unfortnuately I could not find either entries
    in the space.c file.

    Can someone point me in the right direction to set this adapter at
    100MB Full duplex?

    Thanks,

    Michael Vraniak
    Unix Administrator
    com
    Michael Guest

  2. #2

    Default Re: SCO 5.0.5 - How do I set a network adapter to 100 Full duplex?

    Michael Vraniak typed (on Mon, Oct 13, 2003 at 12:21:38PM -0700):
    | I have an IBM Netfinity 5500 running SCO 5.0.5. I am trying to set the
    | network adapter to lock in at 100MB Full Duplex and am unsure of what
    | I need to do. I have a built in ethernet adapter which shows up as an
    | "AMD PCNet-PCI Adapter" and it uses the pnt network driver.
    |
    | Scanning for previous posts on the subject led me to try editting the
    | file /etc/conf/pack.d/pnt/space.c. According to the posts, all I had
    | to do was change the 'speed' and 'duplex' settings in the file,
    | relink, and then reboot. Unfortnuately I could not find either entries
    | in the space.c file.
    |
    | Can someone point me in the right direction to set this adapter at
    | 100MB Full duplex?

    Run netconfig, try to modify the TCP protocol -- do you see an Advanced
    Options choice?

    --
    JP
    Jean-Pierre Guest

  3. #3

    Default Re: SCO 5.0.5 - How do I set a network adapter to 100 Full duplex?

    I accessed the netconfig utility previously and tunneled down to the
    "Advanced Network Driver Configuration". Below is the screen.

    :Enter the configuration of AMD PCNet-PCI Adapter: :0
    : :0
    : Number of tx/rx buffers: | 32___________________|v:0
    : 10-BaseT mode enforced: | 0____________________|v:0
    : Full-duplex mode enabled: | 0____________________|v:0
    :Rotate priority mode for DMA: | 0____________________|v:0
    : Advanced PCnet features: | 0____________________|v:0

    I understand that setting the full-duplex enabled would give me
    full-duplex but I was unsure whether the setting the 10-BaseT option
    to 0 would enable 100-BaseT or set up auto-negotiate for the card.

    Do you know how I can confirm that this is not auto-negotiate?

    Michael Vraniak
    com

    Jean-Pierre Radley <com> wrote in message news:<jpr.com>... 
    Michael Guest

  4. #4

    Default Re: SCO 5.0.5 - How do I set a network adapter to 100 Full duplex?

    Michael Vraniak wrote:
     [/ref]
     

    I believe the "pnt" driver shipped in OSR505 does not support 100Mbps
    operation. There is an updated driver at:

    ftp://ftp.sco.com/pub/openserver5/drivers/OSR505/network/pnt

    Install that and see whether you have any better luck.
     
    Bela Guest

  5. #5

    Default Re: SCO 5.0.5 - How do I set a network adapter to 100 Full duplex?

    Thanks for the info. I downloaded the driver and now I have to set up
    a time to install it. I will update this thread with the results.

    Bela Lubkin <com> wrote in message news:<com>... [/ref]

    >
    > I believe the "pnt" driver shipped in OSR505 does not support 100Mbps
    > operation. There is an updated driver at:
    >
    > ftp://ftp.sco.com/pub/openserver5/drivers/OSR505/network/pnt
    >
    > Install that and see whether you have any better luck.
    > [/ref]
    Michael Guest

Similar Threads

  1. Replies: 7
    Last Post: August 11th, 09:02 PM
  2. How do force 100BaseT full duplex for /dev/ce?
    By Crusher in forum Sun Solaris
    Replies: 5
    Last Post: August 7th, 01:48 PM
  3. Full duplex socket communication
    By jahurt@hotmail.com in forum UNIX Programming
    Replies: 3
    Last Post: July 10th, 03:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139