Professional Web Applications Themes

SCO Openserver 5.0.6 losing time - SCO

We have a server running SCO Openserver 5.0.6a and the system is losing time at about (in fact almost exactly) 15 seconds a minute. The Real Time Clock keeps time fine, however the operating system clock is losing it. # setclk -p RTC 2003/09/11 14:36:29 STD SYS 2003/09/11 14:35:12 STD RTC-SYS=77 # setclk -p RTC 2003/09/11 14:36:43 STD SYS 2003/09/11 14:35:23 STD RTC-SYS=80 # setclk -p RTC 2003/09/11 14:37:29 STD SYS 2003/09/11 14:35:57 STD RTC-SYS=92 # setclk -p RTC 2003/09/11 14:38:44 STD SYS 2003/09/11 14:36:54 STD RTC-SYS=110 Does anyone know of a solution to this? Thanks. -- Posted via http://dbforums.com...

  1. #1

    Default SCO Openserver 5.0.6 losing time


    We have a server running SCO Openserver 5.0.6a and the system is losing
    time at about (in fact almost exactly) 15 seconds a minute. The Real
    Time Clock keeps time fine, however the operating system clock is
    losing it.



    # setclk -p

    RTC 2003/09/11 14:36:29 STD

    SYS 2003/09/11 14:35:12 STD RTC-SYS=77

    # setclk -p

    RTC 2003/09/11 14:36:43 STD

    SYS 2003/09/11 14:35:23 STD RTC-SYS=80

    # setclk -p

    RTC 2003/09/11 14:37:29 STD

    SYS 2003/09/11 14:35:57 STD RTC-SYS=92

    # setclk -p

    RTC 2003/09/11 14:38:44 STD

    SYS 2003/09/11 14:36:54 STD RTC-SYS=110



    Does anyone know of a solution to this?



    Thanks.


    --
    Posted via http://dbforums.com
    schumw Guest

  2. #2

    Default Re: SCO Openserver 5.0.6 losing time

    schumw wrote:
     

    Quote from
    TA # 115103

    Please check the following:
    1. Are you using a non-standard time zone or a half hour time zone, such
    as IST?


    There is a known problem with half hour and non-standard time
    zones, which has been reported to Caldera Engineering. A
    workaround for this problem is to disable RTC tracking. To
    do this,
    edit /etc/conf/pack.d/clock/space.c and change:

    FROM:

    int track_rtc = 1;

    TO:

    int track_rtc = 0;

    then, relink the kernel with the following:

    /etc/conf/cf.d/link_unix -y and reboot.


    2. If you are using a standard time zone, such as GMT or EST, but the
    problem is still occurring, it may be that the clock driver's
    measurements of the CPU clock frequency are inconsistent. To check if
    this is the case, please run:

    grep clock /usr/adm/syslog

    If the output is similar to that below, then this is the
    problem.
    In this case, the system had a 180 Mhz CPU, but as you can
    see the
    clock driver's measurement of the frequency was inconsistent.

    %clock - - - type=TSC/67360126Hz

    %clock - - - type=TSC/101040742Hz

    %clock - - - type=TSC/134720983Hz

    %clock - - - type=TSC/112267613Hz

    %clock - - - type=TSC/134720903Hz


    It is possible to work around this problem by forcing the
    clock
    driver to use a specified frequency. For instance, if you know
    that you have a 133 Mhz CPU, try booting the system with the
    following bootstring:

    unix clock.tsc_clock_hz=133000000

    (that is the Mhz value followed by six zeros). If the
    system clock
    still runs slowly, you can try a slightly lower value. If the
    system clock runs a bit fast, you can try a slightly higher
    value.

    If this fixes the problem, then you can 'hard wire' the clock
    driver to use this value all the time. Edit
    /etc/conf/pack.d/clock/space.c and change:

    unsigned long tsc_clock_hz = 0;

    to equal the Mhz value that fixes the problem. Then, relink the
    kernel with /etc/conf/cf.d/link_unix -y and reboot.


    Note
    If you are having this problem with a version of OpenServer prior to
    5.0.6, then the solution is to upgrade to 5.0.6 and then apply the
    workarounds detailed above.



    Stevalyn Guest

  3. #3

    Default Re: SCO Openserver 5.0.6 losing time


    The timezone is CST which I believe is quite standard.



    When I check /usr/adm/syslog with the command

    grep clock /usr/adm/syslog

    I get the following:

    $ grep clock /usr/adm/syslog

    %clock - - - type=TSC/728436991Hz

    %clock - - - type=TSC/728436991Hz

    %clock - - - type=TSC/728437686Hz

    %clock - - - type=TSC/728437686Hz



    The server has a 759MHz Intel Pentium III processor according to the
    'hw' command. Do you think that the clock driver's measurement of the
    frequency is incorrect? It looks like it to me.



    Is there any way to work out the correct value of clock.tsc_clock_hz
    other than trial and error and rebooting?



    Thanks.


    --
    Posted via http://dbforums.com
    schumw Guest

  4. #4

    Default Re: SCO Openserver 5.0.6 losing time


    Given that the system clock is losing exactly 15 seconds per minute, is
    it possible to calculate the appropriate setting of tsc_clock_hz?


    --
    Posted via http://dbforums.com
    schumw Guest

Similar Threads

  1. OpenServer 5.0.6
    By Roberto in forum SCO
    Replies: 4
    Last Post: November 26th, 04:21 PM
  2. Losing HTTP connections over time
    By Ian L in forum ASP.NET Web Services
    Replies: 0
    Last Post: October 20th, 09:30 PM
  3. defbootstr | SCO OpenServer 5.06
    By Perry Whelan in forum SCO
    Replies: 7
    Last Post: August 22nd, 12:08 AM
  4. SCO OpenServer 5.0.5 Error
    By Jean-Pierre Radley in forum SCO
    Replies: 3
    Last Post: July 15th, 12:02 AM
  5. Replies: 2
    Last Post: July 8th, 09:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139