Professional Web Applications Themes

sendmail only listening on localhost - FreeBSD

Hi all, I have a default sendmail instance on FreeBSD 5.3, the SMTP service only seems to be listening on localhost: netstat -al | grep smtp tcp4 0 0 localhost.smtp *.* LISTEN I can connect locally using telnet localhost 25 but I cannot connect using telnet 10.99.0.2 25. I have tried both editing the .mc file (and regenerating) to add: DAEMON_OPTIONS(`Port=smtp, Addr=10.99.0.2, Name=MTA') and editing the .cf file manually to add: O DaemonPortOptions=Port=smtp, Addr=10.99.0.2, Name=MTA Although of course, that line is there already after regenerating from .mc After restarting, I still cannot connect using 10.99.0.2 Can someone help? Thanks, Simon...

  1. #1

    Default sendmail only listening on localhost

    Hi all,

    I have a default sendmail instance on FreeBSD 5.3, the SMTP service only seems to be listening on localhost:

    netstat -al | grep smtp
    tcp4 0 0 localhost.smtp *.* LISTEN

    I can connect locally using telnet localhost 25 but I cannot connect using telnet 10.99.0.2 25.

    I have tried both editing the .mc file (and regenerating) to add:

    DAEMON_OPTIONS(`Port=smtp, Addr=10.99.0.2, Name=MTA')

    and editing the .cf file manually to add:

    O DaemonPortOptions=Port=smtp, Addr=10.99.0.2, Name=MTA

    Although of course, that line is there already after regenerating from .mc

    After restarting, I still cannot connect using 10.99.0.2

    Can someone help?

    Thanks,
    Simon
    Simon Guest

  2. #2

    Default Re: sendmail only listening on localhost

    >On Mon, 28 Mar 2005 17:25:43 +0100, Simon Ironside
    <net> wrote: 

    I believe the default settings in rc.conf for sendmail has gone
    through some changes in 5.x. The default behavior in 4.x was to
    allow inbound connections for sendmail, which has changed to local
    connections only in 5.x

    Adding the follow to rc.conf should fix the problem...

    sendmail_enable="YES" # Run the sendmail inbound daemon (YES/NO).

    -jw
    Jeff Guest

  3. #3

    Default RE: sendmail only listening on localhost

    From: Jeff Wirth [mailto:com]
    Sent: Mon 28/03/2005 17:55
    To: Simon Ironside
    Cc: org
    Subject: Re: sendmail only listening on localhost
     

    Thankyou, that did the trick.

    Simon

    Simon Guest

Similar Threads

  1. Replies: 4
    Last Post: September 22nd, 02:32 PM
  2. perl script generates sendmail NOQUEUE: connect from rootlocalhost
    By Jhary-a-Conel in forum PERL Miscellaneous
    Replies: 2
    Last Post: July 3rd, 11:27 PM
  3. Something simple!? Sessions - admin.localhost to main.localhost
    By Dave Mateer in forum PHP Development
    Replies: 2
    Last Post: July 1st, 07:57 AM
  4. Mail::Sendmail cannot connect to localhost but the mail command can
    By Andres Monroy-Hernandez in forum PERL Miscellaneous
    Replies: 1
    Last Post: June 27th, 11:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139