Professional Web Applications Themes

Setting up a danish locale - FreeBSD

Problem: We have a visiting scientist from Denmark, whose laptop died a horrible death. A colleagued asked if I would loan him a currently unused system in my office. I've set up FreeBSD 5.3 on the system and everything appears to work except for setting up a Danish locale. Disclaimer: I searched the Handbook, used google, and spent a few hours reading up of login.conf, locale support, etc. But, we are stuck without the danish locale. I have setup a ~/,login_conf in the user home directory that contains dhcp-78-77:kargl[201] cat .login_conf me:\ :cht=ISO8859-1:\ :lang=da_DK.ISO8859-1: When we login, we see that ...

  1. #1

    Default Setting up a danish locale

    Problem: We have a visiting scientist from Denmark, whose laptop
    died a horrible death. A colleagued asked if I would loan him
    a currently unused system in my office. I've set up FreeBSD 5.3
    on the system and everything appears to work except for setting
    up a Danish locale.

    Disclaimer: I searched the Handbook, used google, and spent a
    few hours reading up of login.conf, locale support, etc. But,
    we are stuck without the danish locale.

    I have setup a ~/,login_conf in the user home directory that
    contains

    dhcp-78-77:kargl[201] cat .login_conf
    me:\
    :cht=ISO8859-1:\
    :lang=da_DK.ISO8859-1:

    When we login, we see that the locale is set

    dhcp-78-77:kargl[202] locale
    LANG=da_DK.ISO8859-1
    LC_CTYPE="da_DK.ISO8859-1"
    LC_COLLATE="da_DK.ISO8859-1"
    LC_TIME="da_DK.ISO8859-1"
    LC_NUMERIC="da_DK.ISO8859-1"
    LC_MONETARY="da_DK.ISO8859-1"
    LC_MESSAGES="da_DK.ISO8859-1"
    LC_ALL=

    But any attempt to enter a danish character in for examples xemacs
    fails. From my colleagues comment a "Right-Alt / o" should yield
    a lower case "o" with a slash through it. His system is running
    Xorg 6.7.0_9. I suspect that I need to change/update his xorg.conf
    file. Any insight into setting up the Danish environment would be
    appreciate.

    --
    Steve


    ----- End forwarded message -----

    --
    Steve
    Steve Guest

  2. #2

    Default Re: Setting up a danish locale

    --On Friday, March 11, 2005 09:21:22 AM -0800 Steve Kargl
    <apl.washington.edu> wrote: 
    Just guessing, but did you install /usr/ports/x11-fonts/intlfonts? You may
    need that for the Danish characters to work right.

    Paul Schmehl (edu)
    Adjunct Information Security Officer
    The University of Texas at Dallas
    AVIEN Founding Member
    http://www.utdallas.edu
    Paul Guest

  3. #3

    Default Re: Setting up a danish locale

    On Fri, Mar 11, 2005 at 11:30:08AM -0600, Paul Schmehl wrote: 
    > Just guessing, but did you install /usr/ports/x11-fonts/intlfonts? You may
    > need that for the Danish characters to work right.
    >[/ref]

    intlfonts is not installed. I'll add those and update xorg.conf.
    I suspect that I need to update the Keyboard section of xorg.conf
    to ensure the meta-keys are mapped correctly.

    --
    Steve
    Steve Guest

  4. #4

    Default Re: Setting up a danish locale

    Steve Kargl wrote: 

    From my rc.conf: The keymap sets the keyboard - doesn't make sense to
    set it per account I think? The font stuff is for the console.

    ################################################## ############
    ### System console options #################################
    ################################################## ############

    keymap="danish.iso" # keymap in /usr/share/syscons/keymaps/* (or NO).
    font8x16="iso-8x16" # font 8x16 from /usr/share/syscons/fonts/* (or NO).
    font8x14="iso-8x14" # font 8x14 from /usr/share/syscons/fonts/* (or NO).
    font8x8="iso-8x8" # font 8x8 from /usr/share/syscons/fonts/* (or NO).

     

    Yes, it's not trivial, what have bothered me is that some programs seems
    to have their own overriding settings.
     

    Should you get a future visiting scientist from Denmark, maybe you
    should create a class in /etc/login.conf, I have:

    da_DK:Danish users:\
    :cht=iso-8859-1:\
    :lang=da_DK.ISO8859-1:\
    :tc=default:

    In master.passwd you then set the class for the user to da_DK.

    Finally, in /etc/ttys you need to select a console that supports latin1
    characters instead of plain ascii, cons25l1 is recomended:

    ttyv0 "/usr/libexec/getty Pc" cons25l1 on secure

    All this stuff is to make the console behave. X has it's own life, I
    have had things working in X but not on the console - and I guess the
    oposite is possible too.

    For X I have the following in my XF86Config:

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "keyboard"
    Option "XkbRules" "xfree86"
    Option "XkbModel" "pc102"
    Option "XkbLayout" "dk"

    I haven't installed anything particular for international support, I
    think that is only required for non latin based character sets.

    If you still have problems, you may try and ask in the danish BUG (is it
    called a BUG??) bsd-dk.dk - don't worry, you can write in english.

    Cheers, Erik

    --
    Ph: +34.666334818 web: http://www.locolomo.org
    S/MIME Certificate: http://www.locolomo.org/crt/2004071206.crt
    Subject ID: A9:76:7A:ED:06:95:2B:8D:48:97:CE:F2:3F:42:C8:F2:22 :DE:4C:B9
    Fingerprint: 4A:E8:63:38:46:F6:9A:5D:B4:DC:29:41:3F:62:D3:0A:73 :25:67:C2
    Erik Guest

  5. #5

    Default Re: Setting up a danish locale

    On Sat, Mar 12, 2005 at 05:07:24PM +0100, Erik Norgaard wrote: 

    Erik, Thanks for the pointer. The above partially solved
    out problem. My colleague would like to use the US keyboard
    layout and switch to a Danish layout when he's interacting with
    someone back home. Do you know if this is possible with xmodmap?
    I'm hoping that I can set up some shell aliases that do

    setenv do_danish "xmodmap danish.keys"
    setenv do_english "xmodmap english.keys"

    --
    Steve
    Steve Guest

  6. #6

    Default Re: Setting up a danish locale

    Steve Kargl wrote: 

    No, I personally don't like switching keyboard layouts - I want it to be
    the keys shown on the actual keyboard I use. It it is a matter of having
    the danish characters available and less important where they are, then
    it is posible to define meta-keys - If you or your visiting professor
    understands german there is an article here:

    http://user.cs.tu-berlin.de/~eserte/FreeBSD/doc/umlaute/umlaute.html

    It seems to cover how to use xmodmap:

    xmodmap ${HOME}/.xmodmaprc

    - section 2.2.2

    I generally stick with the danish keyboard - with exception of
    c-circonflex I don't know of any latin character I can't reproduce, so I
    haven't tried.

    Erik
    --
    Ph: +34.666334818 web: http://www.locolomo.org
    S/MIME Certificate: http://www.locolomo.org/crt/2004071206.crt
    Subject ID: A9:76:7A:ED:06:95:2B:8D:48:97:CE:F2:3F:42:C8:F2:22 :DE:4C:B9
    Fingerprint: 4A:E8:63:38:46:F6:9A:5D:B4:DC:29:41:3F:62:D3:0A:73 :25:67:C2
    Erik Guest

Similar Threads

  1. Setting locale?
    By Jim Seymour in forum PHP Development
    Replies: 0
    Last Post: September 17th, 11:39 PM
  2. Database Locale setting
    By Sean in forum IBM DB2
    Replies: 1
    Last Post: August 31st, 04:39 PM
  3. Wierd sort order problem (Danish charcters)
    By JoBless in forum ASP Database
    Replies: 0
    Last Post: August 14th, 07:40 PM
  4. Locale setting problem
    By Sridhar Srinivasan in forum Debian
    Replies: 1
    Last Post: August 3rd, 05:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139