Professional Web Applications Themes

Setting up laptop to use the GPRS connection - Mac Networking

I have no trouble setting up my 12" Al PowerBook to use Bluetooth to dial up EarthLink on my SE P800 phone and connect to the net. But how can I set it up to use the T-Mobile GPRS connection instead of a dial-up service? TIA!...

  1. #1

    Default Setting up laptop to use the GPRS connection

    I have no trouble setting up my 12" Al PowerBook to use Bluetooth to
    dial up EarthLink on my SE P800 phone and connect to the net. But how
    can I set it up to use the T-Mobile GPRS connection instead of a dial-up
    service? TIA!
    Mike O'Connor Guest

  2. #2

    Default Re: Setting up laptop to use the GPRS connection

    First, you have to subscribe to the GPRS service. Second, there is a
    special AT command that connects to a GPRS "PDP Context". It looks like
    "ATD*99***1#" where "1" is the CID number assigned to the GPRS connection in
    the phone. So, you use "*99***1#" as the number to dial in your dialup
    connection. There are instructions on T-Mobile's website on how to do this.
    --

    Donald Newcomb
    DRNewcomb (at) attglobal (dot) net
    Remove 'NOT' from address to reply

    "Mike O'Connor" <mikeleptonicsystems.com> wrote in message
    news:mike-DFCF3F.23162917072003rcache2.srv.hcvlny.cv.net...
    > I have no trouble setting up my 12" Al PowerBook to use Bluetooth to
    > dial up EarthLink on my SE P800 phone and connect to the net. But how
    > can I set it up to use the T-Mobile GPRS connection instead of a dial-up
    > service? TIA!

    Donald Newcomb Guest

  3. #3

    Default Re: Setting up laptop to use the GPRS connection

    In article <3f17d3aa_4news1.prserv.net>,
    "Donald Newcomb" <DRNewcombattglobal.NOT.net> wrote:
    > First, you have to subscribe to the GPRS service. Second, there is a
    > special AT command that connects to a GPRS "PDP Context". It looks like
    > "ATD*99***1#" where "1" is the CID number assigned to the GPRS connection in
    > the phone. So, you use "*99***1#" as the number to dial in your dialup
    > connection. There are instructions on T-Mobile's website on how to do this.
    Thanks! That was the key. I looked around, but couldn't find a thing in
    T-Mobile's help area.
    Mike O'Connor Guest

  4. #4

    Default Re: Setting up laptop to use the GPRS connection


    "Mike O'Connor" <mikeleptonicsystems.com> wrote in message
    news:mike-078F33.11355018072003news4.srv.hcvlny.cv.net...
    > Thanks! That was the key. I looked around, but couldn't find a thing in
    > T-Mobile's help area.
    Start at [url]http://us.t-mobile.mywds.com/[/url] and follow the links to build your
    configuration.
    --

    Donald Newcomb
    DRNewcomb (at) attglobal (dot) net
    Remove 'NOT' from address to reply


    Donald Newcomb Guest

  5. #5

    Default Re: Setting up laptop to use the GPRS connection

    + "Donald Newcomb" <DRNewcombattglobal.NOT.net>:

    | First, you have to subscribe to the GPRS service. Second, there is a
    | special AT command that connects to a GPRS "PDP Context". It looks
    | like "ATD*99***1#" where "1" is the CID number assigned to the GPRS
    | connection in the phone. So, you use "*99***1#" as the number to
    | dial in your dialup connection. There are instructions on T-Mobile's
    | website on how to do this.

    I am suffering a similar problem. My phone is a Siemens S55. Here is
    what happens when I try to connect (verbose log from Internet Connect):

    Sun Jul 20 16:11:07 2003 : Siemens GPRS CID1 56k
    Sun Jul 20 16:11:07 2003 : CCLWrite : AT\13
    Sun Jul 20 16:11:07 2003 : CCLMatched : OK\13\10
    Sun Jul 20 16:11:07 2003 : CCLWrite : AT+GMI\13
    Sun Jul 20 16:11:07 2003 : CCLWrite : AT+CGMI\13
    Sun Jul 20 16:11:07 2003 : CCLMatched : SIEMENS
    Sun Jul 20 16:11:07 2003 : CCLWrite : AT&FE0V1\13
    Sun Jul 20 16:11:07 2003 : CCLMatched : OK\13\10
    Sun Jul 20 16:11:09 2003 : CCLWrite : AT+CGDCONT=1,"IP","internet.netcom.no"\13
    Sun Jul 20 16:11:09 2003 : CCLMatched : OK\13\10
    Sun Jul 20 16:11:09 2003 : Making GPRS connection
    Sun Jul 20 16:11:09 2003 : CCLWrite : ATD*99***1#\13
    Sun Jul 20 16:11:09 2003 : CCLMatched : ERROR\13\10
    Sun Jul 20 16:11:09 2003 : Connect script failed

    And yet, when I connect to the phone using minicom and type in those
    exact AT commands, in the end I get CONNECT followed by a bunch of
    garbage. The modem script came from [url]http://www.taniwha.org.uk/[/url], and
    the connection to the phone is via bluetooth.

    Does anybody have any idea what could be wrong?

    (My next step will be to try it out from my Dell laptop with FreeBSD.
    That one has a serial line, no bluetooth. My Mac has bluetooth, no
    serial port. Which is the reason I got a bluetooth phone in the first
    place. Argh.)

    Followups set to comp.sys.mac.comm.

    - Harald
    Harald Hanche-Olsen Guest

  6. #6

    Default Re: Setting up laptop to use the GPRS connection

    Harald Hanche-Olsen <hanchemath.ntnu.no> wrote:
    > I am suffering a similar problem. My phone is a Siemens S55. Here is
    > what happens when I try to connect (verbose log from Internet Connect):
    > (...)
    > And yet, when I connect to the phone using minicom and type in those
    > exact AT commands, in the end I get CONNECT followed by a bunch of
    > garbage. The modem script came from [url]http://www.taniwha.org.uk/[/url], and
    > the connection to the phone is via bluetooth.
    >
    > Does anybody have any idea what could be wrong?
    >
    > (My next step will be to try it out from my Dell laptop with FreeBSD.
    > That one has a serial line, no bluetooth. My Mac has bluetooth, no
    > serial port. Which is the reason I got a bluetooth phone in the first
    > place. Argh.)
    >
    > Followups set to comp.sys.mac.comm.
    Harald,
    I have a bluetooth mac, and I spent almost one day in sorting everything
    out with my Ericsson T68. No doubt there is a solution, but you may
    waste some hours still.
    I didn't get the beginning of your discussion since I got the previous
    post only on comp.sys.mac.apps, but here is what I know.

    For my T68 I also got a script from taniwha: there were in fact many
    scripts, of which a series that differed only with the bluetooth channel
    used (the CID: they were labeled "T68iCID1", "T68iCID2" etc. in the zip
    archive). I used the CID1 like apparently everyone around advised -this
    appeared to be wrong: inside the T68 (or even maybe the SIMcard) there
    were already half a dozen of GPRS presets, all bad, I had to create
    another one which got by default CID5 (maybbe the first free). When I
    discovered this I changed my modem script to the one with CID5, and all
    was OK. I don't know how the Siemens work, but check wether the CID in
    the Siemens setting you use is the same as the CID in your mac script.
    If it is not you are sure it won't work.

    On the mac I discovered I had to fill up the nameserver addresses in the
    ppp network settings, along with various fields that must be associated
    to your GPRS provider (gprs "name" in the phone number field, name and
    password; uncheck "send PPP echo packets" -forgeting this apparently is
    a killer; no proxie). On R. Barkman site (taniwha...) you also find a
    table describing these settings by country and phone network.

    Ah, one last thing: from my news group list, I can see there are four
    groups associated to Siemens: alt.cellular.siemens,
    alt.pl.mobile.siemens, alt.pl.siemens.rulez.nokia.s (!!), and
    de.comm.geraete.mobil.siemens : did you try describing your problem in
    these groups also? Siemens is the phone I would have chosen if... here
    Orange wouldn't sell it only bundled with an useless and costly camera
    ;-(


    --
    Frédérique & Hervé Sainct, [email]h.sainctlaposte.net[/email]
    Frédérique's initial is missing in front of the above address
    l'initiale de Frédérique manque devant l'adresse email ci-dessus
    Frédérique & Hervé Sainct Guest

  7. #7

    Default Re: Setting up laptop to use the GPRS connection

    + [email]h.sainctlaposte.net[/email] (Frédérique & Hervé Sainct):

    | Harald Hanche-Olsen <hanchemath.ntnu.no> wrote:
    |
    | > I am suffering a similar problem. My phone is a Siemens S55. Here is
    | > what happens when I try to connect (verbose log from Internet Connect):
    | > (...)
    | > And yet, when I connect to the phone using minicom and type in those
    | > exact AT commands, in the end I get CONNECT followed by a bunch of
    | > garbage. The modem script came from [url]http://www.taniwha.org.uk/[/url], and
    | > the connection to the phone is via bluetooth.
    |

    | I didn't get the beginning of your discussion since I got the
    | previous post only on comp.sys.mac.apps, but here is what I know.

    What you saw is all. I just attached my problem description to a
    convenient thread. 8-)

    | I used the CID1 like apparently everyone around advised -this
    | appeared to be wrong: inside the T68 (or even maybe the SIMcard)
    | there were already half a dozen of GPRS presets, all bad, I had to
    | create another one which got by default CID5 (maybbe the first
    | free). When I discovered this I changed my modem script to the one
    | with CID5, and all was OK. I don't know how the Siemens work, but
    | check wether the CID in the Siemens setting you use is the same as
    | the CID in your mac script.

    Will do. The phone is still so new to me I get lost in the menus. It
    seems like a great little phone, but the manual leaves something to be
    desired, IMO. Right now I am unable to even find a CID setting
    anywhere.

    Anyway, your advice seems strangely reminiscent of a suggestion I got
    from the Netcom (my cell phone network) help center: Try *99# instead
    of *99***1#. Presumably, that should just use the next available
    CID. But it did not help.

    | On the mac I discovered I had to fill up the nameserver addresses in the
    | ppp network settings, along with various fields that must be associated
    | to your GPRS provider (gprs "name" in the phone number field, name and
    | password; uncheck "send PPP echo packets" -forgeting this apparently is
    | a killer; no proxie). On R. Barkman site (taniwha...) you also find a
    | table describing these settings by country and phone network.

    Yeah, I tried all those things I think. Actually, his entries for
    Netcom appear to be outdated.

    - Harald
    Harald Hanche-Olsen Guest

  8. #8

    Default SOLVED: Setting up laptop to use the GPRS connection

    + Harald Hanche-Olsen <hanchemath.ntnu.no>:

    | + [email]h.sainctlaposte.net[/email] (Frédérique & Hervé Sainct):
    |
    | | I don't know how the Siemens work, but
    | | check wether the CID in the Siemens setting you use is the same as
    | | the CID in your mac script.

    I did a complete walk through all the menus. No mention of a CID
    anywhere. But anyway, my problem is now solved. And not only that,
    it was my wife who put me on the right track: She said, if it works
    when you type the commands manually, but not when the script does it,
    why not slow the script down? So I edited the script, inserting a
    pause 30 just before the line that dials *99***1#. And, it worked!

    So no I am happy. (Caveat: I had turned the phone off and back on
    earlier, so I am not *completely* sure that wasn't what got it working,
    rather than the pause. But now I am on my way for a vacation, so I
    won't mess with it anymore as long as it works.)

    (A tip, BTW, for anybody who wants to edit their modem scripts: A
    standard Mac text editor won't touch such a script. I used emacs, but
    had to take care not to lose the resource fork. First, I duplicated
    the script using Finder. Then I ran emacs on the copy, and turned on
    backup-by-copying (M-x set-var RET backup-by-copying RET t RET). This
    makes emacs create the backup file as a copy of the original and
    overwrite the original, which preserves the resource fork. The
    backup, of course, will have no resource fork. If you don't do it
    this way, the resource fork winds up with the backup copy, where it
    does no good.)

    --
    * Harald Hanche-Olsen <URL:http://www.math.ntnu.no/~hanche/>
    - Debating gives most of us much more psychological satisfaction
    than thinking does: but it deprives us of whatever chance there is
    of getting closer to the truth. -- C.P. Snow
    Harald Hanche-Olsen Guest

Similar Threads

  1. setting up connection
    By Bushido in forum Macromedia Contribute General Discussion
    Replies: 1
    Last Post: April 7th, 09:53 AM
  2. Setting up new connection
    By Roxanne2 in forum Macromedia Contribute Connection Administrtion
    Replies: 2
    Last Post: January 11th, 01:44 AM
  3. ethernet connection between a laptop and a desktop (crossover cable)
    By Xyerp in forum Linux Setup, Configuration & Administration
    Replies: 0
    Last Post: August 11th, 03:19 PM
  4. Replies: 6
    Last Post: July 18th, 07:30 PM
  5. Internet Connection Setting
    By Juan in forum Windows Networking
    Replies: 1
    Last Post: July 12th, 01:54 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139