I'm not really versed in perl, but created a very simple script to secure ftp files created within my app, which is written in Progress ABL/4GL.

Depending on "how" I run the Progress code that calls the perl script, determines whether the transmission is ultimately successful.

Without going into too much detail you probably don't need, can somebody explain the following debug data as the sftp process ends without a successful transmission:

sftp: sending SSH2_FXP_INIT
Channel 1: rcvd eof
Channel 1: output open => drain
Channel 1: rcvd close
Channel 1: input open => closed
Channel 1: close read
Channel 1: obuf empty
Channel 1: output drain => closed
Channel 1: close_write
Channel 1: send close
Channel 1: full closed
connection closed at: home/it.help/sndbrass.pl line 15

This unsuccessful transmission only occurs when I run the process thru the nightly batch run. However, if I run the process with the same user id outside the nightly batch process, it works.

I wouldn't expect it to be a Progress issue, and the operating system is linux.

And, I should also point out that the files created prior to the sftp ARE being created. The debug message above make it appear like the files attempting to be transmitted are of zero-byte length, but I can assure you they are not. The files are created, then zipped, then the perl script is invoked.

Any info will help - thanks.