Professional Web Applications Themes

Site will not work in IE - Macromedia Dynamic HTML

Can anyone help me figure out why this site will work in every browser except Internet Explorer? Everything just falls apart. Here is a link to the site. Please help. Also, the designer took off the doc type because there was one, the site wouldn't work properly in any browser. Thanks. http://web.mac.com/thewaldengang/ncmf/ncmfweb/index.html...

  1. #1

    Default Site will not work in IE

    Can anyone help me figure out why this site will work in every browser except
    Internet Explorer? Everything just falls apart. Here is a link to the site.
    Please help.

    Also, the designer took off the doc type because there was one, the site
    wouldn't work properly in any browser.

    Thanks.

    http://web.mac.com/thewaldengang/ncmf/ncmfweb/index.html


    pixelchick80 Guest

  2. #2

    Default Re: Site will not work in IE

    I guess you are talking about the Spry menu, which is split between two lines
    on my PC IE7 display with several middle items dropped to the line below. If
    this is not deliberate, then ....

    IE handles padding and margins differently from the other browsers. When I
    get this sort of problem, I parallel preview in IE and FireFox (or whatever)
    and adjust parameters until everything lines up. Tedious experimentation.

    I'll be interested to hear if Murray or anyone else knows a better way.

    akribie Guest

  3. #3

    Default Re: Site will not work in IE

    > IE handles padding and margins differently from the other browsers.

    Not usually, when the page has a valid and complete doctype. There are some
    exceptions, all of which involve floats. But generally it's handled exactly
    the same.

    --
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs, Tutorials & Resources
    ==================


    "akribie" <com> wrote in message
    news:g0tvvv$emc$macromedia.com... 

    Murray Guest

  4. #4

    Default Re: Site will not work in IE

    The designer tried every doc type available, but the site got ed up in every browser. Is the spry menus that are throwing the site for a loop in IE? If so, is there anyway around this?



    pixelchick80 Guest

  5. #5

    Default Re: Site will not work in IE

    The designer tried every doc type available, but the site got ed up in every browser. Is it the spry menus that are throwing the site for a loop in IE? If so, is there anyway around this?



    pixelchick80 Guest

  6. #6

    Default Re: Site will not work in IE

    Changing doctypes will do nothing about a page with bad code. You should
    choose a doctype based not on a random selection process, but on a) your
    skill with HTML, and b) your ability to sustain the restrictions of the
    doctype you choose in your methods and your coding.

    Does the page validate?

    --
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs, Tutorials & Resources
    ==================


    "pixelchick80" <com> wrote in message
    news:g0v0fd$k3i$macromedia.com... 

    Murray Guest

  7. #7

    Default Re: Site will not work in IE

    When I validate the index file in Dreamweaver, I get no errors. However, when I
    check the browser compatibility, it tells me this:

    Line: 149
    Issue: Expanding Box Problem
    Any content that does not fit in a fixed-width or -height box causes the box
    to expand to fit the content rather than letting the content overflow.

    Affects: Internet Explorer 6.0
    Likelihood: Likely

    I know that the problems are coming from the use of Spry menus. I deleted
    them, and the site worked fine. Any suggestions with the spry menus and getting
    them to function properly in IE 6/7?

    I reposted the files with a doctype after I went to the W3C validation site.
    Here is a new link:
    http://parkatdavidson.com/ncmfweb/

    Thanks for your help

    pixelchick80 Guest

Similar Threads

  1. nice work on the new site
    By Mike Mascari in forum PostgreSQL / PGSQL
    Replies: 0
    Last Post: December 22nd, 04:41 PM
  2. site does not work when connected through ssl
    By chris GŁnther in forum PHP Development
    Replies: 1
    Last Post: October 27th, 12:52 PM
  3. Does this site work for you?
    By chameleonmoments webforumsuser@macromedia.com in forum Macromedia Flash Sitedesign
    Replies: 3
    Last Post: October 2nd, 07:06 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139