Professional Web Applications Themes

Slow loading DW Mx website - Macromedia Dreamweaver

I just switched over to DW MX (from frontpage-no jokes please) and have a major problem with a DW website. Since I'm very short on time I attempted to use a dreamweaver-templates. net canned theme to produce a website. The URL is below. Even on a very fast Cable modem connection the website takes 30-50 seconds to laod. The graphics are small in size and there is very litle content in the same site. The web theme creator doesn't have a reason why it loads so slow. The main website (baseballhq.com) loads without a problem. Note the website is on ...

  1. #1

    Default Slow Loading DW MX website

    I just switched over to DW MX (from frontpage-no jokes please) and have a major problem with a DW website. Since I'm very short on time I attempted to use a dreamweaver-templates. net canned theme to produce a website. The URL is below. Even on a very fast Cable modem connection the website takes 30-50 seconds to laod. The graphics are small in size and there is very litle content in the same site.

    The web theme creator doesn't have a reason why it loads so slow. The main website (baseballhq.com) loads without a problem. Note the website is on a Unix server.

    What have I tried?

    I've tried a theme from this company, another company, I even created a basic HTML hand coded page with a few of the graphics and they all load slowly. Any ideas where else to look?

    Any help is greatly appreciated.

    Regards,

    Ken

    [url]http://www.baseballhq.com/template9/index.htm[/url]



    maxmax66 webforumsuser@macromedia.com Guest

  2. #2

    Default Slow loading DW Mx website

    I just switched over to DW MX (from frontpage-no jokes please) and have a
    major problem with a DW website. Since I'm very short on time I attempted
    to use a dreamweaver-templates. net canned theme to produce a website. The
    URL is below. Even on a very fast Cable modem connection the website takes
    30-50 seconds to laod. The graphics are small in size and there is very
    litle content in the same site.

    The web theme creator doesn't have a reason why it loads so slow. The main
    website (baseballhq.com) loads without a problem. Note the website is on a
    Unix server.

    What have I tried?

    I've tried a theme from this company, another company, I even created a
    basic HTML hand coded page with a few of the graphics and they all load
    slowly. Any ideas where else to look?

    Any help is greatly appreciated.

    Regards,

    Ken

    [url]http://www.baseballhq.com/template9/index.htm[/url]

    Ken Guest

  3. #3

    Default Re: Slow Loading DW MX website

    I'm sure this has got nothing to do with DW. We're talking about code, not a
    program.

    If you want to make it faster, however, clean up the lousy code! :) This
    template is just full of it. You can't expect your browser to work magic. It's
    probably trying to figure out what to throw on the screen.

    get rid of this:
    tables/cells have heights - get rid of them, their invalid
    font tags everywhere - <shudder>
    bg colors all over the place

    You have a style sheet there, but for some reason, whoever made this template
    didn't feel it necessary to actually USE it. My suggestion? USE IT! :)

    Also, there isn't much JS there, but you may as well put that in an external
    style sheet as well.
    And while you're there, get rid of the outdated MM_findObj function. Replace
    this:

    function MM_findObj(n, d) { //v4.0
    var p,i,x; if(!d) d=doent; if((p=n.indexOf("?"))>0&&parent.frames.length)
    {
    d=parent.frames[n.substring(p+1)].doent; n=n.substring(0,p);}
    if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++)
    x=d.forms[i][n];
    for(i=0;!x&&d.layers&&i<d.layers.length;i++)
    x=MM_findObj(n,d.layers[i].doent);
    if(!x && doent.getElementById) x=doent.getElementById(n); return x;
    }

    with this:

    function MM_findObj(n, d) { //v4.01
    var p,i,x; if(!d) d=doent; if((p=n.indexOf("?"))>0&&parent.frames.length)
    {
    d=parent.frames[n.substring(p+1)].doent; n=n.substring(0,p);}
    if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++)
    x=d.forms[i][n];
    for(i=0;!x&&d.layers&&i<d.layers.length;i++)
    x=MM_findObj(n,d.layers[i].doent);
    if(!x && d.getElementById) x=d.getElementById(n); return x;
    }

    There are no alt attributes, either.

    You should really look closer at templates before you buy them. Make sure
    they're AT LEAST using valid markup. If they're not...RUN!!

    --
    --
    DiMa
    --------------------
    WEB FORUM USERS: Please log on to the Newsgroup for quicker replies to your
    posts:
    [url]news://forums.macromedia.com/macromedia.dreamweaver[/url]
    For Answers, check here first:
    [url]http://groups.google.com/advanced_group_search?q=+group:macromedia.dreamwea ver[/url]
    [url]http://www.macromedia.com/support/dreamweaver/technotes.html[/url]
    [url]http://www.projectseven.com/faqbase[/url]
    [url]http://www.dreamweaverFAQ.com[/url]

    [url]http://www.macromedia.com/support/forums/etiquette.htm[/url]
    DiMa Design > From Lines...to Designs
    [url]http://www.dimadesign.net[/url]


    "maxmax66" <webforumsusermacromedia.com> wrote in message
    news:bek3bl$h5u$1forums.macromedia.com...
    > I just switched over to DW MX (from frontpage-no jokes please) and have a
    major problem with a DW website. Since I'm very short on time I attempted to
    use a dreamweaver-templates. net canned theme to produce a website. The URL is
    below. Even on a very fast Cable modem connection the website takes 30-50
    seconds to laod. The graphics are small in size and there is very litle content
    in the same site.
    >
    > The web theme creator doesn't have a reason why it loads so slow. The main
    website (baseballhq.com) loads without a problem. Note the website is on a Unix
    server.
    >
    > What have I tried?
    >
    > I've tried a theme from this company, another company, I even created a basic
    HTML hand coded page with a few of the graphics and they all load slowly. Any
    ideas where else to look?
    >
    > Any help is greatly appreciated.
    >
    > Regards,
    >
    > Ken
    >
    > [url]http://www.baseballhq.com/template9/index.htm[/url]
    >
    >

    DiMa Guest

  4. #4

    Default Re: Slow Loading DW MX website

    BTW - it took me 6 seconds on 56K.

    I'd still get rid of the nasty code, though.

    --
    --
    DiMa
    --------------------
    WEB FORUM USERS: Please log on to the Newsgroup for quicker replies to your
    posts:
    [url]news://forums.macromedia.com/macromedia.dreamweaver[/url]
    For Answers, check here first:
    [url]http://groups.google.com/advanced_group_search?q=+group:macromedia.dreamwea ver[/url]
    [url]http://www.macromedia.com/support/dreamweaver/technotes.html[/url]
    [url]http://www.projectseven.com/faqbase[/url]
    [url]http://www.dreamweaverFAQ.com[/url]

    [url]http://www.macromedia.com/support/forums/etiquette.htm[/url]
    DiMa Design > From Lines...to Designs
    [url]http://www.dimadesign.net[/url]


    "DiMa" <dianaYOURHATANDCOATdimadesign.net> wrote in message
    news:bek4pd$k11$1forums.macromedia.com...
    > I'm sure this has got nothing to do with DW. We're talking about code, not a
    > program.
    >
    > If you want to make it faster, however, clean up the lousy code! :) This
    > template is just full of it. You can't expect your browser to work magic.
    It's
    > probably trying to figure out what to throw on the screen.
    >
    > get rid of this:
    > tables/cells have heights - get rid of them, their invalid
    > font tags everywhere - <shudder>
    > bg colors all over the place
    >
    > You have a style sheet there, but for some reason, whoever made this template
    > didn't feel it necessary to actually USE it. My suggestion? USE IT! :)
    >
    > Also, there isn't much JS there, but you may as well put that in an external
    > style sheet as well.
    > And while you're there, get rid of the outdated MM_findObj function. Replace
    > this:
    >
    > function MM_findObj(n, d) { //v4.0
    > var p,i,x; if(!d) d=doent;
    if((p=n.indexOf("?"))>0&&parent.frames.length)
    > {
    > d=parent.frames[n.substring(p+1)].doent; n=n.substring(0,p);}
    > if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++)
    > x=d.forms[i][n];
    > for(i=0;!x&&d.layers&&i<d.layers.length;i++)
    > x=MM_findObj(n,d.layers[i].doent);
    > if(!x && doent.getElementById) x=doent.getElementById(n); return x;
    > }
    >
    > with this:
    >
    > function MM_findObj(n, d) { //v4.01
    > var p,i,x; if(!d) d=doent;
    if((p=n.indexOf("?"))>0&&parent.frames.length)
    > {
    > d=parent.frames[n.substring(p+1)].doent; n=n.substring(0,p);}
    > if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++)
    > x=d.forms[i][n];
    > for(i=0;!x&&d.layers&&i<d.layers.length;i++)
    > x=MM_findObj(n,d.layers[i].doent);
    > if(!x && d.getElementById) x=d.getElementById(n); return x;
    > }
    >
    > There are no alt attributes, either.
    >
    > You should really look closer at templates before you buy them. Make sure
    > they're AT LEAST using valid markup. If they're not...RUN!!
    >
    > --
    > --
    > DiMa
    > --------------------
    > WEB FORUM USERS: Please log on to the Newsgroup for quicker replies to your
    > posts:
    > [url]news://forums.macromedia.com/macromedia.dreamweaver[/url]
    > For Answers, check here first:
    >
    [url]http://groups.google.com/advanced_group_search?q=+group:macromedia.dreamwea ver[/url]
    > [url]http://www.macromedia.com/support/dreamweaver/technotes.html[/url]
    > [url]http://www.projectseven.com/faqbase[/url]
    > [url]http://www.dreamweaverFAQ.com[/url]
    >
    > [url]http://www.macromedia.com/support/forums/etiquette.htm[/url]
    > DiMa Design > From Lines...to Designs
    > [url]http://www.dimadesign.net[/url]
    >
    >
    > "maxmax66" <webforumsusermacromedia.com> wrote in message
    > news:bek3bl$h5u$1forums.macromedia.com...
    > > I just switched over to DW MX (from frontpage-no jokes please) and have a
    > major problem with a DW website. Since I'm very short on time I attempted to
    > use a dreamweaver-templates. net canned theme to produce a website. The URL
    is
    > below. Even on a very fast Cable modem connection the website takes 30-50
    > seconds to laod. The graphics are small in size and there is very litle
    content
    > in the same site.
    > >
    > > The web theme creator doesn't have a reason why it loads so slow. The main
    > website (baseballhq.com) loads without a problem. Note the website is on a
    Unix
    > server.
    > >
    > > What have I tried?
    > >
    > > I've tried a theme from this company, another company, I even created a
    basic
    > HTML hand coded page with a few of the graphics and they all load slowly. Any
    > ideas where else to look?
    > >
    > > Any help is greatly appreciated.
    > >
    > > Regards,
    > >
    > > Ken
    > >
    > > [url]http://www.baseballhq.com/template9/index.htm[/url]
    > >
    > >
    >
    >

    DiMa Guest

  5. #5

    Default Re: Slow Loading DW MX website

    Thanks to Murray and DiMa...I think we'll start from scratch rather than attempt to debugg the site.

    KLLWS5


    maxmax66 webforumsuser@macromedia.com Guest

  6. #6

    Default Re: Slow Loading DW MX website

    max:

    Good luck!

    --
    Murray --- ICQ 71997575
    ==================

    "maxmax66" <webforumsusermacromedia.com> wrote in message
    news:bekf6m$9vm$1forums.macromedia.com...
    > Thanks to Murray and DiMa...I think we'll start from scratch rather than
    attempt to debugg the site.
    >
    > KLLWS5
    >
    >

    Murray *TMM* Guest

  7. #7

    Default Re: Slow loading DW Mx website

    On Thu, 10 Jul 2003 16:19:21 GMT, Ken <kllws55> wrote:
    >I just switched over to DW MX (from frontpage-no jokes please) and have a
    >major problem with a DW website. Since I'm very short on time I attempted
    >to use a dreamweaver-templates. net canned theme to produce a website. The
    >URL is below. Even on a very fast Cable modem connection the website takes
    >30-50 seconds to laod. The graphics are small in size and there is very
    >litle content in the same site.
    >
    >The web theme creator doesn't have a reason why it loads so slow. The main
    >website (baseballhq.com) loads without a problem. Note the website is on a
    >Unix server.
    >
    >What have I tried?
    >
    >I've tried a theme from this company, another company, I even created a
    >basic HTML hand coded page with a few of the graphics and they all load
    >slowly. Any ideas where else to look?
    >
    >Any help is greatly appreciated.
    >
    >Regards,
    >
    >Ken
    >
    >[url]http://www.baseballhq.com/template9/index.htm[/url]
    Site loaded really well for me - sorry!

    It's a nice-looking site, too.

    I know you wanted bad comments, but I can't think of any ;)


    Paul Taylor
    [url]http://www.technocurve.co.uk[/url]
    Paul Taylor Guest

  8. #8

    Default Re: Slow Loading DW MX website

    No worries...there won't *always* be nothing but crap DW templates out there ;)

    Or will there?? <hint hint> :)

    --
    --
    DiMa
    --------------------
    WEB FORUM USERS: Please log on to the Newsgroup for quicker replies to your
    posts:
    [url]news://forums.macromedia.com/macromedia.dreamweaver[/url]
    For Answers, check here first:
    [url]http://groups.google.com/advanced_group_search?q=+group:macromedia.dreamwea ver[/url]
    [url]http://www.macromedia.com/support/dreamweaver/technotes.html[/url]
    [url]http://www.projectseven.com/faqbase[/url]
    [url]http://www.dreamweaverFAQ.com[/url]

    [url]http://www.macromedia.com/support/forums/etiquette.htm[/url]
    DiMa Design > From Lines...to Designs
    [url]http://www.dimadesign.net[/url]


    "maxmax66" <webforumsusermacromedia.com> wrote in message
    news:bekf6m$9vm$1forums.macromedia.com...
    > Thanks to Murray and DiMa...I think we'll start from scratch rather than
    attempt to debugg the site.
    >
    > KLLWS5
    >
    >

    DiMa Guest

Similar Threads

  1. Slow performance of website
    By Mattastic in forum Coldfusion Server Administration
    Replies: 2
    Last Post: September 29th, 07:49 AM
  2. Slow loading
    By just1coder@yahoo.ca in forum ASP Database
    Replies: 2
    Last Post: August 4th, 01:45 PM
  3. Slow Website
    By oz1097 in forum Web Design
    Replies: 1
    Last Post: January 7th, 02:17 AM
  4. Website slow when accessing DB - HELP!!
    By Sprout in forum ASP Database
    Replies: 2
    Last Post: November 8th, 02:27 PM
  5. Website running slow?
    By John in forum Web Design
    Replies: 0
    Last Post: September 22nd, 06:40 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139