Pete Harlan posted a problem and workaround for a problem in a
moderated Debian newsgroup (though this issue is not really related to
Debian specifically):

[url]http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&threadm=SXRp.3ZD.25%40gated-at.bofh.it&rnum=1&prev=/groups%3Fq%3D%2522Can%27t%2Bcall%2Bmethod%2BFETCH% 2Bon%2Ban%2Bundefined%2Bvalue%2522%2Bdebian%26hl%3 Den%26lr%3D%26ie%3DUTF-8%26selm%3DSXRp.3ZD.25%2540gated-at.bofh.it%26rnum%3D1[/url]

The problem is that scripts running under mod_perl die with an error:

Can't call method "FETCH" on an undefined value at
/path/to/my/lib/perl5/5.8.0/CGI/Cookie.pm line 76.

Pete posted a patch (which he admitted was a bit of a kludge) to
Cookie.pm which appears to work (though I haven't really delved into
it to see why, or if it breaks something else).

I also had this problem, and was not readily able to find a less
kludgy answer. I solved the problem and offer my experience here for
benefit of others:

The problem is that mod_perl is not configured with some required
"callback hook." See the INSTALL doc from mod_perl for a list of all
available callback hooks. These are all disabled by default.

I don't really know which one(s) are required to fix the problem with
Cookie.pm (I suspect it's PERL_STACKED_HANDLERS, but I'm not sure); I
took the "big hammer" approach and enabled ALL of them (EVERYTHING=1),
and the problem went away.

In other words, cd to your mod_perl directory (you'll need your Apache
source code as well), and do something like:

perl Makefile.PL DO_HTTPD=1 USE_APACI=1
APACHE_PREFIX=/usr/local/apache EVERYTHING=1
make
make install

(If anyone knows which callback hook(s) is/are specifically needed to
fix this problem, please follow-up)