Professional Web Applications Themes

"Sorry, cannot connect to Calendar Server" - SCO

This annoying message comes up in my new 5.0.7 OpenServer installation. In the past I would just type from root, isverify -I. That would fix the problem. Not in this case. Is there something else I have to do? Regards, RWS [email]transpoweraol.com[/email]...

  1. #1

    Default "Sorry, cannot connect to Calendar Server"

    This annoying message comes up in my new 5.0.7 OpenServer installation. In the
    past I would just type from root, isverify -I. That would fix the problem.
    Not in this case. Is there something else I have to do?

    Regards,
    RWS
    [email]transpoweraol.com[/email]
    Transpower Guest

  2. #2

    Default Re: "Sorry, cannot connect to Calendar Server"

    Transpower wrote:
    > This annoying message comes up in my new 5.0.7 OpenServer installation. In the
    > past I would just type from root, isverify -I. That would fix the problem.
    > Not in this case. Is there something else I have to do?
    Are you using the calendar service? If not, your best bet is to disable
    it: edit /etc/rc2.d/P95calserver, add a line that says "exit 0" to the
    top of the script.

    If you _are_ using the calendar service, then when does this message
    come up? During boot? When you try to use the calendar client?
    >Bela<
    Bela Lubkin Guest

  3. #3

    Default Re: "Sorry, cannot connect to Calendar Server"

    Bela:

    .... when I click on on the Calendar icon in the X-desktop.

    RWS
    [email]transpoweraol.com[/email]
    Transpower Guest

  4. #4

    Default Re: "Sorry, cannot connect to Calendar Server"

    Transpower wrote:
    > ... when I click on on the Calendar icon in the X-desktop.
    I'm sorry, I only half remember the context of this discussion. Please
    use a new posting program which is able to quote context, and _do so_.
    >Bela<
    Bela Lubkin Guest

  5. #5

    Default Re: "Sorry, cannot connect to Calendar Server"

    Bela:

    Subject: Re: "Sorry, cannot connect to Calendar Server"
    > This annoying message comes up in my new 5.0.7 OpenServer installation. In
    the
    > past I would just type from root, isverify -I. That would fix the problem.
    > Not in this case. Is there something else I have to do?
    I am using the Calendar Service. The error message occurs when I double click
    on the Calendar Client icon on the X-windows desk top. There is a "Fatal
    Error" of the Calendar Server during boot.

    RWS
    [email]transpoweraol.com[/email]
    Transpower Guest

  6. #6

    Default Re: "Sorry, cannot connect to Calendar Server"


    "Transpower" <transpoweraol.com> wrote in message
    news:20030804101620.13162.00001245mb-m10.aol.com...
    >
    > > This annoying message comes up in my new 5.0.7 OpenServer installation.
    In
    > the
    > > past I would just type from root, isverify -I. That would fix the
    problem.
    > > Not in this case. Is there something else I have to do?
    >
    > I am using the Calendar Service. The error message occurs when I double
    click
    > on the Calendar Client icon on the X-windows desk top. There is a "Fatal
    > Error" of the Calendar Server during boot.
    Go to /etc/rc2.d/messages and show us the entire contents of
    P95calserver.log
    Do not paraphrase the contents.

    Bob


    Bob Bailin Guest

  7. #7

    Default Re: "Sorry, cannot connect to Calendar Server"

    >Go to /etc/rc2.d/messages and show us the entire contents of
    >P95calserver.log
    >Do not paraphrase the contents.
    Bob, JP, as requested:

    "FATAL ERROR: se '/usr/lib/sco/oadb/caldata/calsrvlog'"

    The contents of calsrvlog:

    Server ID: port = 6373
    machine = non-networked
    servers = 1
    startup date: 08/04/03
    startup time: 17:23:27

    Server is executing ....

    ERRNO = 22, T_ERRNO = 0, ISERRNO = 117
    unable to open '/usr/lib/sco/oadb/caldata/event' database files
    DATE: 08/04/03 TIME: 17:23:27

    Server is exiting! Goodbye!

    ------

    How's that for specificity?

    RWS
    [email]transpoweraol.com[/email]
    Transpower Guest

  8. #8

    Default Re: "Sorry, cannot connect to Calendar Server"

    Transpower wrote:
    > "FATAL ERROR: se '/usr/lib/sco/oadb/caldata/calsrvlog'"
    >
    > The contents of calsrvlog:
    >
    > Server ID: port = 6373
    > machine = non-networked
    > servers = 1
    > startup date: 08/04/03
    > startup time: 17:23:27
    >
    > Server is executing ....
    >
    > ERRNO = 22, T_ERRNO = 0, ISERRNO = 117
    > unable to open '/usr/lib/sco/oadb/caldata/event' database files
    > DATE: 08/04/03 TIME: 17:23:27
    >
    > Server is exiting! Goodbye!
    Ok, now we're getting somewhere. In order for this to have succeeded,
    the directory /usr/lib/sco/oadb/caldata has to exist, and it has to
    contain files named event.dat and event.idx. Does it? We can guess
    that the directory exists since you've shown us the contents of
    calsrvlog from the same directory. Now show us the permissions of the
    involved files:

    # ls -ld /usr/lib/sco/oadb/caldata
    # ls -l /usr/lib/sco/oadb/caldata

    But wait... this is probably your issue. See:

    [url]http://stage.caldera.com/cgi-bin/ssl_reference?105237[/url]
    >Bela<
    Bela Lubkin Guest

  9. #9

    Default Re: "Sorry, cannot connect to Calendar Server"


    "Transpower" <transpoweraol.com> wrote in message
    news:20030805182754.28365.00000043mb-m10.aol.com...
    > Bob:
    >
    > >Either you installed your system on July 29th, or you
    > >tried to set a calendar event at that time and something
    > >got munged up. I suspect the former, and I also suspect
    > >you may have discovered one of those unpleasant side-
    > >effects of upgrading a system rather than doing a
    > >fresh install.
    >
    > I installed the system on July 29. I did not try to set up a calendar
    event.
    > I simply tried to access the calendar client.
    This is probably a language related issue.

    Look in /usr/adm/ISL/iqm_file for the line: IQM_LANGUAGE=
    (easy to find, they're all alphabetical and all start with "IQM_")

    What language is shown? The default is "C_C.C".

    Now look in the file /etc/default/lang for the first two non-comment lines.
    They should both be LANG=C_C.C

    If either of these are not the case on your system,
    you were a little too clever for your own good when installing
    5.0.7 (or the previous version you upgraded from) and
    selected another, seemingly reasonable language choice
    such as "english_us.ascii". Unfortunately, this reasonable
    choice breaks a few scripts & programs such as the
    calendar server, as I found out myself years ago when
    first installing 5.0.2 or 5.0.4.

    Bob


    Bob Bailin Guest

  10. #10

    Default Re: "Sorry, cannot connect to Calendar Server"

    Bob:
    >Look in /usr/adm/ISL/iqm_file for the line: IQM_LANGUAGE=
    >(easy to find, they're all alphabetical and all start with "IQM_")
    >
    >What language is shown? The default is "C_C.C".
    There was no language specified, so I added the default just now.
    >
    >Now look in the file /etc/default/lang for the first two non-comment lines.
    >They should both be LANG=C_C.C
    No, one wasn't so I changed it to the above.
    >
    >If either of these are not the case on your system,
    >you were a little too clever for your own good when installing
    >5.0.7 (or the previous version you upgraded from) and
    >selected another, seemingly reasonable language choice
    >such as "english_us.ascii". Unfortunately, this reasonable
    >choice breaks a few scripts & programs such as the
    >calendar server, as I found out myself years ago when
    >first installing 5.0.2 or 5.0.4.
    Alas, making these changes did not solve the problem. I still get the error
    message "Sorry, cannot connect to Calendar Server". The bootup error message
    is the same as previously posted.

    RWS
    [email]transpoweraol.com[/email]


    Transpower Guest

  11. #11

    Default Re: "Sorry, cannot connect to Calendar Server"


    "Transpower" <transpoweraol.com> wrote in message
    news:20030806181505.21977.00000064mb-m07.aol.com...
    > Bob:
    >
    > >Look in /usr/adm/ISL/iqm_file for the line: IQM_LANGUAGE=
    > >(easy to find, they're all alphabetical and all start with "IQM_")
    > >
    > >What language is shown? The default is "C_C.C".
    >
    > There was no language specified, so I added the default just now.
    The iqm_file is simply a list of the answers you provided during
    installation of 5.0.7. During a fresh installation, one of the questions
    you must answer is which language the system will be using.

    Since you did an upgrade, I guess it never asked you and continued
    to use the same language as the prior edition, whatever that was.
    > >
    > >Now look in the file /etc/default/lang for the first two non-comment
    lines.
    > >They should both be LANG=C_C.C
    >
    > No, one wasn't so I changed it to the above.
    > >
    > >If either of these are not the case on your system,
    > >you were a little too clever for your own good when installing
    > >5.0.7 (or the previous version you upgraded from) and
    > >selected another, seemingly reasonable language choice
    > >such as "english_us.ascii". Unfortunately, this reasonable
    > >choice breaks a few scripts & programs such as the
    > >calendar server, as I found out myself years ago when
    > >first installing 5.0.2 or 5.0.4.
    >
    > Alas, making these changes did not solve the problem. I still get the
    error
    > message "Sorry, cannot connect to Calendar Server". The bootup error
    message
    > is the same as previously posted.
    I think it's time to realize that the upgrade was not an appropriate
    option for you. Eat your losses and start again with a fresh
    install of 5.0.7. If you have other filesystems besides root, you
    can preserve them during the fresh install.

    I'll assume you still have a complete, verified backup of 5.0.4 from
    July 28th. Keep it handy (and write-protected) for future reference.

    Bob


    Bob Bailin Guest

  12. #12

    Default Re: "Sorry, cannot connect to Calendar Server"

    >Eat your losses and start again with a fresh
    >install of 5.0.7.
    Bob, Bela:

    I'm not willing to give up. It's a learning experience to figure out the
    solutions to such problems. Is there a way to uninstall and then reinstall the
    calendar files using custom or customextract?

    RWS
    [email]transpoweraol.com[/email]
    Transpower Guest

  13. #13

    Default Re: "Sorry, cannot connect to Calendar Server"

    Transpower <transpoweraol.com> wrote:
    >>Is there a way to uninstall and then reinstall the
    >>calendar files using custom or customextract?
    >I did just that! I removed the calendar and calendar server (using Software
    >Manager) and then I installed the calendar and calendar server from the master
    >SCO CD. Voila, the calendar now works!
    Which would indicate that the reason it did not work previously was due to the IPU
    retaining something it should not have or otherwise ing up.

    IPU's are more time consuming than they appear.

    I hope some folks are learning something from this.

    --
    [email]tonyaplawrence.com[/email] Unix/Linux/Mac OS X resources: [url]http://aplawrence.com[/url]
    Get paid for writing about tech: [url]http://aplawrence.com/publish.html[/url]
    tony@aplawrence.com Guest

  14. #14

    Default Re: "Sorry, cannot connect to Calendar Server"

    Tony:>Which would indicate that the reason it did not work previously was due
    to
    >the IPU
    >retaining something it should not have or otherwise ing up.
    >
    ....which indicates to me that SCO should do a better job in implementing
    in-place upgrades. It's not the user's fault.

    RWS
    [email]transpoweraol.com[/email]
    Transpower Guest

  15. #15

    Default Re: "Sorry, cannot connect to Calendar Server"

    Transpower <transpoweraol.com> wrote:
    >Tony:>Which would indicate that the reason it did not work previously was due
    >to
    >>the IPU
    >>retaining something it should not have or otherwise ing up.
    >>
    >...which indicates to me that SCO should do a better job in implementing
    >in-place upgrades. It's not the user's fault.
    ???

    Of course it's not the user's fault.

    I contend that no amount of engineering foresight can account for every
    possible up on an IPU.

    If, however, IPU's doented their work as I have suggested at
    [url]http://aplawrence.com/Unixart/ipuvsfreshinstall.html[/url] , I'd be much
    more favorable toward this approach.

    --
    [email]tonyaplawrence.com[/email] Unix/Linux/Mac OS X resources: [url]http://aplawrence.com[/url]
    Get paid for writing about tech: [url]http://aplawrence.com/publish.html[/url]
    tony@aplawrence.com Guest

  16. #16

    Default Re: "Sorry, cannot connect to Calendar Server"

    [email]tonyaplawrence.com[/email] wrote:
    > Transpower <transpoweraol.com> wrote:
    > >Tony:>Which would indicate that the reason it did not work previously was due
    > >to
    > >>the IPU
    > >>retaining something it should not have or otherwise ing up.
    > >>
    >
    > >...which indicates to me that SCO should do a better job in implementing
    > >in-place upgrades. It's not the user's fault.
    >
    > ???
    >
    > Of course it's not the user's fault.
    >
    > I contend that no amount of engineering foresight can account for every
    > possible up on an IPU.
    >
    > If, however, IPU's doented their work as I have suggested at
    > [url]http://aplawrence.com/Unixart/ipuvsfreshinstall.html[/url] , I'd be much
    > more favorable toward this approach.
    And I've said that they do, or close enough for your purposes.

    Now that Transpower has removed and reinstalled his calendar subsystem,
    it's probably too late; if he had a backup of it from before the R&R, he
    could compare it to the current install and probably figure out exactly
    what was wrong.

    He now has a fresh, unconfigured calendar server. If he had previously
    configured it then that configuration would now be lost, and he would be
    scrambling to find it (and 100 other things lost during a fresh
    install). Both routes involve a lot of subtleties.
    >Bela<
    Bela Lubkin Guest

Similar Threads

  1. "Contribute could not connect because the server is downor not acception connections"
    By Roxanne23 in forum Macromedia Contribute Connection Administrtion
    Replies: 3
    Last Post: December 21st, 01:09 AM
  2. how to get a file from the "Testing Server" / "remote view"
    By Cuckoo in forum Macromedia Exchange Dreamweaver Extensions
    Replies: 1
    Last Post: August 3rd, 04:11 AM
  3. Replies: 0
    Last Post: March 23rd, 04:03 PM
  4. Replies: 3
    Last Post: March 7th, 06:36 PM
  5. <tr id="MyRow" runat="server"> ... </tr> doesn't appear in server-side code
    By Elliot M. Rodriguez in forum ASP.NET General
    Replies: 1
    Last Post: July 21st, 02:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139