Professional Web Applications Themes

Sound Card Problem - Linux Setup, Configuration & Administration

Hello All, I have a problem with my onboard sound card. My sound card was auto detected during Linux installation. I found in the /var/log/messages Oct 28 19:41:08 RedHatMinang kernel: Intel 810 + AC97 Audio, version 0.24, 17:59:48 Mar 13 2003 Oct 28 19:41:08 RedHatMinang kernel: PCI: Found IRQ 10 for device 00:1f.5 Oct 28 19:41:08 RedHatMinang kernel: PCI: Sharing IRQ 10 with 02:05.0 Oct 28 19:41:08 RedHatMinang kernel: i810: Intel ICH2 found at IO 0x9400 and 0x9800, MEM 0x0000 and 0x0000, IRQ 10 Oct 28 19:41:08 RedHatMinang kernel: i810_audio: Audio Controller supports 6 channels. Oct 28 19:41:08 RedHatMinang kernel: ...

  1. #1

    Default Sound Card Problem

    Hello All,

    I have a problem with my onboard sound card.
    My sound card was auto detected during Linux installation.

    I found in the /var/log/messages

    Oct 28 19:41:08 RedHatMinang kernel: Intel 810 + AC97 Audio, version 0.24,
    17:59:48 Mar 13 2003
    Oct 28 19:41:08 RedHatMinang kernel: PCI: Found IRQ 10 for device 00:1f.5
    Oct 28 19:41:08 RedHatMinang kernel: PCI: Sharing IRQ 10 with 02:05.0
    Oct 28 19:41:08 RedHatMinang kernel: i810: Intel ICH2 found at IO 0x9400 and
    0x9800, MEM 0x0000 and 0x0000, IRQ 10
    Oct 28 19:41:08 RedHatMinang kernel: i810_audio: Audio Controller supports 6
    channels.
    Oct 28 19:41:08 RedHatMinang kernel: i810_audio: Defaulting to base 2
    channel mode.
    Oct 28 19:41:08 RedHatMinang kernel: i810_audio: Resetting connection 0
    Oct 28 19:41:08 RedHatMinang kernel: ac97_codec: AC97 Audio codec, id:
    ADS112 (Unknown)
    Oct 28 19:41:08 RedHatMinang kernel: i810_audio: AC'97 codec 0 supports
    AMAP, total channels = 6

    I run redhat-config-soundcard and I click "Play test sound", no sound come
    out of my speaker. My sound card is Ok in Windows 2000.


    Below is my /etc/module.conf

    [rootRedHatMinang /usr/include/asm ]# cat /etc/modules.conf
    alias usb-controller ehci-hcd
    alias usb-controller1 usb-uhci
    alias eth0 via-rhine
    alias eth1 tulip
    alias sound-slot-0 i810_audio
    post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
    2>&1 || :
    pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null
    2>&1 || :
    [rootRedHatMinang /usr/include/asm ]#

    Below is my /etc/.aumixrc

    [rootRedHatMinang /usr/include/asm ]# cat /etc/.aumixrc
    vol:67:67:P
    pcm:67:67:P
    speaker:67:0:P
    line:67:67:P
    mic:0:0:R
    cd:67:67:P
    pcm2:67:67:P
    igain:67:67:P
    line1:67:67:P
    phin:67:0:P
    phout:67:0:P
    video:67:67:P
    [rootRedHatMinang /usr/include/asm ]#

    Below is uname -a

    [rootRedHatMinang /usr/include/asm ]# uname -a
    Linux RedHatMinang 2.4.20-8 #1 Thu Mar 13 17:54:28 EST 2003 i686 i686 i386
    GNU/Linux
    [rootRedHatMinang /usr/include/asm ]#

    I tried to install alsa-driver 0.9.8 but fail in "make" command

    Would you tell me why my sound card does not work ?


    Thanks


    Yuki


    Yuki Guest

  2. #2

    Default Re: Sound Card Problem

    Yuki Arif wrote:
     

    ............... CRIPE SAKES Yuki ... STOP multi-posting !!!!!!!
    ..
    --
    /// Michael J. Tobler: motorcyclist, surfer, skydiver, \\\
    \\\ and author: "Inside Linux", "C++ HowTo", "C++ Unleashed" ///
    While money doesn't buy love, it puts you in a great
    bargaining position.

    mjt Guest

  3. #3

    Default Re: Sound Card Problem

    Yuki Arif wrote:
     
    > pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null
    > 2>&1 || :
    > [rootRedHatMinang /usr/include/asm ]#
    >
    > Below is my /etc/.aumixrc
    >
    > [rootRedHatMinang /usr/include/asm ]# cat /etc/.aumixrc
    > vol:67:67:P
    > pcm:67:67:P
    > speaker:67:0:P
    > line:67:67:P
    > mic:0:0:R
    > cd:67:67:P
    > pcm2:67:67:P
    > igain:67:67:P
    > line1:67:67:P
    > phin:67:0:P
    > phout:67:0:P
    > video:67:67:P
    > [rootRedHatMinang /usr/include/asm ]#
    >
    > Below is uname -a
    >
    > [rootRedHatMinang /usr/include/asm ]# uname -a
    > Linux RedHatMinang 2.4.20-8 #1 Thu Mar 13 17:54:28 EST 2003 i686 i686 i386
    > GNU/Linux
    > [rootRedHatMinang /usr/include/asm ]#
    >
    > I tried to install alsa-driver 0.9.8 but fail in "make" command
    >
    > Would you tell me why my sound card does not work ?
    >
    >
    > Thanks
    >
    >
    > Yuki[/ref]

    "They" claim that the 2.4 kernels support AC97 soundcards, but plenty still
    seem to be having trouble with them. I have turned mine off and installed
    a Creative Vibra card.

    Doug.
    --
    Registered Linux User No. 277548.
    They say lightning never strikes twice in the same place. My typing is
    about as accurate. Apologies for any typos that slip in. - Doug.
    Doug Guest

  4. #4

    Default Re: Sound Card Problem

    mjt wrote:
     
    >
    > .............. CRIPE SAKES Yuki ... STOP multi-posting !!!!!!!
    > .[/ref]
    It is possible to post to several newsgroups by cross-posting. This means
    listing several groups in the "Groups" line and putting only one group in
    the "Follow-up" line. Much quicker than posting repeatedly to multiple
    groups, and all your answers go to the one place. As far as I can see, you
    haven't posted to an irrelevant group. My newsreader is set to ignore
    messages posted to more than 5 groups, but it wouldn't catch yours, which
    are posted to one at a time.

    HTH,

    Doug.
    --
    Registered Linux User No. 277548.
    They say lightning never strikes twice in the same place. My typing is
    about as accurate. Apologies for any typos that slip in. - Doug.
    Doug Guest

Similar Threads

  1. No sound card on citrix server ...
    By myspacee in forum Macromedia Flash Player
    Replies: 0
    Last Post: April 13th, 08:21 AM
  2. Best pci sound card for linux
    By David. in forum Linux Setup, Configuration & Administration
    Replies: 2
    Last Post: October 11th, 12:53 AM
  3. Replies: 0
    Last Post: July 17th, 02:00 PM
  4. Sound card recommendations?
    By Kirk Strauser in forum Debian
    Replies: 2
    Last Post: July 7th, 08:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139