Professional Web Applications Themes

Specify location of port install? - FreeBSD

On Tue, 2005-02-15 at 09:29 -0800, Michael C. Shultz wrote: > If the port is prefix compliant you should be able to do > > make PREFIX=/alternate base dir/ > > Then watch out for libraries the port installs, because > they will end up in /alternate base dir/lib. When that happens > run ldconfig -m /alternate base dir/lib, add /alternate base dir/bin > to your path and everything should be set. Thanks. Couldn't get it to work with gpgme03. I have gpgme installed (as it's needed by a number of my installed ports) but I'm trying to install a ...

  1. #1

    Default Re: Specify location of port install?

    On Tue, 2005-02-15 at 09:29 -0800, Michael C. Shultz wrote:
    > If the port is prefix compliant you should be able to do
    >
    > make PREFIX=/alternate base dir/
    >
    > Then watch out for libraries the port installs, because
    > they will end up in /alternate base dir/lib. When that happens
    > run ldconfig -m /alternate base dir/lib, add /alternate base dir/bin
    > to your path and everything should be set.
    Thanks. Couldn't get it to work with gpgme03. I have gpgme installed
    (as it's needed by a number of my installed ports) but I'm trying to
    install a sylpheed-claws-gtk2 tarball with gpg-mime support and it
    doesn't work with the newer gpgme 1.0.x versions.

    I have both
    /usr/local/bin/gpgme-config
    /usr/local/bin/gpgme03-config

    and I think I'm getting errors when installing because they're both in
    identical paths and it's trying to build against the newer version. It
    builds fine if I disable pgp-mime support.

    For example, the --help file says:

    ~/src/sylpheed-claws$ ./configure --help | grep gpg
    --with-gpgme-prefix=PFX prefix where GPGME is installed (optional)

    So I've been trying to build with:

    --with-gpgme-prefix=/usr/local

    Any ideas how I might work around this?

    Thanks.

    --
    Cheers,
    Trey
    ---

    When you have robbed a man of everything, he is no longer in your power.
    He is free again.
    -- Alexander Solzhenitsyn

    6:14PM up 21:24, 0 users, load averages: 0.77, 0.45, 0.29
    FreeBSD salamander.thesizemores.net 5.3-STABLE i386

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.0 (FreeBSD)

    iD8DBQBCEoOo9VBpGyCc6+gRAvqTAJ41P+gmoAwKcdq9aFF6y7 vuUjKQ4gCfcTa2
    fwdUlOMb+TgvRihFOe9DtUk=
    =2URO
    -----END PGP SIGNATURE-----

    Trey Sizemore Guest

  2. #2

    Default Re: Specify location of port install?

    On Tuesday 15 February 2005 03:20 pm, Trey Sizemore wrote:
    > On Tue, 2005-02-15 at 09:29 -0800, Michael C. Shultz wrote:
    > > If the port is prefix compliant you should be able to do
    > >
    > > make PREFIX=/alternate base dir/
    > >
    > > Then watch out for libraries the port installs, because
    > > they will end up in /alternate base dir/lib. When that happens
    > > run ldconfig -m /alternate base dir/lib, add /alternate base
    > > dir/bin to your path and everything should be set.
    >
    > Thanks. Couldn't get it to work with gpgme03. I have gpgme
    > installed (as it's needed by a number of my installed ports) but I'm
    > trying to install a sylpheed-claws-gtk2 tarball with gpg-mime support
    > and it doesn't work with the newer gpgme 1.0.x versions.
    >
    > I have both
    > /usr/local/bin/gpgme-config
    > /usr/local/bin/gpgme03-config
    >
    > and I think I'm getting errors when installing because they're both
    > in identical paths and it's trying to build against the newer
    > version. It builds fine if I disable pgp-mime support.
    >
    > For example, the --help file says:
    >
    > ~/src/sylpheed-claws$ ./configure --help | grep gpg
    > --with-gpgme-prefix=PFX prefix where GPGME is installed (optional)
    >
    > So I've been trying to build with:
    >
    > --with-gpgme-prefix=/usr/local
    >
    > Any ideas how I might work around this?
    >
    > Thanks.
    Well prefix=/usr/local by default, in otherwords
    you change nothing when you use that setting.
    Why not try prefix=/home/your home dir/TEMP?

    -Mike
    Michael C. Shultz Guest

Similar Threads

  1. Error: That location is controlled by another site.Please choose another location
    By zelen2 in forum Macromedia Contribute Connection Administrtion
    Replies: 0
    Last Post: February 24th, 03:36 PM
  2. how to configure a port for install
    By Bob Ababurko in forum FreeBSD
    Replies: 0
    Last Post: February 16th, 09:35 PM
  3. Replies: 1
    Last Post: December 15th, 09:08 PM
  4. Replies: 2
    Last Post: September 15th, 08:36 AM
  5. Change address location in WSDL to port 8080
    By Mark in forum ASP.NET Web Services
    Replies: 1
    Last Post: July 13th, 04:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139