Professional Web Applications Themes

SSH tunneling to vsftpd not working RH8 - Linux Setup, Configuration & Administration

Sam Nichols wrote: > So with some help from Kenneth I've got a tunnel (on 20 and 21) to my > linux server from my local machine and am running vsftpd on the server. > Problem is when I 'ftp localhost' it gives me 'ftp: connect to address > ::1: Connection refused' and won't connect. I did some testing and the > tunnel works (I made a tunnel to 22 [ssh] and it worked fine), I think > the problem is with vsftpd. I looked through the manual and all the > vsftpd.conf options but nothing fixed it, any ideas? ...

  1. #1

    Default Re: SSH tunneling to vsftpd not working RH8

    Sam Nichols wrote:
    > So with some help from Kenneth I've got a tunnel (on 20 and 21) to my
    > linux server from my local machine and am running vsftpd on the server.
    > Problem is when I 'ftp localhost' it gives me 'ftp: connect to address
    > ::1: Connection refused' and won't connect. I did some testing and the
    > tunnel works (I made a tunnel to 22 [ssh] and it worked fine), I think
    > the problem is with vsftpd. I looked through the manual and all the
    > vsftpd.conf options but nothing fixed it, any ideas?
    May I suggest that you proceed directly to an SSH client with a chroot
    cage on the server to get the same sort safe file-transfer environment,
    and simply not bother with the FTP server?

    Nico Kadel-Garcia Guest

  2. #2

    Default Re: SSH tunneling to vsftpd not working RH8

    In article <jh_Ka.29347$pH3.11564news2.east.cox.net>,
    "Kenneth A Kauffman" <kkauffmannospam.headfog.com> wrote:
    > "Nico Kadel-Garcia" <nkadelverizon.net> wrote in message
    > news:uHLKa.276$oF.264nwrdny03.gnilink.net...
    > > Sam Nichols wrote:
    > >
    > > > So with some help from Kenneth I've got a tunnel (on 20 and 21) to my
    > > > linux server from my local machine and am running vsftpd on the server.
    > > > Problem is when I 'ftp localhost' it gives me 'ftp: connect to address
    > > > ::1: Connection refused' and won't connect. I did some testing and the
    > > > tunnel works (I made a tunnel to 22 [ssh] and it worked fine), I think
    > > > the problem is with vsftpd. I looked through the manual and all the
    > > > vsftpd.conf options but nothing fixed it, any ideas?
    > >
    > > May I suggest that you proceed directly to an SSH client with a chroot
    > > cage on the server to get the same sort safe file-transfer environment,
    > > and simply not bother with the FTP server?
    > >
    >
    > If I recall correctly, he has a specific client that he needs to use that
    > only supports FTP. However, by using port forwarding, he should be able to
    > connect directly to the FTP server via the SSH tunnel.
    >
    > Assuming you are using putty on the windows side:
    >
    > in the SSH Tunnels definition add:
    > SOURCE PORT : 20 DESTINATION (local): <ip of the ftp server listening
    > address>:20
    > SOURCE PORT : 21 DESTINATION (local): <ip of the ftp server listening
    > address>:21
    >
    > Your entries should then look like this in the window:
    > L20 <yourip>:20
    > L21 <yourip>:21
    >
    > Save the settings.
    >
    > Now SSH into your remote machine. Once you have SSHd into the remote
    > machine the tunnel is "ready" to be used. This is important. From your FTP
    > client, you will wan to FTP into hostname "localhost" and NOT the remote IP
    > address. The redirection will occur in the SSH forwarding tunnel. It
    > basically takes the localhost:<port> and forwards it to the address you
    > specified in putty.
    >
    > If you are not using putty, you will need to figure out how to do this with
    > whatever your SSH client is.
    >
    > I've tested this out from work to my home machine using a remote FTP client.
    > This is the only solution I can think of because of the limited nature of
    > the FTP client you are using.
    >
    > ken k
    Yes, I have a client that will only use FTP (BBEdit) so I need to use a
    tunnel to FTP. And I'm pretty sure the connections are solid, and there
    is something preventing the tunnel from talking to the FTP port, I'm on
    a unix box (OS X). I've got the two connections running:

    ssh -l <user> -f -N -L 21:host.net:21 host.net
    ssh -l <user> -f -N -L 20:host.net:20 host.net

    If I ftp localhost it gives me:

    'ftp: connect to address ::1: Connection refused'

    I also setup a tunnel to one of our work computers and ftp'd to that and
    it worked fine so I know in theory my ftp tunnel should work. Also, as
    another test, I did:

    ssh -l <user> -f -N -L 9999:host.net:22 host.net

    Which is the ssh port, and then ran 'telnet <user>localhost 9999' and
    the tunnel worked, it connected me to my ssh port on the remote machine
    so I know the tunnel should work to my remote machine. Which leads me
    to the conclusion that vsftpd is rejecting my advances for some reason
    but I can't figure out why :(
    Sam Nichols Guest

  3. #3

    Default Re: SSH tunneling to vsftpd not working RH8


    "Sam Nichols" <sizaminerd.net> wrote in message
    news:sizam-34B918.10110327062003news.stanford.edu...
    > In article <jh_Ka.29347$pH3.11564news2.east.cox.net>,
    > "Kenneth A Kauffman" <kkauffmannospam.headfog.com> wrote:
    >
    > > "Nico Kadel-Garcia" <nkadelverizon.net> wrote in message
    > > news:uHLKa.276$oF.264nwrdny03.gnilink.net...
    > > > Sam Nichols wrote:
    > > >
    > > > > So with some help from Kenneth I've got a tunnel (on 20 and 21) to
    my
    > > > > linux server from my local machine and am running vsftpd on the
    server.
    > > > > Problem is when I 'ftp localhost' it gives me 'ftp: connect to
    address
    > > > > ::1: Connection refused' and won't connect. I did some testing and
    the
    > > > > tunnel works (I made a tunnel to 22 [ssh] and it worked fine), I
    think
    > > > > the problem is with vsftpd. I looked through the manual and all the
    > > > > vsftpd.conf options but nothing fixed it, any ideas?
    > > >
    > > > May I suggest that you proceed directly to an SSH client with a chroot
    > > > cage on the server to get the same sort safe file-transfer
    environment,
    > > > and simply not bother with the FTP server?
    > > >
    > >
    > > If I recall correctly, he has a specific client that he needs to use
    that
    > > only supports FTP. However, by using port forwarding, he should be able
    to
    > > connect directly to the FTP server via the SSH tunnel.
    > >
    > > Assuming you are using putty on the windows side:
    > >
    > > in the SSH Tunnels definition add:
    > > SOURCE PORT : 20 DESTINATION (local): <ip of the ftp server
    listening
    > > address>:20
    > > SOURCE PORT : 21 DESTINATION (local): <ip of the ftp server
    listening
    > > address>:21
    > >
    > > Your entries should then look like this in the window:
    > > L20 <yourip>:20
    > > L21 <yourip>:21
    > >
    > > Save the settings.
    > >
    > > Now SSH into your remote machine. Once you have SSHd into the remote
    > > machine the tunnel is "ready" to be used. This is important. From your
    FTP
    > > client, you will wan to FTP into hostname "localhost" and NOT the remote
    IP
    > > address. The redirection will occur in the SSH forwarding tunnel. It
    > > basically takes the localhost:<port> and forwards it to the address you
    > > specified in putty.
    > >
    > > If you are not using putty, you will need to figure out how to do this
    with
    > > whatever your SSH client is.
    > >
    > > I've tested this out from work to my home machine using a remote FTP
    client.
    > > This is the only solution I can think of because of the limited nature
    of
    > > the FTP client you are using.
    > >
    > > ken k
    >
    > Yes, I have a client that will only use FTP (BBEdit) so I need to use a
    > tunnel to FTP. And I'm pretty sure the connections are solid, and there
    > is something preventing the tunnel from talking to the FTP port, I'm on
    > a unix box (OS X). I've got the two connections running:
    >
    > ssh -l <user> -f -N -L 21:host.net:21 host.net
    > ssh -l <user> -f -N -L 20:host.net:20 host.net
    >
    > If I ftp localhost it gives me:
    >
    > 'ftp: connect to address ::1: Connection refused'
    >
    > I also setup a tunnel to one of our work computers and ftp'd to that and
    > it worked fine so I know in theory my ftp tunnel should work. Also, as
    > another test, I did:
    >
    > ssh -l <user> -f -N -L 9999:host.net:22 host.net
    >
    > Which is the ssh port, and then ran 'telnet <user>localhost 9999' and
    > the tunnel worked, it connected me to my ssh port on the remote machine
    > so I know the tunnel should work to my remote machine. Which leads me
    > to the conclusion that vsftpd is rejecting my advances for some reason
    > but I can't figure out why :(
    Instead of host.net, try the actual IP assigned to the NIC card and give
    that a whirl. Also make sure that VSFTP is listening on that IP address.

    ken k


    Kenneth A Kauffman Guest

  4. #4

    Default Re: SSH tunneling to vsftpd not working RH8


    "Sam Nichols" <sizaminerd.net> wrote in message
    news:sizam-34B918.10110327062003news.stanford.edu...
    > In article <jh_Ka.29347$pH3.11564news2.east.cox.net>,
    > "Kenneth A Kauffman" <kkauffmannospam.headfog.com> wrote:
    >
    > > "Nico Kadel-Garcia" <nkadelverizon.net> wrote in message
    > > news:uHLKa.276$oF.264nwrdny03.gnilink.net...
    > > > Sam Nichols wrote:
    > > >
    > > > > So with some help from Kenneth I've got a tunnel (on 20 and 21) to
    my
    > > > > linux server from my local machine and am running vsftpd on the
    server.
    > > > > Problem is when I 'ftp localhost' it gives me 'ftp: connect to
    address
    > > > > ::1: Connection refused' and won't connect. I did some testing and
    the
    > > > > tunnel works (I made a tunnel to 22 [ssh] and it worked fine), I
    think
    > > > > the problem is with vsftpd. I looked through the manual and all the
    > > > > vsftpd.conf options but nothing fixed it, any ideas?
    > > >
    > > > May I suggest that you proceed directly to an SSH client with a chroot
    > > > cage on the server to get the same sort safe file-transfer
    environment,
    > > > and simply not bother with the FTP server?
    > > >
    > >
    > > If I recall correctly, he has a specific client that he needs to use
    that
    > > only supports FTP. However, by using port forwarding, he should be able
    to
    > > connect directly to the FTP server via the SSH tunnel.
    > >
    > > Assuming you are using putty on the windows side:
    > >
    > > in the SSH Tunnels definition add:
    > > SOURCE PORT : 20 DESTINATION (local): <ip of the ftp server
    listening
    > > address>:20
    > > SOURCE PORT : 21 DESTINATION (local): <ip of the ftp server
    listening
    > > address>:21
    > >
    > > Your entries should then look like this in the window:
    > > L20 <yourip>:20
    > > L21 <yourip>:21
    > >
    > > Save the settings.
    > >
    > > Now SSH into your remote machine. Once you have SSHd into the remote
    > > machine the tunnel is "ready" to be used. This is important. From your
    FTP
    > > client, you will wan to FTP into hostname "localhost" and NOT the remote
    IP
    > > address. The redirection will occur in the SSH forwarding tunnel. It
    > > basically takes the localhost:<port> and forwards it to the address you
    > > specified in putty.
    > >
    > > If you are not using putty, you will need to figure out how to do this
    with
    > > whatever your SSH client is.
    > >
    > > I've tested this out from work to my home machine using a remote FTP
    client.
    > > This is the only solution I can think of because of the limited nature
    of
    > > the FTP client you are using.
    > >
    > > ken k
    >
    > Yes, I have a client that will only use FTP (BBEdit) so I need to use a
    > tunnel to FTP. And I'm pretty sure the connections are solid, and there
    > is something preventing the tunnel from talking to the FTP port, I'm on
    > a unix box (OS X). I've got the two connections running:
    >
    > ssh -l <user> -f -N -L 21:host.net:21 host.net
    > ssh -l <user> -f -N -L 20:host.net:20 host.net
    >
    > If I ftp localhost it gives me:
    >
    > 'ftp: connect to address ::1: Connection refused'
    >
    > I also setup a tunnel to one of our work computers and ftp'd to that and
    > it worked fine so I know in theory my ftp tunnel should work. Also, as
    > another test, I did:
    >
    > ssh -l <user> -f -N -L 9999:host.net:22 host.net
    >
    > Which is the ssh port, and then ran 'telnet <user>localhost 9999' and
    > the tunnel worked, it connected me to my ssh port on the remote machine
    > so I know the tunnel should work to my remote machine. Which leads me
    > to the conclusion that vsftpd is rejecting my advances for some reason
    > but I can't figure out why :(
    Also, have you tried it without the -f and -N options (just in case).

    ken k


    Kenneth A Kauffman Guest

  5. #5

    Default Re: SSH tunneling to vsftpd not working RH8

    In article <9m0La.29591$pH3.7822news2.east.cox.net>,
    "Kenneth A Kauffman" <kkauffmannospam.headfog.com> wrote:
    > "Sam Nichols" <sizaminerd.net> wrote in message
    > news:sizam-34B918.10110327062003news.stanford.edu...
    > > In article <jh_Ka.29347$pH3.11564news2.east.cox.net>,
    > > "Kenneth A Kauffman" <kkauffmannospam.headfog.com> wrote:
    > >
    > > > "Nico Kadel-Garcia" <nkadelverizon.net> wrote in message
    > > > news:uHLKa.276$oF.264nwrdny03.gnilink.net...
    > > > > Sam Nichols wrote:
    > > > >
    > > > > > So with some help from Kenneth I've got a tunnel (on 20 and 21) to
    > my
    > > > > > linux server from my local machine and am running vsftpd on the
    > server.
    > > > > > Problem is when I 'ftp localhost' it gives me 'ftp: connect to
    > address
    > > > > > ::1: Connection refused' and won't connect. I did some testing and
    > the
    > > > > > tunnel works (I made a tunnel to 22 [ssh] and it worked fine), I
    > think
    > > > > > the problem is with vsftpd. I looked through the manual and all the
    > > > > > vsftpd.conf options but nothing fixed it, any ideas?
    > > > >
    > > > > May I suggest that you proceed directly to an SSH client with a chroot
    > > > > cage on the server to get the same sort safe file-transfer
    > environment,
    > > > > and simply not bother with the FTP server?
    > > > >
    > > >
    > > > If I recall correctly, he has a specific client that he needs to use
    > that
    > > > only supports FTP. However, by using port forwarding, he should be able
    > to
    > > > connect directly to the FTP server via the SSH tunnel.
    > > >
    > > > Assuming you are using putty on the windows side:
    > > >
    > > > in the SSH Tunnels definition add:
    > > > SOURCE PORT : 20 DESTINATION (local): <ip of the ftp server
    > listening
    > > > address>:20
    > > > SOURCE PORT : 21 DESTINATION (local): <ip of the ftp server
    > listening
    > > > address>:21
    > > >
    > > > Your entries should then look like this in the window:
    > > > L20 <yourip>:20
    > > > L21 <yourip>:21
    > > >
    > > > Save the settings.
    > > >
    > > > Now SSH into your remote machine. Once you have SSHd into the remote
    > > > machine the tunnel is "ready" to be used. This is important. From your
    > FTP
    > > > client, you will wan to FTP into hostname "localhost" and NOT the remote
    > IP
    > > > address. The redirection will occur in the SSH forwarding tunnel. It
    > > > basically takes the localhost:<port> and forwards it to the address you
    > > > specified in putty.
    > > >
    > > > If you are not using putty, you will need to figure out how to do this
    > with
    > > > whatever your SSH client is.
    > > >
    > > > I've tested this out from work to my home machine using a remote FTP
    > client.
    > > > This is the only solution I can think of because of the limited nature
    > of
    > > > the FTP client you are using.
    > > >
    > > > ken k
    > >
    > > Yes, I have a client that will only use FTP (BBEdit) so I need to use a
    > > tunnel to FTP. And I'm pretty sure the connections are solid, and there
    > > is something preventing the tunnel from talking to the FTP port, I'm on
    > > a unix box (OS X). I've got the two connections running:
    > >
    > > ssh -l <user> -f -N -L 21:host.net:21 host.net
    > > ssh -l <user> -f -N -L 20:host.net:20 host.net
    > >
    > > If I ftp localhost it gives me:
    > >
    > > 'ftp: connect to address ::1: Connection refused'
    > >
    > > I also setup a tunnel to one of our work computers and ftp'd to that and
    > > it worked fine so I know in theory my ftp tunnel should work. Also, as
    > > another test, I did:
    > >
    > > ssh -l <user> -f -N -L 9999:host.net:22 host.net
    > >
    > > Which is the ssh port, and then ran 'telnet <user>localhost 9999' and
    > > the tunnel worked, it connected me to my ssh port on the remote machine
    > > so I know the tunnel should work to my remote machine. Which leads me
    > > to the conclusion that vsftpd is rejecting my advances for some reason
    > > but I can't figure out why :(
    >
    > Instead of host.net, try the actual IP assigned to the NIC card and give
    > that a whirl. Also make sure that VSFTP is listening on that IP address.
    >
    > ken k
    >
    >
    Nope, no dice, its just not happening. I think I'll just set my
    iptables to only listen to connections from my IP on port 21 and run
    with it, unfortuantly.
    Sam Nichols Guest

Similar Threads

  1. http tunneling not working well.
    By yuvallahav in forum Macromedia Flash Flashcom
    Replies: 5
    Last Post: April 7th, 02:59 PM
  2. vsftpd
    By pkt in forum Linux / Unix Administration
    Replies: 1
    Last Post: February 23rd, 09:19 PM
  3. vsftpd setup
    By wesley in forum Linux Setup, Configuration & Administration
    Replies: 16
    Last Post: October 16th, 05:01 PM
  4. vsftpd questions
    By David in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: September 21st, 09:05 PM
  5. Starting vsftpd
    By Vwakes in forum Linux Setup, Configuration & Administration
    Replies: 2
    Last Post: July 1st, 02:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139