Hi everybody,

I've been setting up a RH 7.2 system for a while to serve as my
router/firewall for a home network.
I did the initial setup behind my previous router. Everything worked OK
when I had the system set up this way. The boot sequence proceeded
normally, the printer worked and all that.
The other day, I actually made the switch. Now, the RH system
interfaces between my cable modem and the rest of my network. When I
booted the first time, instead of coming up to the graphical login
screen, it comes up with a console login prompt. I can still get to the
graphical interface by logging in and then typing 'startx'. The
/etc/inittab still has a 'command' to enter run-level 5, but it never does.
In addition, during the boot sequence, I get "failed" notification when
the system is trying to start the LPD service. I get the following message:
Starting LPD: 2003-08-05-19:09:06 Get_Local_Host: hostname "" bad.

I have changed the xx above from it's actual value. I assigned my
hostname by doing an ifconfig on my external ethernet I/F, and then
entering the command:

host {IP Address from ifconfig}

In response, I got "xx.yyyyy.pa.comcast.net" and entered in this
whole string as the hostname for the system in the
/etc/sysconfig/network file.

My questions are:
1) What do I need to do to get the LPD service running?

2) Is the boot problem (not booting into the graphical login) related to
the LPR problem? If not, any guesses as to what is causing this?

Thanks in advance,
Jon