Professional Web Applications Themes

Text mode in init 5! NVIDIA drivers - Linux Setup, Configuration & Administration

I hope that these questions are not too dumb. I recently installed RedHat Advanced Server 2.1. When I installed, I didn't see my video card, so I just used the default, or generic. I got nice graphics during the install, and used the mouse. Now, when I boot, the default init level is 5. However, I only ever get the text prompt. It looks like an old DOS computer screen. The video card is: nvidia gforce fx 5200 that came with the Dell. I looked on the nvidia website for the drivers at: http://www.nvidia.com/object/linux.html and http://www.nvidia.com/object/linux_display_ia32_1.0-4496.html and found: Version: 1.0-4496 ...

  1. #1

    Default Text mode in init 5! NVIDIA drivers

    I hope that these questions are not too dumb.

    I recently installed RedHat Advanced Server 2.1.
    When I installed, I didn't see my video card, so I
    just used the default, or generic. I got nice graphics
    during the install, and used the mouse.

    Now, when I boot, the default init level is 5.
    However, I only ever get the text prompt. It looks
    like an old DOS computer screen.


    The video card is:
    nvidia gforce fx 5200
    that came with the Dell.

    I looked on the nvidia website for the drivers at:

    http://www.nvidia.com/object/linux.html
    and
    http://www.nvidia.com/object/linux_display_ia32_1.0-4496.html

    and found:
    Version: 1.0-4496
    Operating System: Linux IA32
    Release Date: July 28, 2003

    It says that it supports:
    GeForce FX 5900 support

    Do you think that these would work with my 5200?

    I emailed nvidia, but their support had close to
    a 100% failure ratio. The only reason it is not
    100% failure is that it had automatic response bots
    to tell me to go away and figure it out myself,
    or bother someone else. Thus, I'm asking you guys.
    Sorry.
    linuxquestion@yahoo.com Guest

  2. #2

    Default Re: Text mode in init 5! NVIDIA drivers

    [ non-Linux NGs removed ]
    ["Followup-To:" header set to comp.os.linux.hardware.] On 24 Nov 2003
    18:57:16 -0800, com staggered into the Black Sun and
    said: 

    We were all newbies once.
     

    During the install, RHAS was using the VESA framebuffer. This always
    works, but it's slow and is not recommended if you're going to actually
    sit at the machine's console and use X.
     

    Did you configure X properly, using the X configuration tool provided by
    Redhat? If this machine is really going to be a server, why does it
    need X? If it's going to be a desktop, why did you pay the extra for
    RHAS?
     
    [nVidia evil binary-only kernel modules and such] 

    Yes, if you read the README and follow the directions. Alternatively,
    and perhaps more easily, you can use the Free "nv" X server, which will
    work as long as you don't need hardware-accelerated 3D. (Why do you
    need hardware-accelerated 3D on a server?) I think Redhat's X
    configuration is done via the "setup" command, so log in as root and
    enter "setup" on the command line, then navigate the menus until you
    find "X configuration", then follow that.
     

    Next time, try something *before* posting to a newsgroup, and report
    what you tried, and how it failed.
    http://catb.org/~esr/faqs/smart-questions.html , HTH.

    --
    Matt G|There is no Darkness in Eternity/But only Light too dim for us to see
    Brainbench MVP for Linux Admin / mail: TRAP + SPAN don't belong
    http://www.brainbench.com / "He is a rhythmic movement of the
    -----------------------------/ penguins, is Tux." --MegaHAL
    Dances Guest

  3. #3

    Default Re: Text mode in init 5! NVIDIA drivers

    On 24 Nov 2003 18:57:16 -0800, com wrote:
     

    .... then it aint runlevel 5 :) .... gather all your h/w info,
    such as keybd, mouse, video card, monitor to include the
    horiz/vert refresh rates and run "xf86config"
    ..
    --
    /// Michael J. Tobler: motorcyclist, surfer, skydiver, \\\
    \\\ and author: "Inside Linux", "C++ HowTo", "C++ Unleashed" ///
    fortune: cpu time/usefulness ratio too high -- core dumped.
    mjt Guest

  4. #4

    Default Re: Text mode in init 5! NVIDIA drivers

    Thanks for responding.

    I need Advanced Server for Oracle. The video card just came with this
    machine. I don't need 3d, but I do the gui to work.
     
    >
    > Did you configure X properly, using the X configuration tool provided by
    > Redhat? If this machine is really going to be a server, why does it
    > need X? If it's going to be a desktop, why did you pay the extra for
    > RHAS?[/ref]

    So, do I need to config X manually? This will be different from my
    Suse installation, which configed X as part of the install.

    What if I just reinstall everything, and choose a Gforce card,
    with a lower number? Should that work?
     
    > [nVidia evil binary-only kernel modules and such] 
    >
    > Yes, if you read the README and follow the directions. Alternatively,
    > and perhaps more easily, you can use the Free "nv" X server, which will
    > work as long as you don't need hardware-accelerated 3D. (Why do you
    > need hardware-accelerated 3D on a server?) I think Redhat's X
    > configuration is done via the "setup" command, so log in as root and
    > enter "setup" on the command line, then navigate the menus until you
    > find "X configuration", then follow that.[/ref]

    Thanks.

    When you guys install the regular RedHat, does it config X, and boot
    to init 5, with the GUI?
     

    Well, I reported what I installed, and the symptoms. I spent seven
    hours searching for info last night. Is this normal install for AS?
    Run level not configured right? Video Card? Looking for drivers.
    Reading the README. Something else?

    I'm not a big fan of trial and error. It's often led to lots of trouble
    and wasted time.
    linuxquestion@yahoo.com Guest

  5. #5

    Default Re: Text mode in init 5! NVIDIA drivers

    Hi,
     

    Well, guess what, X11 doesn't care about Oracle. (-;

    And I afraid by crystal ball is under repair, so more information is
    needed to fix the problem. Post your /etc/X11/XF86Config or related
    file here, and post /var/log/XFree86.0.log here as well, and then we'll
    see what can be done against it.
     
     

    Quite unnecessary, and a lot more work than just to correct the X
    settings.
     [/ref][/ref]

    Will require the nvidia custom driver. Go to their web-page,
    download the driver and install it. You'll find a readme in its
    archive.
     
    >>
    >> Yes, if you read the README and follow the directions. Alternatively,
    >> and perhaps more easily, you can use the Free "nv" X server, which will
    >> work as long as you don't need hardware-accelerated 3D. (Why do you
    >> need hardware-accelerated 3D on a server?)[/ref][/ref]

    AFAIK, the "nv" won't support the FX 5200. For very simple unaccellerated
    access, the "vesa" driver should do it, though.
     

    If the graphics card is supported, yes.
     [/ref]
     

    Please post the configuration files and the log files.
     

    Yes. Please collect the information requested above, then come back.
     

    Might be. But this ain't windows. Reinstallation might take longer, and
    might not even solve the trouble either. The problem is most likely
    easily fixed if you know how, or if we know how if you provide the
    information. (-;

    Hence: Config file please, log file please. Monitor (CRT/TFT) and
    where it's connected (DVI/VGA) might help as well.

    So long,
    Thomas
    Thomas Guest

  6. #6

    Default Re: Text mode in init 5! NVIDIA drivers

    mjt wrote:
     
    >
    >
    > .... uhhhhhh. the OP said "it looks like an old DOS screen".
    > why are you on about 'DOS prompt' and 'DOS shell'???? there
    > is no such thing on Linux :)
    > .[/ref]

    Alright... The term "DOS" is somewhat antiquated, so I will no longer
    use it when referring to a linux shell.

    --
    To email me replace the org.nz with net.nz

    The Guest

  7. #7

    Default Re: Text mode in init 5! NVIDIA drivers

    On Thu, 27 Nov 2003 11:43:15 +1300, The Black Wibble <org.nz> wrote:
     

    ..... uhhhhhh. the OP said "it looks like an old DOS screen".
    why are you on about 'DOS prompt' and 'DOS shell'???? there
    is no such thing on Linux :)
    ..
    --
    /// Michael J. Tobler: motorcyclist, surfer, skydiver, \\\
    \\\ and author: "Inside Linux", "C++ HowTo", "C++ Unleashed" ///
    "Benson, you are so free of the ravages of intelligence"
    mjt Guest

  8. #8

    Default Re: Text mode in init 5! NVIDIA drivers

    The Black Wibble wrote:
     

    When I type startx at a dos prompt it says "command not found"
    C:\
    :)

    Ivor Cave

    Ivor Guest

  9. #9

    Default Re: Text mode in init 5! NVIDIA drivers

    com wrote: 

    But further down the list you should be able to select the generic
    driver used for nVidia FX cards.
     

    Weird. So when you enter telinit 5 or startx at the DOS prompt what
    happens? Normally when the X server has difficulty starting, the
    display goes black, then you see the DOS shell, then it goes black
    again, etc, and an error message eventually appears with a blue background.

    If it gets that far then maybe posting the contents of your XF86Config
    file in /etc/X11/ might give us a clue.
     

    The drivers support the FX5200. Click the "README - Text Version" link
    on the same webpage.
     

    ---
    To email me replace the org.nz with net.nz

    The Guest

  10. #10

    Default Re: Text mode in init 5! NVIDIA drivers

    ["Followup-To:" header set to comp.os.linux.hardware.]

    On 2003-11-25, mjt <com> wrote: [/ref]
     

    You will get a text console in runlevel 5 if your X server fails to
    initialize, which sounds very much like the problem the OP is having,

    The OP can check this by running "runlevel" which will show the previous
    and current runlevels.

    --

    -John (rr.com)
    John Guest

  11. #11

    Default Re: Text mode in init 5! NVIDIA drivers

    Here is what I did. Do a lot of reading from the nvidia website.
    And google. Look at a lot of files.

    Reinstall everything. Probably not necessary, but I wanted
    to change the sizes of the partitions. Choose to use the
    video card: Nvidia Gforce

    Install as many options as possible!

    Including almost everything concerned with X, and gcc, and libraries,
    etc. Config at install to boot to init 3.

    Reboot. It boots to text again. init 5 won't work.

    Download the .rpm file from nvidia. Install it.
    Since I'm not yet connected to the internet, tell it to
    compile the kernel without searching the net.

    After many hours, and much reading, finally edit the file:
    /etc/X11/XF68Config-4
    which was the file that was being used as the default.

    Change a few lines:

    Change the line
    Driver "nv"
    to
    Driver "nvidia"

    comment out the parts for GLcore, and dri:

    Section "Module"
    # Load "GLcore"
    # Load "dri"

    Reboot to init3.
    init 5.
    Works. Brings up X, and gnome.

    I'm not sure if this is the best it should be. But so far the
    GUI works. I'll look more soon.

    What a lot of work!!!!

    Ratio of reading to editing:
    thousands, probably hundreds of thousands of words read.
    to
    one word edited, and two lines commented.

    Just to get a fundamental thing like the video card to work.

    How's that for making (in)efficient use of my time?
    Isn't the computer suppposed to serve me? Not the other way around?

    So I do appreciate all the help everyone has given!



    com wrote in message news:<google.com>... 
    linuxquestion@yahoo.com Guest

  12. #12

    Default Re: Text mode in init 5! NVIDIA drivers

    On 1 Dec 2003 21:21:21 -0800, com wrote:
     
     

    I just read the doent supplied in the package.
    Bit Guest

  13. #13

    Default Re: Text mode in init 5! NVIDIA drivers

    On 1 Dec 2003 21:21:21 -0800, com wrote:
     

    .... i do the anti-male thing: read the manual FIRST
    ..
    --
    /// Michael J. Tobler: motorcyclist, surfer, skydiver, \\\
    \\\ and author: "Inside Linux", "C++ HowTo", "C++ Unleashed" ///
    To be intoxicated is to feel sophisticated but not be able to say it.
    mjt Guest

  14. #14

    Default Re: Text mode in init 5! NVIDIA drivers

    I wish my endeavors were just that simple. I also read the doc.

    But first I had to figure out that it was the video card. I've
    never seen a video card give trouble before. That took a lot of
    research over a few days to conclude that it was the video card.

    Then the doc was 55 pages long. I read most of it, and made 12
    pages of notes.

    In the end, I only had to comment two lines, and change a word
    on another line.

    So, I "just" read the doent too. It bothers me how much was
    involved to do something that was pretty simple. You would think
    that the scripts would do this for you.


    Bit Twister <localdomain> wrote in message news:<home>... 

    >
    > I just read the doent supplied in the package.[/ref]
    linuxquestion@yahoo.com Guest

  15. #15

    Default Re: Text mode in init 5! NVIDIA drivers

    com wrote:
     
    >> 
    >>
    >> I just read the doent supplied in the package.[/ref][/ref]
    I agree with you. The first thing you have to do after installing the
    driver is change one word in your XF86config-4 file. Why do they have to
    hide this halfway down a mass of irrelevant waffle? It should be on the
    first line.

    Doug.
    --
    Murphy's Law of Optimism
    (otherwise the First Law of Investing)
    If it seems too good to be true, it probably is.

    Doug Guest

  16. #16

    Default Re: Text mode in init 5! NVIDIA drivers


    <com> wrote in message news:google.com...
    [...] 

    Yes, I know what you mean. I have spent days trying to get the video capture on my MSI FX5900 Ultra working
    which included stuffing around with the AGP recognition part of some driver source code searching for a bug
    which didn't really exist. All it took was an option to the agpgart.o module and a simple modification to the
    source code to recognise my card and it worked. I could watch TV in Linux.fedora. Now after downloaded and
    installing an updated kernel, it no longer works. grrrr..

    Tony.

    To email me, replace the org.nz with net.nz


    Anthony Guest

Similar Threads

  1. Nvidia drivers leave a black margin
    By alex in forum Ubuntu
    Replies: 4
    Last Post: August 30th, 07:06 AM
  2. Installing NVIDIA drivers on Debian
    By vir in forum Linux Setup, Configuration & Administration
    Replies: 4
    Last Post: September 8th, 06:33 PM
  3. NVIDIA driver (nvidia-kernel-source)
    By David in forum Debian
    Replies: 5
    Last Post: August 18th, 03:40 PM
  4. re nvidia drivers
    By john in forum Debian
    Replies: 3
    Last Post: August 14th, 02:10 AM
  5. Replies: 1
    Last Post: August 1st, 07:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139