Professional Web Applications Themes

Thanks... but OUCH! - Linux Setup, Configuration & Administration

Ok, I finally got Debian loaded and LOVE IT!!! I am a command line junkie and am adapting to the "new" file structure. (vs windows) I wanted to do some playing with the gui options so i tried to load Xfree86 (startx) I tried and it kicked back some errors at me. I checked the log file and determined that my video card was too new for the version of xfree86 that is included with Debian 3 r1. So i rebooted to windows and downloaded the newest version of xfree86. It installed fine. Durring the install process i chose yes ...

  1. #1

    Default Thanks... but OUCH!

    Ok, I finally got Debian loaded and LOVE IT!!! I am a command line junkie
    and am adapting to the "new" file structure. (vs windows) I wanted to do
    some playing with the gui options so i tried to load Xfree86 (startx) I
    tried and it kicked back some errors at me. I checked the log file and
    determined that my video card was too new for the version of xfree86 that is
    included with Debian 3 r1. So i rebooted to windows and downloaded the
    newest version of xfree86. It installed fine. Durring the install process i
    chose yes to all the prompts thinking that would do a clean upgrade. I then
    typed 'startx' and it loaded to a gui terminal.

    PROBLEM!!! I have no keyboard, no mouse. I have tried to ctrl + c, ctrl +
    break, ctrl + alt +fn, and everything else i can think of to try and get
    out. Now my monitor's "built in screen saver" kicked in and I have a black
    screen. I cant get out and I cant get linux to MOVE! I know I am not
    supposed to hard start but I fear that I have no other option at this point.
    Any other suggestions? I know if/when i restart to redo my config for
    xfree86.

    Any ideas?


    Sonny Guest

  2. #2

    Default Re: Thanks... but OUCH!

    In article <ni1Eb.432$randori.com>, Sonny wrote:
     

    Try ctrl+alt+BACKSPACE, it will kill X. Then reconfigure :)

    --
    Juha Siltala
    http://www.edu.helsinki.fi/activity/people/jsiltala/
    Juha Guest

  3. #3

    Default Re: Thanks... but OUCH!

    In article <ni1Eb.432$randori.com>, Sonny wrote: 

    I just had a similar problem with a RedHat 7.3 machine. I did a clean install,
    got the system configured (I manage a number of linux boxes; we have a standard
    install / config procedure in place); fired up X on the console, and was locked
    out. No keyboard or mouse response.

    The problem turned out to be a BIOS setting. I made two changes - don't know
    which fixed it, but I have my suspicions ....

    (1) I turned APCI off ... (probably not the fix) ;
    (2) I changed the PS/2 Mouse setting in the BIOS from "Auto" to "On".

    After I rebooted, Kudzu came up and announced it had detected new hardware
    (the mouse) and I told it to go ahead and update the hardware configuration;
    X came up happily after that with full keyboard and mouse functionality.
    I don't remember if I ran mouseconfig or Xconfigurator after changing the BIOS
    settings; I do know that nothing I tried worked before the BIOS setting change,
    and getting X running afterwards was straightforward.

    Hope that helps!
    Michael Guest

  4. #4

    Default Re: Thanks... but OUCH!

    Thank you Michael, I will give that a try. It sounds like my most promising
    hope yet.

    Happy Holidays!
    Shane

    "Michael K. Heney" <com> wrote in message
    news:com... [/ref]
    junkie [/ref]
    that is [/ref]
    process i [/ref]
    then [/ref]
    ctrl + [/ref]
    black [/ref]
    point. 
    >
    > I just had a similar problem with a RedHat 7.3 machine. I did a clean[/ref]
    install, 
    standard 
    locked 
    know 
    configuration; 
    BIOS 
    change, 


    Sonny Guest

  5. #5

    Default Re: Thanks... but OUCH!


    "Juha Siltala" <net> wrote in message
    news:mosa.homelinux.org... [/ref]
    ctrl + 
    >
    > Try ctrl+alt+BACKSPACE, it will kill X. Then reconfigure :)[/ref]

    But if X starts again, he might be back at the same situation.
    You would think if ctr+alt+F1 didnt work, then ctrl+alt+backspace would not
    either.

    Whats the way to change run level when booting ?

    linux single su, to get to single user mode ? then fix the XF86Config-4 ,
    and then go back to a normal runlevel

     


    Leon. Guest

  6. #6

    Default Re: Thanks... but OUCH!

    In article <3fe11a1f$rivernet.com.au>, Leon. wrote: 
    >
    > But if X starts again, he might be back at the same situation.
    > You would think if ctr+alt+F1 didnt work, then ctrl+alt+backspace would not
    > either.[/ref]

    Yes. I'll crawl under my bed now :)
     

    If I still dare, 'linux single' will give you single user mode.

    --
    Juha Siltala
    http://www.edu.helsinki.fi/activity/people/jsiltala/
    Juha Guest

  7. #7

    Default Re: Thanks... but OUCH!

    Well, my P.O.S. bios (piece of $h!t) doesnt have the "goodies" it is a very
    limited bios. The only setting in there that I could remotely affect
    anything is plug 'n' play OS. I changed it to no and tried to walk through
    the video/mouse/kebd setup again.
    and.............................

    IT LOCKED UP AGAIN! i have NO keyboard, no mouse and am forced to shut down
    hard.
    Here is my list:
    P4 2.6 ghz
    256 Ram
    80 gig HD, (40 windows/40 debian)
    Standard 2button scroll mouse.
    Standard Keyboard
    Intell 82845G onboard video, (8mb ram onboard 32 shared)
    Debian 3.0 r1

    any other ideas? Thanks to all who have helped me up to this point and a
    Big THANK YOU to all for having this board!!

    Shane

    "Michael K. Heney" <com> wrote in message
    news:com... [/ref]
    junkie [/ref]
    that is [/ref]
    process i [/ref]
    then [/ref]
    ctrl + [/ref]
    black [/ref]
    point. 
    >
    > I just had a similar problem with a RedHat 7.3 machine. I did a clean[/ref]
    install, 
    standard 
    locked 
    know 
    configuration; 
    BIOS 
    change, 


    Sonny Guest

  8. #8

    Default Re: Thanks... but OUCH!

    Sonny wrote: 
    You have no keyboard so you will have to reboot into the fixit floppy
    you made or the cd. You will have to get into command line mode 3 and
    edit the file:
    /etc/X11/XF86Config or maybe ti has a -4 at the end. You may be able to
    fix the keyboard and mouse this way. If you can't figure your way with
    this, I think you may have to reinstall. Most times when you do a hard
    reset things will still be ok because of the journalling.
    Lots of luck.

    Leo Guest

  9. #9

    Default Re: Thanks... but OUCH!


    "Leo (Bing) Whiteway" <ca> wrote in message
    news:9PlEb.107670$.. [/ref]
    junkie [/ref]
    that is [/ref]
    process i [/ref]
    then [/ref]
    ctrl + [/ref]
    black [/ref]
    point. 
    > You have no keyboard so you will have to reboot into the fixit floppy
    > you made or the cd. You will have to get into command line mode 3 and
    > edit the file:[/ref]

    Is keyboard available at reboot time? Then he can boot into single user mode
    with "linux 1" or "linux single" or whatever is appropriate for his boot
    options.

    Also, doing a "linux 3" should provide all the non-X-based tools including
    setting up the network, and not start the automatic X-windows tools, which
    may be a more workable for him.

    And if the thing is running sshd, you should be able to log into it remotely
    with an SSH client to reboot, disable the auto-X-login screen stuff by
    editing "/etc/inittab" and changing the default boot to runlevel 3, etc.

    Last: Debian stable is not famous for actually working on any hardware less
    than 3 years old: Debian puts a lot of feature enhancements, including
    hardware support, in the "unstable" list of available packages. This often
    makes it like driving your mom's 10-year-old beater of a mini-van. Useful
    for stability, but not ideal for any challenging environments or specialized
    tasks and in need of upgrading to be comfortable to use.


    Nico Guest

  10. #10

    Default Re: Thanks... but OUCH!

    "Juha Siltala" wrote 
    > >
    > > But if X starts again, he might be back at the same situation.
    > > You would think if ctr+alt+F1 didnt work, then ctrl+alt+backspace
    > > would not either.[/ref]
    >
    > Yes. I'll crawl under my bed now :)

    >
    > If I still dare, 'linux single' will give you single user mode.[/ref]
    Maybe Ctrl-alt-F1 didn't seem to work because X was running on alt-F1;
    you'd also have to try Ctrl-alt-F2 to make sure the keyboard wasn't working.
    He also didn't explicitly say he'd tried Ctrl-alt-delete , which hopefully has
    an /etc/inittab entry that says do a shutdown and reboot.
    As to making a permanent change to boot into runlevel 3 instead of 5,
    probably changing /etc/inittab line
    id::5: to instead be id::3: is the ticket. Would be in Redhat anyway...
    And again on Redhat, I'd check that /dev/mouse was a link to or clone of
    /dev/psaux {major device number 10, minor 2 if you fabricate it using mknod}
    I'm a little fuzzy on how to configure just it, not the graphics card too, for X use.
    You might test it is working properly by running the gpm and testing cut-n-paste.

    Frank Guest

Similar Threads

  1. OUCH!
    By ErnieT in forum Macromedia Freehand
    Replies: 8
    Last Post: February 3rd, 04:51 PM
  2. Applying styles to a vector group - Ouch!
    By GloriaS in forum Macromedia Fireworks
    Replies: 2
    Last Post: August 15th, 04:55 AM
  3. Ouch!! That forum style hurted...
    By Gustavo Sanchez in forum Adobe Photoshop 7, CS, CS2 & CS3
    Replies: 6
    Last Post: July 8th, 06:25 AM
  4. Replies: 1
    Last Post: June 30th, 12:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139