Professional Web Applications Themes

The ALSA-SAGA continues.... - Linux Setup, Configuration & Administration

next step to get Alsa working: I followed this link: http://www.sonic.net/~rknop/linux/debian_alsa.html now while the kernel was created the next step failed. sudo /usr/bin/make-kpkg --revision 1 --append-to-version "-jo1" modules_image *** Warning: Overriding SUBDIRS on the command line can cause *** inconsistencies make[5]: ťarch/i386/kernel/asm-offsets.sŤ ist bereits aktualisiert. CC [M] /usr/src/modules/alsa-driver/usb/usbaudio.o /usr/src/modules/alsa-driver/usb/usbaudio.c: In function `snd_usb_find_csint_desc': /usr/src/modules/alsa-driver/usb/usbaudio.c:1754: error: `USB_DT_CS_INTERFACE' undeclared (first use in this function) /usr/src/modules/alsa-driver/usb/usbaudio.c:1754: error: (Each undeclared identifier is reported only once /usr/src/modules/alsa-driver/usb/usbaudio.c:1754: error: for each function it appears in.) /usr/src/modules/alsa-driver/usb/usbaudio.c: In function `p_audio_endpoints': /usr/src/modules/alsa-driver/usb/usbaudio.c:2340: error: `USB_DT_CS_ENDPOINT' undeclared (first use in this function) make[5]: *** [/usr/src/modules/alsa-driver/usb/usbaudio.o] Fehler 1 make[4]: *** [/usr/src/modules/alsa-driver/usb] Fehler ...

  1. #1

    Default The ALSA-SAGA continues....


    next step to get Alsa working:

    I followed this link:

    http://www.sonic.net/~rknop/linux/debian_alsa.html

    now while the kernel was created the next step failed.

    sudo /usr/bin/make-kpkg --revision 1 --append-to-version "-jo1" modules_image

    *** Warning: Overriding SUBDIRS on the command line can cause
    *** inconsistencies
    make[5]: ťarch/i386/kernel/asm-offsets.sŤ ist bereits aktualisiert.
    CC [M] /usr/src/modules/alsa-driver/usb/usbaudio.o
    /usr/src/modules/alsa-driver/usb/usbaudio.c: In function `snd_usb_find_csint_desc':
    /usr/src/modules/alsa-driver/usb/usbaudio.c:1754: error: `USB_DT_CS_INTERFACE' undeclared (first use in this function)
    /usr/src/modules/alsa-driver/usb/usbaudio.c:1754: error: (Each undeclared identifier is reported only once
    /usr/src/modules/alsa-driver/usb/usbaudio.c:1754: error: for each function it appears in.)
    /usr/src/modules/alsa-driver/usb/usbaudio.c: In function `p_audio_endpoints':
    /usr/src/modules/alsa-driver/usb/usbaudio.c:2340: error: `USB_DT_CS_ENDPOINT' undeclared (first use in this function)
    make[5]: *** [/usr/src/modules/alsa-driver/usb/usbaudio.o] Fehler 1
    make[4]: *** [/usr/src/modules/alsa-driver/usb] Fehler 2
    make[4]: Leaving directory `/usr/src/kernel-source-2.6.0'
    make[3]: *** [compile] Fehler 1
    make[3]: Leaving directory `/usr/src/modules/alsa-driver'
    make[2]: *** [build-stamp] Fehler 2
    make[2]: Leaving directory `/usr/src/modules/alsa-driver'
    make[1]: *** [kdist_image] Fehler 2
    make[1]: Leaving directory `/usr/src/modules/alsa-driver'
    Module /usr/src/modules/alsa-driver failed.
    Hit return to Continue

    end for tonight,


    LinuxUser aka Josef Oswald at
    --
    registered-linux-user # 134.818 at http://counter.li.org

    OS.IS.LINUX Guest

  2. #2

    Default Re: The ALSA-SAGA continues....

    OS.IS.LINUX wrote:

    <snip> 
    <snip>

    Missing or wrong headerfiles. Probably a kernel 2.6 related
    problem, builds fine on 2.4.24 (ALSA 1.0.1). As a wild guess:
    Compare /usr/include/linux/usb.h (assuming /usr /inlude/linux is
    not a symlink) and your_kernel_sources/include/linux/usb.h

    Ransom
    --
    For real email get public key 0xF6BB5695 from www.keyserver.net
    Ransom Guest

  3. #3

    Default Re: The ALSA-SAGA continues....

    Ransom <org> writes:
     

    This is where my _greatest_ problem comes into play: I am not
    knowledgeable enough to see the difference...

    For now I found a workable solution, for the AC97 card I use a OSS
    driver ( since I need it only the Line input) and the other Card uses
    a ALSA driver.

     

     


    LinuxUser aka Josef Oswald at
    --
    registered-linux-user # 134.818 at http://counter.li.org

    The box said Windows, NT or better, so I installed Linux :-)
    OS.IS.LINUX Guest

Similar Threads

  1. Replies: 2
    Last Post: February 16th, 08:58 PM
  2. dynamic text, embedded fonts, the saga continues
    By goddamthissignin webforumsuser@macromedia.com in forum Macromedia Flash Actionscript
    Replies: 0
    Last Post: February 6th, 04:57 PM
  3. HP printer saga
    By J. in forum Debian
    Replies: 3
    Last Post: August 7th, 05:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139