Professional Web Applications Themes

Unable to configure PHP5 on Linux - PHP Development

My current setup is httpd 2.0.47 on a Red Hat 8. When I try to configure php I do ../configure --with-apxs2=/etc/httpd/bin/apxs --disable-cgi it runs for a while until I get configure: error: libxml2 version 2.5.1 or greater required. but yet, when I do an rpm search for libxml2 rpm -q libxml2 I get libxml2-2.5.1-1 Any ideas on this?...

  1. #1

    Default Unable to configure PHP5 on Linux

    My current setup is httpd 2.0.47 on a Red Hat 8.

    When I try to configure php I do

    ../configure --with-apxs2=/etc/httpd/bin/apxs --disable-cgi

    it runs for a while until I get

    configure: error: libxml2 version 2.5.1 or greater required.

    but yet, when I do an rpm search for libxml2

    rpm -q libxml2

    I get

    libxml2-2.5.1-1

    Any ideas on this?

    Jonathan Villa Guest

  2. #2

    Default Re: [PHP] Unable to configure PHP5 on Linux

    Ya- you have to have libxml2-devel installed. Possibly
    [url]http://rpmfind.net/linux/RPM/rufus/libxml/libxml2-devel-2.5.1-1.i386.html[/url]
    but check your distro cd first. Or you could rpm -e libxml2-2.5.1-1, get a
    tarball, and compile it yourself



    On Monday 28 July 2003 07:13 pm, Jonathan Villa wrote:
    > My current setup is httpd 2.0.47 on a Red Hat 8.
    >
    > When I try to configure php I do
    >
    > ./configure --with-apxs2=/etc/httpd/bin/apxs --disable-cgi
    >
    > it runs for a while until I get
    >
    > configure: error: libxml2 version 2.5.1 or greater required.
    >
    > but yet, when I do an rpm search for libxml2
    >
    > rpm -q libxml2
    >
    > I get
    >
    > libxml2-2.5.1-1
    >
    > Any ideas on this?
    --
    Status: 0
    Content-type: text/html

    [cgi]
    "The missionaries go forth to Christianize the savages- as if the savages
    weren't dangerous enough already."

    -Edward Abbey

    Evan Nemerson Guest

  3. #3

    Default Re: [PHP] Unable to configure PHP5 on Linux

    Thanks! That was it...

    On Mon, 2003-07-28 at 21:41, Evan Nemerson wrote:
    > Ya- you have to have libxml2-devel installed. Possibly
    > [url]http://rpmfind.net/linux/RPM/rufus/libxml/libxml2-devel-2.5.1-1.i386.html[/url]
    > but check your distro cd first. Or you could rpm -e libxml2-2.5.1-1, get a
    > tarball, and compile it yourself
    >
    >
    >
    > On Monday 28 July 2003 07:13 pm, Jonathan Villa wrote:
    > > My current setup is httpd 2.0.47 on a Red Hat 8.
    > >
    > > When I try to configure php I do
    > >
    > > ./configure --with-apxs2=/etc/httpd/bin/apxs --disable-cgi
    > >
    > > it runs for a while until I get
    > >
    > > configure: error: libxml2 version 2.5.1 or greater required.
    > >
    > > but yet, when I do an rpm search for libxml2
    > >
    > > rpm -q libxml2
    > >
    > > I get
    > >
    > > libxml2-2.5.1-1
    > >
    > > Any ideas on this?
    >
    > --
    > Status: 0
    > Content-type: text/html
    >
    > [cgi]
    > "The missionaries go forth to Christianize the savages- as if the savages
    > weren't dangerous enough already."
    >
    > -Edward Abbey
    >
    Jonathan Villa Guest

Similar Threads

  1. Replies: 1
    Last Post: October 4th, 03:10 AM
  2. How to configure GD support in php on linux/apache?
    By Larry Li in forum PHP Development
    Replies: 1
    Last Post: September 25th, 05:57 AM
  3. unable to configure tape drive
    By felix Sanchez in forum Sun Solaris
    Replies: 1
    Last Post: July 24th, 02:26 PM
  4. Unable to configure PS/2 Mouse in woody!
    By Andreas Janssen in forum Debian
    Replies: 0
    Last Post: July 23rd, 06:30 PM
  5. installing and running apache 2.0.46 / php5.0.0b1 / Suse Linux 8.2
    By michael newport in forum PHP Development
    Replies: 0
    Last Post: July 2nd, 09:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139