[allowsmilie] => 1 [showsignature] => 0 [ipaddress] => [iconid] => 0 [visible] => 1 [attach] => 0 [infraction] => 0 [reportthreadid] => 0 [isusenetpost] => 1 [msgid] => [ref] => [htmlstate] => on_nl2br [postusername] => Brian Pittman [ip] => bpittman@nlta.n [isdeleted] => 0 [usergroupid] => [membergroupids] => [displaygroupid] => [password] => [passworddate] => [email] => [styleid] => [parentemail] => [homepage] => [icq] => [aim] => [yahoo] => [msn] => [skype] => [showvbcode] => [showbirthday] => [usertitle] => [customtitle] => [joindate] => [daysprune] => [lastvisit] => [lastactivity] => [lastpost] => [lastpostid] => [posts] => [reputation] => [reputationlevelid] => [timezoneoffset] => [pmpopup] => [avatarid] => [avatarrevision] => [profilepicrevision] => [sigpicrevision] => [options] => [akvbghsfs_optionsfield] => [birthday] => [birthday_search] => [maxposts] => [startofweek] => [referrerid] => [languageid] => [emailstamp] => [threadedmode] => [autosubscribe] => [pmtotal] => [pmunread] => [salt] => [ipoints] => [infractions] => [warnings] => [infractiongroupids] => [infractiongroupid] => [adminoptions] => [profilevisits] => [friendcount] => [friendreqcount] => [vmunreadcount] => [vmmoderatedcount] => [socgroupinvitecount] => [socgroupreqcount] => [pcunreadcount] => [pcmoderatedcount] => [gmmoderatedcount] => [assetposthash] => [fbuserid] => [fbjoindate] => [fbname] => [logintype] => [fbaccesstoken] => [newrepcount] => [vbseo_likes_in] => [vbseo_likes_out] => [vbseo_likes_unread] => [temp] => [field1] => [field2] => [field3] => [field4] => [field5] => [subfolders] => [pmfolders] => [buddylist] => [ignorelist] => [signature] => [searchprefs] => [rank] => [icontitle] => [iconpath] => [avatarpath] => [hascustomavatar] => 0 [avatardateline] => [avwidth] => [avheight] => [edit_userid] => [edit_username] => [edit_dateline] => [edit_reason] => [hashistory] => [pagetext_html] => [hasimages] => [signatureparsed] => [sighasimages] => [sigpic] => [sigpicdateline] => [sigpicwidth] => [sigpicheight] => [postcount] => 1 [islastshown] => [isfirstshown] => 1 [attachments] => [allattachments] => ) --> > > > > > > > > > > > > > > > > > > > > > > > > > > traceMode="SortByTime" localOnly="true" /> > > > > > > > mode="InProc" > > stateConnectionString="tcpip=127.0.0.1:42424" > > sqlConnectionString="data source=127.0.0.1;user id=sa;password=" > > cookieless="false" > > timeout="20" > > /> > > > > > > > > > [/quote] Try using different names for your machine. Also trying Windows authentication or sa/password (sql server login) machinename localhost (local) 127.0.0.1 machinename\\vsdotnet ... Karim [allowsmilie] => 1 [showsignature] => 0 [ipaddress] => [iconid] => 0 [visible] => 1 [attach] => 0 [infraction] => 0 [reportthreadid] => 0 [isusenetpost] => 1 [msgid] => <51f823c3c6bc98021d85ff99ae202079@free.teranews.com> [ref] => [htmlstate] => on_nl2br [postusername] => karim [ip] => karim3411@11yah [isdeleted] => 0 [usergroupid] => [membergroupids] => [displaygroupid] => [password] => [passworddate] => [email] => [styleid] => [parentemail] => [homepage] => [icq] => [aim] => [yahoo] => [msn] => [skype] => [showvbcode] => [showbirthday] => [usertitle] => [customtitle] => [joindate] => [daysprune] => [lastvisit] => [lastactivity] => [lastpost] => [lastpostid] => [posts] => [reputation] => [reputationlevelid] => [timezoneoffset] => [pmpopup] => [avatarid] => [avatarrevision] => [profilepicrevision] => [sigpicrevision] => [options] => [akvbghsfs_optionsfield] => [birthday] => [birthday_search] => [maxposts] => [startofweek] => [referrerid] => [languageid] => [emailstamp] => [threadedmode] => [autosubscribe] => [pmtotal] => [pmunread] => [salt] => [ipoints] => [infractions] => [warnings] => [infractiongroupids] => [infractiongroupid] => [adminoptions] => [profilevisits] => [friendcount] => [friendreqcount] => [vmunreadcount] => [vmmoderatedcount] => [socgroupinvitecount] => [socgroupreqcount] => [pcunreadcount] => [pcmoderatedcount] => [gmmoderatedcount] => [assetposthash] => [fbuserid] => [fbjoindate] => [fbname] => [logintype] => [fbaccesstoken] => [newrepcount] => [vbseo_likes_in] => [vbseo_likes_out] => [vbseo_likes_unread] => [temp] => [field1] => [field2] => [field3] => [field4] => [field5] => [subfolders] => [pmfolders] => [buddylist] => [ignorelist] => [signature] => [searchprefs] => [rank] => [icontitle] => [iconpath] => [avatarpath] => [hascustomavatar] => 0 [avatardateline] => [avwidth] => [avheight] => [edit_userid] => [edit_username] => [edit_dateline] => [edit_reason] => [hashistory] => [pagetext_html] => [hasimages] => [signatureparsed] => [sighasimages] => [sigpic] => [sigpicdateline] => [sigpicwidth] => [sigpicheight] => [postcount] => 2 [islastshown] => 1 [isfirstshown] => [attachments] => [allattachments] => ) --> Unable to connect to SQL 2K via VS.NET - ASP.NET General

Unable to connect to SQL 2K via VS.NET - ASP.NET General

Hi all, As the subject says I'm having trouble connecting to SQL Server 2K via Visual Studio.NET 2002 (VB). It tells me that SQL Server does not exist or access is denied. I know that the server exists because its on the machine I'm working on. There is no reason for me to be denied access. I am using a trusted connection and access has been granted to the ASPNET account for the referenced Database. I have been developing asp apps for years now I am just moving to the .NET revolution so I do know how to connect to ...

  1. #1

    Default Unable to connect to SQL 2K via VS.NET

    Hi all,

    As the subject says I'm having trouble connecting to SQL Server 2K via
    Visual Studio.NET 2002 (VB). It tells me that SQL Server does not exist or
    access is denied. I know that the server exists because its on the machine
    I'm working on. There is no reason for me to be denied access. I am using
    a trusted connection and access has been granted to the ASPNET account for
    the referenced Database. I have been developing asp apps for years now I am
    just moving to the .NET revolution so I do know how to connect to a database
    via asp and there is nothing wrong with my connection string. I have to
    assume that when I create an asp.net app in vs.net that the web.config file
    is some how preventing me from accessing the Database. Is there some
    setting that has to initialized in this file or even the machine.config
    file? I have included the web.config file source below. Thanks for any
    help

    Brian

    '****************************
    '** WEB.CONFIG SOURCE
    '****************************
    <?xml version="1.0" encoding="utf-8" ?>

    <configuration>


    <system.web>

    <!-- DYNAMIC DEBUG COMPILATION

    Set compilation debug="true" to insert debugging symbols (.pdb information)

    into the compiled page. Because this creates a larger file that executes

    more slowly, you should set this value to true only when debugging and to

    false at all other times. For more information, refer to the doentation
    about

    debugging ASP.NET files.

    -->

    <compilation defaultLanguage="vb" debug="true" />

    <!-- CUSTOM ERROR MESSAGES

    Set customErrors mode="On" or "RemoteOnly" to enable custom error messages,
    "Off" to disable.

    Add <error> tags for each of the errors you want to handle.

    -->

    <customErrors mode="RemoteOnly" />

    <!-- AUTHENTICATION

    This section sets the authentication policies of the application. Possible
    modes are "Windows",

    "Forms", "Passport" and "None"

    -->

    <authentication mode="Windows" />



    <!-- AUTHORIZATION

    This section sets the authorization policies of the application. You can
    allow or deny access

    to application resources by user or role. Wildcards: "*" mean everyone, "?"
    means anonymous

    (unauthenticated) users.

    -->

    <authorization>

    <allow users="*" /> <!-- Allow all users -->

    <!-- <allow users="[comma separated list of users]"

    roles="[comma separated list of roles]"/>

    <deny users="[comma separated list of users]"

    roles="[comma separated list of roles]"/>

    -->

    </authorization>

    <!-- APPLICATION-LEVEL TRACE LOGGING

    Application-level tracing enables trace log output for every page within an
    application.

    Set trace enabled="true" to enable application trace logging. If
    pageOutput="true", the

    trace information will be displayed at the bottom of each page. Otherwise,
    you can view the

    application trace log by browsing the "trace.axd" page from your web
    application

    root.

    -->

    <trace enabled="false" requestLimit="10" pageOutput="false"
    traceMode="SortByTime" localOnly="true" />



    <!-- SESSION STATE SETTINGS

    By default ASP.NET uses cookies to identify which requests belong to a
    particular session.

    If cookies are not available, a session can be tracked by adding a session
    identifier to the URL.

    To disable cookies, set sessionState cookieless="true".

    -->

    <sessionState

    mode="InProc"

    stateConnectionString="tcpip=127.0.0.1:42424"

    sqlConnectionString="data source=127.0.0.1;user id=sa;password="

    cookieless="false"

    timeout="20"

    />

    <!-- GLOBALIZATION

    This section sets the globalization settings of the application.

    -->

    <globalization requestEncoding="utf-8" responseEncoding="utf-8" />


    </system.web>

    </configuration>


    Brian Pittman Guest

  2. #2

    Default Re: Unable to connect to SQL 2K via VS.NET

    On Fri, 11 Jul 2003 11:56:07 -0230, Brian Pittman wrote:
    > Hi all,
    >
    > As the subject says I'm having trouble connecting to SQL Server 2K via
    > Visual Studio.NET 2002 (VB). It tells me that SQL Server does not exist or
    > access is denied. I know that the server exists because its on the machine
    > I'm working on. There is no reason for me to be denied access. I am using
    > a trusted connection and access has been granted to the ASPNET account for
    > the referenced Database. I have been developing asp apps for years now I am
    > just moving to the .NET revolution so I do know how to connect to a database
    > via asp and there is nothing wrong with my connection string. I have to
    > assume that when I create an asp.net app in vs.net that the web.config file
    > is some how preventing me from accessing the Database. Is there some
    > setting that has to initialized in this file or even the machine.config
    > file? I have included the web.config file source below. Thanks for any
    > help
    >
    > Brian
    >
    > '****************************
    > '** WEB.CONFIG SOURCE
    > '****************************
    > <?xml version="1.0" encoding="utf-8" ?>
    >
    > <configuration>
    >
    >
    > <system.web>
    >
    > <!-- DYNAMIC DEBUG COMPILATION
    >
    > Set compilation debug="true" to insert debugging symbols (.pdb information)
    >
    > into the compiled page. Because this creates a larger file that executes
    >
    > more slowly, you should set this value to true only when debugging and to
    >
    > false at all other times. For more information, refer to the doentation
    > about
    >
    > debugging ASP.NET files.
    >
    > -->
    >
    > <compilation defaultLanguage="vb" debug="true" />
    >
    > <!-- CUSTOM ERROR MESSAGES
    >
    > Set customErrors mode="On" or "RemoteOnly" to enable custom error messages,
    > "Off" to disable.
    >
    > Add <error> tags for each of the errors you want to handle.
    >
    > -->
    >
    > <customErrors mode="RemoteOnly" />
    >
    > <!-- AUTHENTICATION
    >
    > This section sets the authentication policies of the application. Possible
    > modes are "Windows",
    >
    > "Forms", "Passport" and "None"
    >
    > -->
    >
    > <authentication mode="Windows" />
    >
    >
    >
    > <!-- AUTHORIZATION
    >
    > This section sets the authorization policies of the application. You can
    > allow or deny access
    >
    > to application resources by user or role. Wildcards: "*" mean everyone, "?"
    > means anonymous
    >
    > (unauthenticated) users.
    >
    > -->
    >
    > <authorization>
    >
    > <allow users="*" /> <!-- Allow all users -->
    >
    > <!-- <allow users="[comma separated list of users]"
    >
    > roles="[comma separated list of roles]"/>
    >
    > <deny users="[comma separated list of users]"
    >
    > roles="[comma separated list of roles]"/>
    >
    > -->
    >
    > </authorization>
    >
    > <!-- APPLICATION-LEVEL TRACE LOGGING
    >
    > Application-level tracing enables trace log output for every page within an
    > application.
    >
    > Set trace enabled="true" to enable application trace logging. If
    > pageOutput="true", the
    >
    > trace information will be displayed at the bottom of each page. Otherwise,
    > you can view the
    >
    > application trace log by browsing the "trace.axd" page from your web
    > application
    >
    > root.
    >
    > -->
    >
    > <trace enabled="false" requestLimit="10" pageOutput="false"
    > traceMode="SortByTime" localOnly="true" />
    >
    >
    >
    > <!-- SESSION STATE SETTINGS
    >
    > By default ASP.NET uses cookies to identify which requests belong to a
    > particular session.
    >
    > If cookies are not available, a session can be tracked by adding a session
    > identifier to the URL.
    >
    > To disable cookies, set sessionState cookieless="true".
    >
    > -->
    >
    > <sessionState
    >
    > mode="InProc"
    >
    > stateConnectionString="tcpip=127.0.0.1:42424"
    >
    > sqlConnectionString="data source=127.0.0.1;user id=sa;password="
    >
    > cookieless="false"
    >
    > timeout="20"
    >
    > />
    >
    > <!-- GLOBALIZATION
    >
    > This section sets the globalization settings of the application.
    >
    > -->
    >
    > <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
    >
    >
    > </system.web>
    >
    > </configuration>
    Try using different names for your machine. Also trying Windows
    authentication or sa/password (sql server login)

    machinename
    localhost
    (local)
    127.0.0.1
    machinename\\vsdotnet
    ...

    Karim
    karim Guest

Similar Threads

  1. Unable to connect to endpoint..
    By mikadig in forum Macromedia Flash Data Integration
    Replies: 1
    Last Post: March 24th, 08:50 AM
  2. Unable to connect to FMS from outside of the US
    By jessbryant in forum Macromedia Flash Flashcom
    Replies: 3
    Last Post: July 23rd, 10:04 AM
  3. Unable to connect via fms2_console
    By FlashStreams in forum Macromedia Flash Flashcom
    Replies: 3
    Last Post: July 5th, 10:59 PM
  4. Help me: Unable to connect to FMS
    By Nightbird0 in forum Macromedia Flash Flashcom
    Replies: 1
    Last Post: January 14th, 07:25 PM
  5. Unable to connect
    By Radovan Radic in forum Microsoft SQL / MS SQL Server
    Replies: 1
    Last Post: July 3rd, 12:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •