Am running Samba V2.2.7a on a SCO 5.0.2 system.
The printer 'spmgm3' is a valid unix printer attached to a wyse terminal at
/dev/prn1c01.
Can print to it from unix without a problem

Have added the following to smb.conf to make 'spmgm3' available to windows
users.

[spmgm3]
printing = sysv
comment = Johns Test Printer
browseable = yes
printable = yes
printer name = spmgm3
public = yes
writable = yes
create mode = 0755
path = /tmp
print command = lp -o nobanner -s -c -d %p %s > /dev/null 2>&1 ; rm %s
printer driver = Epson LX-300+

The printer 'spmgm3' then appears in the network neighbourhood, and I am
able
to create this printer on a windows box. When I print to it, a file
'/tmp/smbprn.000004.a0079f' or such is created and I assume sent to the
Epson
printer 'spmgm3'.

Problem is that the printer prints EJL and locks up,
requiring a restart. The temp file created for printing has the following as
its first 3 lines;
^[^AEJL 1284.4
EJL
^[^M^[t^A^[6^[R^[P^R^[(U^A

and then continues in a similar fashion to the end. My test print from
wordpad contained 'This is a test'
Have tried cat temp_print_file >/dev/print_device
Have tried lp -oraw
Have tried lp -Tsimple

They all produce the same result as above.

Can anyone help me with this one??

Thanks and regards,

John Clarke