-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Some more info: I've found the alsaconf utility and run it. It finds
and installs snd-intel8x0 (successfully it seems, but fails on the
"alsasound start" test phase with the errors:

Loading driver...
Starting sound driver: snd-intel8x0
/lib/modules/2.4.20-18.9smp/kernel/sound/acore/snd.o: unresolved symbol
schedule_work
/lib/modules/2.4.20-18.9smp/kernel/sound/acore/snd.o: insmod
/lib/modules/2.4.20-18.9smp/kernel/sound/acore/snd.o failed
/lib/modules/2.4.20-18.9smp/kernel/sound/acore/snd.o: insmod
snd-intel8x0 faileddone

It seems that there is something wrong with the snd.o module.

Anyone have any advice? (Google shows nothing :-( )



Mike Pelley wrote:

| sndconfig finds the card:
| ~ Model: Intel Corp.|82801EB AC'97 Audio Then I get:
| ~ The Intel Corp.|82801EB AC'97 Audio is not currently supported.
|
| More ideas?
|
| Cheers,
| Mike
|
| Bob Buckley wrote:
|
| |Have you run sndconfig?
| |
| |
| |-----Original Message-----
| |From: [email]redhat-list-adminredhat.com[/email]
| |[mailto:redhat-list-adminredhat.com]On Behalf Of Mike Pelley
| |Sent: Tuesday, July 15, 2003 1:48 PM
| |To: redhat-list
| |Subject: Getting sound to work on an Abit IC7 and RH9
| |
| |
|
| | Hi all,
| |
| | I'm trying to get the onboard sound on my Abit IC7 working. I've
| | downloaded the drivers from Abit for Linux and run the configuration,
| | compiled the modules and installed the drivers. The kernel has sound
| | compiled into it and lsmod reports:
| | ~ soundcore 7044 0 (autoclean) [bttv]
| |
| | I've added the following lines to my /etc/modules.conf:
| | ~ #====== added those lines =============
| | ~ alias char-major-116 snd
| | ~ options snd snd_major=116 snd_cards_limit=1
| | ~ #--- Intel 8x0 and SiS 7012 ----------
| | ~ alias snd-card-0 snd-intel8x0
| | ~ options snd-intel8x0 snd_index=0 snd_id="ICH"
| | ~ alias char-major-14 soundcore
| | ~ alias sound-service-0-0 snd-mixer-oss
| | ~ alias sound-service-0-1 snd-seq-oss
| | ~ alias sound-service-0-3 snd-pcm-oss
| | ~ alias sound-service-0-8 snd-seq-oss
| | ~ alias sound-service-0-12 snd-pcm-oss
| | ~ #=================================
| | ~ alias sound-slot-0 snd-intel8x0
| | ~ post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
| | /dev/null 2>&1 || :
| | ~ pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc
| | -S >/dev/null 2>&1 || :
| |
| | However, if I try to insmod snd-intel8x0 I get these errors:
| |
| | ~ [roothelios dev]# insmod snd-intel8x0
| | Using /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_verbose_printk_Rsmp_49d4e4d1
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_card_free_Rsmp_d6b576fb
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_card_register_Rsmp_879bc8e0
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_card_new_Rsmp_148a84cf
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_iprintf_Rsmp_2f0b152f
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_kcalloc_Rsmp_4da9e78a
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_pcm_period_elapsed_Rsmp_575e1363
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_ac97_set_rate_Rsmp_af52f286
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_mpu401_uart_new_Rsmp_f889bf50
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_pcm_new_Rsmp_8e4a587a
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_ac97_update_bits_Rsmp_e8b0d65c
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_free_pci_pages_Rsmp_a6cdb189
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_pcm_lib_malloc_pages_Rsmp_da167b77
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_pcm_suspend_all_Rsmp_456c3764
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_pcm_lib_ioctl_Rsmp_3519bc9d
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_ac97_tune_hardware_Rsmp_dd9358a1
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_ac97_resume_Rsmp_dd19a47b
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_pcm_hw_constraint_list_Rsmp_e5ea3560
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_malloc_pci_pages_Rsmp_be4b1f0a
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_device_new_Rsmp_9a0a1360
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_pcm_hw_constraint_integer_Rsmp_b1214ca0
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_pcm_lib_free_pages_Rsmp_637b45db
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_pcm_lib_preallocate_pci_pages_for_all_Rsmp_ff6 28f66
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_pcm_lib_preallocate_free_for_all_Rsmp_afc784ec
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_ac97_mixer_Rsmp_770d538d
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_pcm_set_ops_Rsmp_89bdab12
| | /lib/modules/2.4.20-18.9smp/kernel/sound/pci/snd-intel8x0.o: unresolved
| | symbol snd_card_proc_new_Rsmp_6dabc97f
| |
| | I've even tried to reconfigure ALSA with the following:
| | ./configure --with-cards=intel8x0 --with-sequencer=yes;make;make install
| |
| | Still no go. I'm running 2.4.20-18.9smp #1 SMP Thu May 29 06:55:05 EDT
| | 2003 i686 i686 i386 GNU/Linux
| |
| |
| | Any ideas?
| |
| | Cheers,
| | Mike
| | [email]mikepelleys.com[/email]_remove_nospam
|
|
| --
| redhat-list mailing list
| unsubscribe mailto:redhat-list-requestredhat.com?subject=unsubscribe
| [url]https://www.redhat.com/mailman/listinfo/redhat-list[/url]
|
|
|
|
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (GNU/Linux)
Comment: Using GnuPG with Netscape - [url]http://enigmail.mozdev.org[/url]

iD8DBQE/F0EnFW7Xii2aqO8RAuhQAKC0OGFodEm+oFqS9l5ZaP3SweuX7g CdHif9
gPPk2w44T0+EyCJpu/sMMVg=
=zNtI
-----END PGP SIGNATURE-----