if I upgrade from 4.1 to 5.0 can I use the same db's?

my problem:

I have 4.1 installed, but yesterday I installed xampp (for PHP
development) it comes with its own MySQL server (5.0) I wanted to just
copy db's that come w/PHP installation to my 4.1 installation, but
wonder if that will work..

the db's in 5.0 contain, in addition to .frm files, .MYI and .MYD files,
which I don't see with db's in 4.1 installation..

conversely, if I upgrade to 5.0 can I use db's I've been using with 4.1
with 5.0?

thank you..

Frances