We have a survey that we wanted to use an onLoad() function in flash forms, so
we had to move to CF 7.01. Well the installer for the update looked to have
worked but CF would not start. I thought it was because we had Felx 1.5
integrated on our installation.

The error was something like this:

java.util.MissingResourceException: Can't find resource for base name
coldfusion/server/j2ee/resource.properties

and further errors like this:

java.security.AccessControlException: access denied (java.io.FilePermission
E:\JRun4\servers...

So it looked like some sort of file persmission error.

Also, in the CF server log the startup would hang after this line:

"Information","scheduler-5","03/03/06","10:31:58",,"Starting License server
...."

So I killed that install. and I reinstalled from the new 7.01 installer.

That went great, everything installed, it worked. So then I went to go figure
out how to get all of the settings into the server. We run a small cluster on
Enterprise, so I did a ".car" backup of all of the settings from the CF admin,
and updated the new install. Great it still worked. Except for a few things,
which we have seen ever since the MX release, like old CFX's not loading due to
the cfx.jar not being in the classpath.... SO I went to update the jvm.config,
and the server wouldn't start again.. ???

I tried lots of stuff, searching the net, these forums, and even inside jar
files for clues.

I went back to the server.log for the cfusion server, and it would hang on the
license server starting... I found some blog posts and tech notes on this at:

[url]http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=f9e312a2[/url]


[url]http://www.macromedia.com/cfusion/webforums/forum/messageview.cfm?catid=65&threa[/url]
did=784675&enterthread=y

Where they mess around and have you copy license files and whatnot around..
which did not help me.

Well, it is simpler than that. I guess if you ever set SandBox Security up, or
maybe even just have a new installation, it runs fine once, and then it won't
run again because the sandbox security attirubte in the neo-security.xml file
gets set to true. Maybe it happens in the ".car" update. I am not sure, but
just change this attribute to false, and restart, and you are good to go. I
guess if you need sandbox security, you should double check the whole file and
make sure it is right before enabling it.

Oh, I also set the CFIDE directory to the correct folder in the
neo-security.xml file.



<var name='sbs.security.enabled'><boolean value='false'/></var>