/mi05;c:\temp\ I have this code in the .ASC file: application.onConnect = function(user) { application.acceptConnection(user); Client.prototype.songPlay = function(songsNow, v2) { this.songStream = Stream.get("songs"); this.songStream.play("mp3:song4", 0); trace("Playing MI01"); }; Client.prototype.stopPlay = function() { this.songStream.play(false); trace("All play has stopped."); }; }; I have song4.mp3 in C:\temp. I know the code is working because I'm getting the trace messages in FMS. However, I'm not hearing anything. What am I doing wrong? --Mike [allowsmilie] => 1 [showsignature] => 0 [ipaddress] => [iconid] => 0 [visible] => 1 [attach] => 0 [infraction] => 0 [reportthreadid] => 0 [isusenetpost] => 1 [msgid] => [ref] => [htmlstate] => on_nl2br [postusername] => Mike Burger [ip] => webforumsuser@m [isdeleted] => 0 [usergroupid] => [membergroupids] => [displaygroupid] => [password] => [passworddate] => [email] => [styleid] => [parentemail] => [homepage] => [icq] => [aim] => [yahoo] => [msn] => [skype] => [showvbcode] => [showbirthday] => [usertitle] => [customtitle] => [joindate] => [daysprune] => [lastvisit] => [lastactivity] => [lastpost] => [lastpostid] => [posts] => [reputation] => [reputationlevelid] => [timezoneoffset] => [pmpopup] => [avatarid] => [avatarrevision] => [profilepicrevision] => [sigpicrevision] => [options] => [akvbghsfs_optionsfield] => [birthday] => [birthday_search] => [maxposts] => [startofweek] => [referrerid] => [languageid] => [emailstamp] => [threadedmode] => [autosubscribe] => [pmtotal] => [pmunread] => [salt] => [ipoints] => [infractions] => [warnings] => [infractiongroupids] => [infractiongroupid] => [adminoptions] => [profilevisits] => [friendcount] => [friendreqcount] => [vmunreadcount] => [vmmoderatedcount] => [socgroupinvitecount] => [socgroupreqcount] => [pcunreadcount] => [pcmoderatedcount] => [gmmoderatedcount] => [assetposthash] => [fbuserid] => [fbjoindate] => [fbname] => [logintype] => [fbaccesstoken] => [newrepcount] => [vbseo_likes_in] => [vbseo_likes_out] => [vbseo_likes_unread] => [temp] => [field1] => [field2] => [field3] => [field4] => [field5] => [subfolders] => [pmfolders] => [buddylist] => [ignorelist] => [signature] => [searchprefs] => [rank] => [icontitle] => [iconpath] => [avatarpath] => [hascustomavatar] => 0 [avatardateline] => [avwidth] => [avheight] => [edit_userid] => [edit_username] => [edit_dateline] => [edit_reason] => [hashistory] => [pagetext_html] => [hasimages] => [signatureparsed] => [sighasimages] => [sigpic] => [sigpicdateline] => [sigpicwidth] => [sigpicheight] => [postcount] => 2 [islastshown] => [isfirstshown] => [attachments] => [allattachments] => ) --> Virtual Directory Problem - Macromedia Flash Flashcom

Virtual Directory Problem - Macromedia Flash Flashcom

Dear Friends, In Apache, the /usr/local/fsuser/sbin directory is mapped to the virtual directory [url]http://192.168.0.10/fsuser/cgi-bin/[/url]. From browser, I am able to access all the .cgi and .pl files present in the /usr/local/fsuser/sbin and its subdirectories. But I am not able to access the html files present in this directory. When I am giving the following URL it is giving the Premature end of script error. [url]http://192.168.0.10/fsuser/cgi-bin/help.htm[/url]. Whereas, I am able to access the same html with the following URL. [url]http://192.168.0.10/help.htm[/url]. How can I access the html file with the URL [url]http://192.168.0.10/fsuser/cgi-bin/help.htm[/url] Thanks, Mallik....

  1. #1

    Default Virtual Directory Problem

    Dear Friends,

    In Apache, the /usr/local/fsuser/sbin directory is mapped to the
    virtual directory [url]http://192.168.0.10/fsuser/cgi-bin/[/url].

    From browser, I am able to access all the .cgi and .pl files
    present in the /usr/local/fsuser/sbin and its subdirectories.

    But I am not able to access the html files present in this
    directory. When I am giving the following URL it is giving
    the Premature end of script error.

    [url]http://192.168.0.10/fsuser/cgi-bin/help.htm[/url].

    Whereas, I am able to access the same html with the following URL.

    [url]http://192.168.0.10/help.htm[/url].


    How can I access the html file with the URL
    [url]http://192.168.0.10/fsuser/cgi-bin/help.htm[/url]

    Thanks,
    Mallik.

    Mallik Guest

  2. #2

    Default Virtual Directory Problem

    Any help would be greatly appreciated.

    I am new to Flash, and I'm new to Flash Media Server. I am trying to get FMS
    to look at a virtual directory. I have set up this simple Application.XML file:

    <Application>
    <!-- This section contains information about configuring the script engine.
    -->
    <JSEngine>
    <FileObject>
    <VirtualDirectory>/mi05;c:\temp\</VirtualDirectory>
    </FileObject>
    </JSEngine>
    </Application>


    I have this code in the .ASC file:
    application.onConnect = function(user) {
    application.acceptConnection(user);
    Client.prototype.songPlay = function(songsNow, v2) {
    this.songStream = Stream.get("songs");
    this.songStream.play("mp3:song4", 0);
    trace("Playing MI01");
    };
    Client.prototype.stopPlay = function() {
    this.songStream.play(false);
    trace("All play has stopped.");
    };
    };


    I have song4.mp3 in C:\temp. I know the code is working because I'm getting
    the trace messages in FMS. However, I'm not hearing anything. What am I doing
    wrong?


    --Mike

    Mike Burger Guest

  3. #3

    Default Re: Virtual Directory Problem

    I self-diagnosed the issue. I'm using VirtualDirectory inside the default
    vhost.xml instead of application.xml. You also need to have the virtual
    directory declared in the filename instead of the connection:

    this.songStream.play("mp3:mi05/song4", 0);

    I hope this helps someone in the future.

    Mike Burger Guest

Similar Threads

  1. virtual directory
    By triadwm in forum Macromedia Flash Flashcom
    Replies: 15
    Last Post: November 19th, 09:35 PM
  2. Accessing Virtual Directory in IIS 6
    By Fred Herring in forum ASP.NET Web Services
    Replies: 2
    Last Post: October 12th, 11:29 AM
  3. Web.Config and Virtual Directory
    By Wm. Scott Miller in forum ASP.NET Security
    Replies: 1
    Last Post: June 9th, 10:37 AM
  4. Have to Be A Virtual Directory?
    By Chan in forum ASP.NET Web Services
    Replies: 5
    Last Post: January 19th, 01:49 PM
  5. How to create a new Virtual Directory?
    By qiuji in forum ASP.NET General
    Replies: 0
    Last Post: August 12th, 07:02 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139