Unix-box.[ref] > and point out a >similar oddity: by default your Win98 box can't read an NTFS drive if >installed locally, yet if an NT box has a share on the network, you can now >read it just fine-file system becomes irrelevant. > >Go figure > > >"Peter Michel" wrote in message >news:com...[ref] >> On Wed, 5 Nov 2003 07:16:58 -0800, "Bob Meyers" >> wrote: >>[ref] >> >> I tried .911 with the same result 8-(( >> >> Copy a normal file works, setting it's write protected attribute than >> >> the copy fails. >> >> Here the output of a) .../version: >> >> SCO VisionFS >> >> 3.10.911 >> >> b) of the problem of .../logs/error.log: >> >> 2003/11/05 12:05:43.270 (pid 621) >> >> SCO VisionFS(3.1) ERROR: >> >> connecttree/unixfile/truncatefailed >> >> An attempt to truncate a file has failed: >> >> ftruncate(/home/michel/SicherungDVD.nri(7),61440): (13) >> >> Permission denied >> > >> >Does this file have a real long filename or funny characters in it?[/ref] >> Yes and NO, just change the attribute to 'not write protected', and >> the same thing works![ref] >> >Are you trying to overwrite a copy already on server?[/ref] >> No, s.o.[ref] >> >Look in profile editor and try liberalizing permissions on just that[/ref][/ref] >share.[ref][ref] >> >Check/liberalize file permissions on share directory and share[/ref][/ref] >subfolders.[ref][ref] >> >Make note of current file perms of share folder and any applicable[/ref][/ref] >subfolder[ref][ref] >> >you are copying, then chmod 777 the affected folder. >> >Are you saving files with different user names (file ownership)? >> >It sounds like a permissions issue.[/ref] >> I think, it must have to do with the protocol under XP prof/SP1. >> Sitting on a 3rd computer with Win98(FE) in the same net (means >> workgroup), i can pick up the file (with the 'write protected' attrib >> set) of the XP box and copy it without any trouble to the >> visionfs-box. Fucky - sorry ;-) >> Cheers Peter >> Beg for help 8-((((((([/ref] >[/ref] [allowsmilie] => 1 [showsignature] => 0 [ipaddress] => [iconid] => 0 [visible] => 1 [attach] => 0 [infraction] => 0 [reportthreadid] => 0 [isusenetpost] => 1 [msgid] => [ref] => <9mshqvsc0ci7g5m92ako2bv7r78g63t5sq@4ax.com> [htmlstate] => on_nl2br [postusername] => Peter [ip] => proORGA-Leimen. [isdeleted] => 0 [usergroupid] => [membergroupids] => [displaygroupid] => [password] => [passworddate] => [email] => [styleid] => [parentemail] => [homepage] => [icq] => [aim] => [yahoo] => [msn] => [skype] => [showvbcode] => [showbirthday] => [usertitle] => [customtitle] => [joindate] => [daysprune] => [lastvisit] => [lastactivity] => [lastpost] => [lastpostid] => [posts] => [reputation] => [reputationlevelid] => [timezoneoffset] => [pmpopup] => [avatarid] => [avatarrevision] => [profilepicrevision] => [sigpicrevision] => [options] => [akvbghsfs_optionsfield] => [birthday] => [birthday_search] => [maxposts] => [startofweek] => [referrerid] => [languageid] => [emailstamp] => [threadedmode] => [autosubscribe] => [pmtotal] => [pmunread] => [salt] => [ipoints] => [infractions] => [warnings] => [infractiongroupids] => [infractiongroupid] => [adminoptions] => [profilevisits] => [friendcount] => [friendreqcount] => [vmunreadcount] => [vmmoderatedcount] => [socgroupinvitecount] => [socgroupreqcount] => [pcunreadcount] => [pcmoderatedcount] => [gmmoderatedcount] => [assetposthash] => [fbuserid] => [fbjoindate] => [fbname] => [logintype] => [fbaccesstoken] => [newrepcount] => [vbseo_likes_in] => [vbseo_likes_out] => [vbseo_likes_unread] => [temp] => [field1] => [field2] => [field3] => [field4] => [field5] => [subfolders] => [pmfolders] => [buddylist] => [ignorelist] => [signature] => [searchprefs] => [rank] => [icontitle] => [iconpath] => [avatarpath] => [hascustomavatar] => 0 [avatardateline] => [avwidth] => [avheight] => [edit_userid] => [edit_username] => [edit_dateline] => [edit_reason] => [hashistory] => [pagetext_html] => [hasimages] => [signatureparsed] => [sighasimages] => [sigpic] => [sigpicdateline] => [sigpicwidth] => [sigpicheight] => [postcount] => 7 [islastshown] => [isfirstshown] => [attachments] => [allattachments] => ) --> visionfs 3.10.905 copy-problem under XP prof. - SCO

visionfs 3.10.905 copy-problem under XP prof. - SCO

Hi! We use visionfs 3.10.905 in a small netwerk with a XP prof. and Win98/98SE machines. Now i got there a problem on copying a file from a CD-device on the XP box to a directory on the Unix-visionfs box. The error is: not privileged (we have here the german language). Copy the file from the cd to a place on the XP box first, and than to the unixbox works ! So now, i tried to use a random file on the XP box and copied it without a problem, then i set the read-only on that file and ...

  1. #1

    Default visionfs 3.10.905 copy-problem under XP prof.

    Hi!
    We use visionfs 3.10.905 in a small netwerk with a XP prof. and
    Win98/98SE machines. Now i got there a problem on copying a file from
    a CD-device on the XP box to a directory on the Unix-visionfs box.
    The error is: not privileged (we have here the german language).
    Copy the file from the cd to a place on the XP box first, and than to
    the unixbox works !
    So now, i tried to use a random file on the XP box and copied it
    without a problem, then i set the read-only on that file and tried to
    copy it again and the same problems came up!
    I thing the trouble cames up from the read-only attribute - which of
    course all the file on cd have.
    What is the problem, how to work around?
    Best regards
    Peter
    Peter Guest

  2. #2

    Default Re: visionfs 3.10.905 copy-problem under XP prof.

    In article <com>,
    Peter Michel <de> wrote: 
    Have you tried upgrading to .911?

    SCO VisionFS 3.10.911

    LER


    --
    Larry Rosenman http://www.lerctr.org/~ler
    Phone: +1 972-414-9812 E-Mail: org
    US Mail: 1905 Steamboat Springs Drive, Garland, TX 75044-6749
    Larry Guest

  3. #3

    Default Re: visionfs 3.10.905 copy-problem under XP prof.

    On Tue, 4 Nov 2003 18:44:12 +0000 (UTC), org (Larry
    Rosenman) wrote:
     
    >Have you tried upgrading to .911?
    >
    >SCO VisionFS 3.10.911[/ref]

    Hi Larry!
    I tried .911 with the same result 8-((
    Copy a normal file works, setting it's write protected attribute than
    the copy fails.
    Here the output of a) .../version:
    SCO VisionFS
    3.10.911
    b) of the problem of .../logs/error.log:
    2003/11/05 12:05:43.270 (pid 621)
    SCO VisionFS(3.1) ERROR:
    connecttree/unixfile/truncatefailed
    An attempt to truncate a file has failed:
    ftruncate(/home/michel/SicherungDVD.nri(7),61440): (13)
    Permission denied
    The transaction has failed.
    Check the permissions are correct.

    Cheers Peter
    Peter Guest

  4. #4

    Default Re: visionfs 3.10.905 copy-problem under XP prof.

    > I tried .911 with the same result 8-(( 

    Does this file have a real long filename or funny characters in it?
    Are you trying to overwrite a copy already on server?
    Look in profile editor and try liberalizing permissions on just that share.
    Check/liberalize file permissions on share directory and share subfolders.
    Make note of current file perms of share folder and any applicable subfolder
    you are copying, then chmod 777 the affected folder.
    Are you saving files with different user names (file ownership)?
    It sounds like a permissions issue.


    Bob Guest

  5. #5

    Default Re: visionfs 3.10.905 copy-problem under XP prof.

    On Wed, 5 Nov 2003 07:16:58 -0800, "Bob Meyers"
    <com> wrote:
     
    >
    >Does this file have a real long filename or funny characters in it?[/ref]
    Yes and NO, just change the attribute to 'not write protected', and
    the same thing works! 
    No, s.o. 
    I think, it must have to do with the protocol under XP prof/SP1.
    Sitting on a 3rd computer with Win98(FE) in the same net (means
    workgroup), i can pick up the file (with the 'write protected' attrib
    set) of the XP box and copy it without any trouble to the
    visionfs-box. y - sorry ;-)
    Cheers Peter
    Beg for help 8-(((((((
    Peter Guest

  6. #6

    Default Re: visionfs 3.10.905 copy-problem under XP prof.

    It is the write protect setting causing it. Previous versions of Windoze,
    such as 98, when copying direct from a CD-ROM to the local drive retain the
    wp bit. Yet XP and (uncornfirmed) likely W2k automagically strip this bit
    and make the file "useful".

    As for the last bit of this post Peter, I can only smile and point out a
    similar oddity: by default your Win98 box can't read an NTFS drive if
    installed locally, yet if an NT box has a share on the network, you can now
    read it just fine-file system becomes irrelevant.

    Go figure


    "Peter Michel" <de> wrote in message
    news:com... 
    > >
    > >Does this file have a real long filename or funny characters in it?[/ref]
    > Yes and NO, just change the attribute to 'not write protected', and
    > the same thing works! 
    > No, s.o. [/ref]
    share. [/ref]
    subfolders. [/ref]
    subfolder 
    > I think, it must have to do with the protocol under XP prof/SP1.
    > Sitting on a 3rd computer with Win98(FE) in the same net (means
    > workgroup), i can pick up the file (with the 'write protected' attrib
    > set) of the XP box and copy it without any trouble to the
    > visionfs-box. y - sorry ;-)
    > Cheers Peter
    > Beg for help 8-((((((([/ref]


    Dave Guest

  7. #7

    Default Re: visionfs 3.10.905 copy-problem under XP prof.

    But this can not be the main problem. I did some tests an got:
    a) i maked a Test-share under profedit to the /tmp on the unix-box
    b) On the XP-box: created a testfile and set the write-protect attrib.
    c) Connected as a visionfs Admin on the XP-box: i can copy it!
    d) Connected as not a visionfs Admin i can not (directly), i must:
    - remove write-protect on the testfile
    - copy it
    - set write-potect on the copied testfile again.

     
    Don't smile to much ;-) Why can i not read on a Win98-Box (via TCP/IP)
    a file on a NTFS-fs on XP machine???
    There where 3 boxes in the play:
    XP-box with sourcefile---------Win98-box action copy----->Unix-box. 
    >> Yes and NO, just change the attribute to 'not write protected', and
    >> the same thing works! 
    >> No, s.o. [/ref]
    >share. [/ref]
    >subfolders. [/ref]
    >subfolder 
    >> I think, it must have to do with the protocol under XP prof/SP1.
    >> Sitting on a 3rd computer with Win98(FE) in the same net (means
    >> workgroup), i can pick up the file (with the 'write protected' attrib
    >> set) of the XP box and copy it without any trouble to the
    >> visionfs-box. y - sorry ;-)
    >> Cheers Peter
    >> Beg for help 8-((((((([/ref]
    >[/ref]

    Peter Guest

  8. #8

    Default Re: visionfs 3.10.905 copy-problem under XP prof.


    "Peter Michel" <de> wrote in message
    news:com... 

    Define "why can I not read on a Win98 box". What error message?


    Bob Guest

Similar Threads

  1. Debugging problem in Win 2000 prof.
    By Johyson in forum ASP.NET Security
    Replies: 1
    Last Post: September 5th, 08:55 AM
  2. visionfs problem with the PC License Manager
    By tony@aplawrence.com in forum SCO
    Replies: 0
    Last Post: August 8th, 10:38 AM
  3. Visionfs and Samba
    By tony@aplawrence.com in forum SCO
    Replies: 0
    Last Post: August 1st, 09:00 PM
  4. Visionfs & XP
    By Jean-Pierre Radley in forum SCO
    Replies: 14
    Last Post: July 15th, 05:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •