Professional Web Applications Themes

Web services are not working on win2003 server Enterprise edition - ASP.NET Web Services

Hi I have created a simple "Hello world" ASP.NET web service for tesing purpose. This runs well on windows2000 machines but if I deploy in the same way onto Windows 2003 server enterprise edition it does not work!!. IE throws The page cannot be found (HTTP Error 404 ) Other .Net applications(like console apps and Form based apps) run well on this machine. Is there anything I need to take care on this platform. Thanks in advance Kiran...

  1. #1

    Default Web services are not working on win2003 server Enterprise edition

    Hi
    I have created a simple "Hello world" ASP.NET web
    service for tesing purpose. This runs well on windows2000
    machines but if I deploy in the same way onto Windows 2003
    server enterprise edition it does not work!!.
    IE throws The page cannot be found (HTTP Error 404 )

    Other .Net applications(like console apps and Form based
    apps) run well on this machine.

    Is there anything I need to take care on this platform.

    Thanks in advance
    Kiran



    Kiran Guest

  2. #2

    Default RE: Web services are not working on win2003 server Enterprise edition

    Hi Kiran,

    Thank you for using Microsoft MSDN managed newsgroup.

    Would you please tell me how do you deploy your web service onto the
    Windows 2003 Server? Is it possible for you to try to create a web service
    on the Windows 2003 Server? Please try to test the following sample on the
    Windows 2003 server. Can you reproduce the same error?

    HOW TO: Build and Use XML Web Services by Using Visual Studio .NET
    [url]http://support.microsoft.com/default.aspx?scid=kb;en-us;315935[/url]

    Best regards,

    Jacob Yang
    Microsoft Online Partner Support
    Get Secure! 每 [url]www.microsoft.com/security[/url]
    This posting is provided "as is" with no warranties and confers no rights.

    Jacob Yang [MSFT] Guest

  3. #3

    Default Re: Web services are not working on win2003 server Enterprise edition

    Kiran,

    I would recommend verifying your IIS configs; make sure the necessary
    site/vroot is established.

    Cheers,

    John
    [url]http://www.bristowe.com/[/url]
    > Hi
    > I have created a simple "Hello world" ASP.NET web
    > service for tesing purpose. This runs well on windows2000
    > machines but if I deploy in the same way onto Windows 2003
    > server enterprise edition it does not work!!.
    > IE throws The page cannot be found (HTTP Error 404 )
    >
    > Other .Net applications(like console apps and Form based
    > apps) run well on this machine.
    >
    > Is there anything I need to take care on this platform.
    >
    > Thanks in advance
    > Kiran

    John Bristowe Guest

  4. #4

    Default Re: Web services are not working on win2003 server Enterprise edition

    Try to call "aspnet_regiis.exe -i" from Visual studio .net 2003 Command
    prompt.
    Bye

    Marco.

    Kiran wrote:
    > Hi
    > I have created a simple "Hello world" ASP.NET web
    > service for tesing purpose. This runs well on windows2000
    > machines but if I deploy in the same way onto Windows 2003
    > server enterprise edition it does not work!!.
    > IE throws The page cannot be found (HTTP Error 404 )
    >
    > Other .Net applications(like console apps and Form based
    > apps) run well on this machine.
    >
    > Is there anything I need to take care on this platform.
    >
    > Thanks in advance
    > Kiran
    >
    >
    >
    Marco Neri Guest

  5. #5

    Default Re: Web services are not working on win2003 server Enterprise edition

    "Kiran" <kiranjoseph74hotmail.com> wrote in message
    news:02b701c39a79$bf9502c0$a601280aphx.gbl...
    > Hi
    > I have created a simple "Hello world" ASP.NET web
    > service for tesing purpose. This runs well on windows2000
    > machines but if I deploy in the same way onto Windows 2003
    > server enterprise edition it does not work!!.
    > IE throws The page cannot be found (HTTP Error 404 )
    >
    > Other .Net applications(like console apps and Form based
    > apps) run well on this machine.
    >
    > Is there anything I need to take care on this platform.
    By default, IIS does not allow you to run anything (secure mode)...

    you need to configure IIS to run ASP.NET so go to administrative tools,
    configure this computer, and enable IIS for ASp.NET and for static pages
    (html)
    > Thanks in advance
    > Kiran
    >
    >
    >
    Egbert Nierop \(MVP for IIS\) Guest

  6. #6

    Default RE: Web services are not working on win2003 server Enterprise edition

    Hi Jacob,
    Thanks for your reply

    I created the web service same way as the sample and
    deployed on 2000 server by creating the virtual directory
    and pointing to the folder containing related files, it
    worked fine
    If I do the same thing on windows 2003 server machine it
    does not work
    Do I have to do some thing with IIS setting specifically
    for win 2003 server if YES what kind of setting I need to
    do


    Thanks in advance
    Kiran
    >-----Original Message-----
    >Hi Kiran,
    >
    >Thank you for using Microsoft MSDN managed newsgroup.
    >
    >Would you please tell me how do you deploy your web
    service onto the
    >Windows 2003 Server? Is it possible for you to try to
    create a web service
    >on the Windows 2003 Server? Please try to test the
    following sample on the
    >Windows 2003 server. Can you reproduce the same error?
    >
    >HOW TO: Build and Use XML Web Services by Using Visual
    Studio .NET
    >[url]http://support.microsoft.com/default.aspx?scid=kb;en-[/url]
    us;315935
    >
    >Best regards,
    >
    >Jacob Yang
    >Microsoft Online Partner Support
    >Get Secure! 每 [url]www.microsoft.com/security[/url]
    >This posting is provided "as is" with no warranties and
    confers no rights.
    >
    >.
    >
    Kiran Guest

  7. #7

    Default Re: Web services are not working on win2003 server Enterprise edition

    Hi
    Thnaks for the reply
    Can you be more specific as where exactly can I enable
    IIS for ASp.NET and for static pages(under which tab in
    IIS manager console).

    Thanks
    Kiran
    >-----Original Message-----
    >"Kiran" <kiranjoseph74hotmail.com> wrote in message
    >news:02b701c39a79$bf9502c0$a601280aphx.gbl...
    >> Hi
    >> I have created a simple "Hello world" ASP.NET web
    >> service for tesing purpose. This runs well on
    windows2000
    >> machines but if I deploy in the same way onto Windows
    2003
    >> server enterprise edition it does not work!!.
    >> IE throws The page cannot be found (HTTP Error 404 )
    >>
    >> Other .Net applications(like console apps and Form based
    >> apps) run well on this machine.
    >>
    >> Is there anything I need to take care on this platform.
    >By default, IIS does not allow you to run anything
    (secure mode)...
    >
    >you need to configure IIS to run ASP.NET so go to
    administrative tools,
    >configure this computer, and enable IIS for ASp.NET and
    for static pages
    >(html)
    >
    >> Thanks in advance
    >> Kiran
    >>
    >>
    >>
    >
    >.
    >
    Guest

  8. #8

    Default Re: Web services are not working on win2003 server Enterprise edition

    Hi
    Thanks for the reply
    I tried it but did not help


    Kiran
    >-----Original Message-----
    >Try to call "aspnet_regiis.exe -i" from Visual
    studio .net 2003 Command
    >prompt.
    >Bye
    >
    >Marco.
    >
    >Kiran wrote:
    >> Hi
    >> I have created a simple "Hello world" ASP.NET web
    >> service for tesing purpose. This runs well on
    windows2000
    >> machines but if I deploy in the same way onto Windows
    2003
    >> server enterprise edition it does not work!!.
    >> IE throws The page cannot be found (HTTP Error 404 )
    >>
    >> Other .Net applications(like console apps and Form
    based
    >> apps) run well on this machine.
    >>
    >> Is there anything I need to take care on this platform.
    >>
    >> Thanks in advance
    >> Kiran
    >>
    >>
    >>
    >
    >.
    >
    Kiran Guest

  9. #9

    Default Re: Web services are not working on win2003 server Enterprise edition

    Hi

    I can access the html page succefully from the vroot
    but not the actual asmx file which has a simple hello
    world method in it


    Kiran
    >-----Original Message-----
    >Kiran,
    >
    >I would recommend verifying your IIS configs; make sure
    the necessary
    >site/vroot is established.
    >
    >Cheers,
    >
    >John
    >[url]http://www.bristowe.com/[/url]
    >
    >> Hi
    >> I have created a simple "Hello world" ASP.NET web
    >> service for tesing purpose. This runs well on
    windows2000
    >> machines but if I deploy in the same way onto Windows
    2003
    >> server enterprise edition it does not work!!.
    >> IE throws The page cannot be found (HTTP Error 404 )
    >>
    >> Other .Net applications(like console apps and Form based
    >> apps) run well on this machine.
    >>
    >> Is there anything I need to take care on this platform.
    >>
    >> Thanks in advance
    >> Kiran
    >
    >
    >.
    >
    Kiran Guest

  10. #10

    Default RE: Web services are not working on win2003 server Enterprise edition

    Hi Kiran,

    Based on my research and experience, the following Knowledge Base article
    is useful to you. Please refer to it carefully.

    HOW TO: Enable and Disable Dynamic Content in IIS 6.0
    [url]http://support.microsoft.com/?id=315122[/url]
    "...
    By default, when Internet Information Services (IIS) is installed on any
    version of the Microsoft Windows Server 2003 family, IIS only serves static
    content (HTML). When you request dynamic content, such as Active Server
    Pages (ASP) or ASP.NET pages, you receive one of the following error
    messages:

    HTTP Error 404 - File Not Found
    -or-

    HTTP Error 404- File or Directory not found
    To permit IIS to serve other types of content, the administrator must
    unlock this content in the Web service extensions node in the IIS
    management console. To do this, either enable a pre-existing Web service
    extension or add a new Web service extension.
    ..."

    Does it answer your question? If I have misunderstood your concern, please
    feel free to let me know.

    Best regards,

    Jacob Yang
    Microsoft Online Partner Support
    Get Secure! 每 [url]www.microsoft.com/security[/url]
    This posting is provided "as is" with no warranties and confers no rights.

    Jacob Yang [MSFT] Guest

  11. #11

    Default Re: Web services are not working on win2003 server Enterprise edition

    > Thnaks for the reply
    > Can you be more specific as where exactly can I enable
    > IIS for ASp.NET and for static pages(under which tab in
    > IIS manager console).
    Look for the node called "Web Service Extensions", at the same level as "Web
    Sites" and "Application Pools".

    --
    Tomas Restrepo
    [email]tomasrmvps.org[/email]


    Tomas Restrepo \(MVP\) Guest

  12. #12

    Default RE: Web services are not working on win2003 server Enterprise edition

    Hi Jacob,
    Your suggestion really helped me.
    It was the issue with Web services extension it was
    disabled(I think by default) for ASP.net
    I enabled it and it started working.


    Thanks
    Kiran
    >-----Original Message-----
    >Hi Kiran,
    >
    >Based on my research and experience, the following
    Knowledge Base article
    >is useful to you. Please refer to it carefully.
    >
    >HOW TO: Enable and Disable Dynamic Content in IIS 6.0
    >[url]http://support.microsoft.com/?id=315122[/url]
    >"...
    >By default, when Internet Information Services (IIS) is
    installed on any
    >version of the Microsoft Windows Server 2003 family, IIS
    only serves static
    >content (HTML). When you request dynamic content, such as
    Active Server
    >Pages (ASP) or ASP.NET pages, you receive one of the
    following error
    >messages:
    >
    >HTTP Error 404 - File Not Found
    >-or-
    >
    >HTTP Error 404- File or Directory not found
    >To permit IIS to serve other types of content, the
    administrator must
    >unlock this content in the Web service extensions node in
    the IIS
    >management console. To do this, either enable a pre-
    existing Web service
    >extension or add a new Web service extension.
    >..."
    >
    >Does it answer your question? If I have misunderstood
    your concern, please
    >feel free to let me know.
    >
    >Best regards,
    >
    >Jacob Yang
    >Microsoft Online Partner Support
    >Get Secure! 每 [url]www.microsoft.com/security[/url]
    >This posting is provided "as is" with no warranties and
    confers no rights.
    >
    >.
    >
    Kiran Guest

  13. #13

    Default Re: Web services are not working on win2003 server Enterprise edition

    Hi Tomas
    Your suggestion really helped me.
    It was the issue with Web services extension it was
    disabled(I think by default) for ASP.net
    I enabled it and it started working.


    Thanks
    Kiran
    >-----Original Message-----
    >> Thnaks for the reply
    >> Can you be more specific as where exactly can I
    enable
    >> IIS for ASp.NET and for static pages(under which tab in
    >> IIS manager console).
    >
    >Look for the node called "Web Service Extensions", at the
    same level as "Web
    >Sites" and "Application Pools".
    >
    >--
    >Tomas Restrepo
    >tomasrmvps.org
    >
    >
    >.
    >
    kiran Guest

Similar Threads

  1. FMS on Microsoft Windows Server 2003, Enterprise Edition(64-bit)
    By alan_leung in forum Macromedia Flash Flashcom
    Replies: 1
    Last Post: July 19th, 05:29 PM
  2. Enterprise Edition on 2 dual core CPU server?
    By Bill Gordon in forum Coldfusion Server Administration
    Replies: 1
    Last Post: July 7th, 08:01 AM
  3. Terminal Services still not working on Win2003
    By Jon Ballinger in forum Windows Server
    Replies: 0
    Last Post: July 3rd, 03:57 PM
  4. Problems re-activating Win2003 Enterprise Eval
    By Eric Kimminau in forum Windows Server
    Replies: 9
    Last Post: June 24th, 08:39 PM
  5. Replies: 1
    Last Post: June 11th, 10:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139