Professional Web Applications Themes

webserver through netcomm nb1300 adsl modem - Mac Networking

hi there i want to reach the web server i'm running on my Mac Os X 10.3.2 machine from the outside world. the NB1300 adsl modem is connected via ethernet to the machine and via adsl phone line to the provider. i did not change the standrad config. so i guess the modem acts as a "router". the provider issues dynamic ip addresses (however the address stays fixed for at least on session). i tried to reach the web server from the outside via the just issued ip address but i can get through the modem.i always get a 404 ...

  1. #1

    Default webserver through netcomm nb1300 adsl modem

    hi there

    i want to reach the web server i'm running on my Mac Os X 10.3.2 machine
    from the outside world.

    the NB1300 adsl modem is connected via ethernet to the machine and via adsl
    phone line to the provider. i did not change the standrad config. so i guess
    the modem acts as a "router".

    the provider issues dynamic ip addresses (however the address stays fixed
    for at least on session).

    i tried to reach the web server from the outside via the just issued ip
    address but i can get through the modem.i always get a 404 error.

    does anubody know how i have to configure the NB1300 modem so the http and
    ftp requests go through?

    thanks for advice,

    leo broska



    leo Guest

  2. #2

    Default Re: webserver through netcomm nb1300 adsl modem

    leo <myrealbox.com> wrote: 
     
     

    Yep, DHCP server and network router is the default. Works quite
    well and will allow web serving if you set it up.
     

    Lets call that 200.200.200.200. Are you aware you can get a free
    referrer name from dyndns and the like, which can be set up to
    update the referenced IP as your IP changes?
     

    Yep, the web requests will go to the modem, not your web server.
     

    Yes. I have the 1300Plus4. I imagine the 1300 interface is similar.

    Now, you will have probably set up your web server to get an IP via
    DHCP (check your network settings to confirm this). The modem will
    have given you a private IP to use. Lets call it 192.168.1.12 (did
    I get it right?).

    All you need to do is to tell the modem to forward all connections
    on port 80 (the normal web server port) to your computer. From your
    web server, browse to the modem's configuration web interface
    (probably just by entering 192.168.1.1 as the URL in your browser.
    Click on Advanced Settings, and find the Port Forwarding
    configuration page.

    Add a new forward like this:
    Incoming port: 80
    Destination port: 80 (or whatever your web server is set to)
    Connection type: TCP
    Destination host: 192.168.1.12 (or your private IP if different).

    Click the link to save and reboot the modem. In 30 seconds or so,
    you should be right to go. Note that you can't test this from
    inside your network though! Either go to some other Internet
    connected machine, or remote login to another machine on the
    Internet and make a connection back to your web server from there.

    Enabling ftp is similar, but a bit more complicated. To enable
    PASSIVE ftp, forwards ports 20 TCP and 21 TCP as above. To enable
    ACTIVE ftp, you'd actually need to put your web server in the DMZ,
    or put the modem into half-bridge mode. Passive should work fine
    though.

    Hope that helps!
    --
    *--------------------------------------------------------*
    | ^Nothing is foolproof to a sufficiently talented fool^ |
    | Heath Raftery, HRSoftWorks _\|/_ |
    *______________________________________m_('.')_m__ _______*
    Heath Guest

  3. #3

    Default Re: webserver through netcomm nb1300 adsl modem

    Heath Raftery wrote:
     
    >
    >
    > Yep, DHCP server and network router is the default. Works quite
    > well and will allow web serving if you set it up.

    >
    > Lets call that 200.200.200.200. Are you aware you can get a free
    > referrer name from dyndns and the like, which can be set up to
    > update the referenced IP as your IP changes?[/ref]

    first of all, thanks for your detailed info!

    and yep, i've already got my subdomain name with dyndns. :-)
     
    >
    >
    > Yes. I have the 1300Plus4. I imagine the 1300 interface is similar.
    >
    > Now, you will have probably set up your web server to get an IP via
    > DHCP (check your network settings to confirm this). The modem will
    > have given you a private IP to use. Lets call it 192.168.1.12 (did
    > I get it right?).
    >
    > All you need to do is to tell the modem to forward all connections
    > on port 80 (the normal web server port) to your computer. From your
    > web server, browse to the modem's configuration web interface
    > (probably just by entering 192.168.1.1 as the URL in your browser.
    > Click on Advanced Settings, and find the Port Forwarding
    > configuration page.
    >
    > Add a new forward like this:
    > Incoming port: 80
    > Destination port: 80 (or whatever your web server is set to)
    > Connection type: TCP
    > Destination host: 192.168.1.12 (or your private IP if different).
    >
    > Click the link to save and reboot the modem. In 30 seconds or so,
    > you should be right to go. Note that you can't test this from
    > inside your network though! Either go to some other Internet
    > connected machine, or remote login to another machine on the
    > Internet and make a connection back to your web server from there.[/ref]

    thanks, i did that (btw 192.168.1.12 _is_ my private IP issued from
    NB1300), but it still doesn't work:

    when i try to reach my server the browser always prsents the
    authentication dialog with the realm BB1300, so the request still does
    not go through the modem... :(

    any idea?

    leo
    leo Guest

  4. #4

    Default Re: webserver through netcomm nb1300 adsl modem

    leo <myrealbox.com> wrote: 
     
    >>
    >> Yes. I have the 1300Plus4. I imagine the 1300 interface is similar.
    >>
    >> Now, you will have probably set up your web server to get an IP via
    >> DHCP (check your network settings to confirm this). The modem will
    >> have given you a private IP to use. Lets call it 192.168.1.12 (did
    >> I get it right?).
    >>
    >> All you need to do is to tell the modem to forward all connections
    >> on port 80 (the normal web server port) to your computer. From your
    >> web server, browse to the modem's configuration web interface
    >> (probably just by entering 192.168.1.1 as the URL in your browser.
    >> Click on Advanced Settings, and find the Port Forwarding
    >> configuration page.
    >>
    >> Add a new forward like this:
    >> Incoming port: 80
    >> Destination port: 80 (or whatever your web server is set to)
    >> Connection type: TCP
    >> Destination host: 192.168.1.12 (or your private IP if different).
    >>
    >> Click the link to save and reboot the modem. In 30 seconds or so,
    >> you should be right to go. Note that you can't test this from
    >> inside your network though! Either go to some other Internet
    >> connected machine, or remote login to another machine on the
    >> Internet and make a connection back to your web server from there.[/ref][/ref]
     
     

    Oops, I forgot to mention that you have to disable the modem's
    own web server on that port somehow. The way I did it, which is
    pretty easy, was just to move it to port 81 instead.

    Can't quite recall the steps at this stage, but just go through
    the options and find the one which deals with the modem's
    configuration web server. There'll be an option to allow LAN or
    WAN access, and then one to specify the port it runs on. Change
    it to 81, Save and Reboot modem, and you should be away.

    --
    *--------------------------------------------------------*
    | ^Nothing is foolproof to a sufficiently talented fool^ |
    | Heath Raftery, HRSoftWorks _\|/_ |
    *______________________________________m_('.')_m__ _______*
    Heath Guest

  5. #5

    Default Re: webserver through netcomm nb1300 adsl modem


    "Heath Raftery" <com> wrote in message
    news:bvk7se$hqf$newcastle.edu.au... 
    > [/ref][/ref]
    and [/ref]


    >
    > Oops, I forgot to mention that you have to disable the modem's
    > own web server on that port somehow. The way I did it, which is
    > pretty easy, was just to move it to port 81 instead.[/ref]

    did that as well, so i have to reach the modem config now on 192.168.1.1:81.
    plain http requests on port 80 for my webbrowser still don't go
    through...what else can i have done wrong????

    thanks, leo


    leo Guest

  6. #6

    Default Re: webserver through netcomm nb1300 adsl modem

    leo <myrealbox.com> wrote:
     
    >> [/ref]
    > and 
    >> 
    >> 
    >>
    >> Oops, I forgot to mention that you have to disable the modem's
    >> own web server on that port somehow. The way I did it, which is
    >> pretty easy, was just to move it to port 81 instead.[/ref][/ref]
     

    Don't have a firewall running do you? Double check the IP address you
    are forwarding to. Look through your system.log and httpd/access.log
    for any clues. You've reset the modem (using the Save and Reboot button
    on the website will do)?

    --
    *--------------------------------------------------------*
    | ^Nothing is foolproof to a sufficiently talented fool^ |
    | Heath Raftery, HRSoftWorks _\|/_ |
    *______________________________________m_('.')_m__ _______*
    Heath Guest

  7. #7

    Default thanks! (was Re: webserver through netcomm nb1300 adsl modem)


    "Heath Raftery" <com> wrote in message
    news:bvs15n$cre$newcastle.edu.au... 
    > > ...
    > > did that as well, so i have to reach the modem config now on[/ref][/ref]
    192.168.1.1:81. 
    >
    > Don't have a firewall running do you? Double check the IP address you
    > are forwarding to. Look through your system.log and httpd/access.log
    > for any clues. You've reset the modem (using the Save and Reboot button
    > on the website will do)?[/ref]

    now it works, additionally i had to enabled the dmz to my internatl
    ip.(don't know why...) but now i can get through from the outside! jipeee!

    thanks for your help, heath!

    cheers, leo



    leo Guest

Similar Threads

  1. Newbie Q: ADSL Modem
    By Tom Croydon in forum Ubuntu
    Replies: 7
    Last Post: January 15th, 05:19 AM
  2. OS X loses USB ADSL Modem
    By Pascal Sartoretti in forum Mac Networking
    Replies: 0
    Last Post: October 9th, 07:21 PM
  3. USB adsl modem/network
    By Michael in forum Windows Networking
    Replies: 0
    Last Post: July 8th, 05:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139