I've been dealing with this issue today, and have some information to
share.

I created a ws, let's call it 1.asmx.
1.asmx contained a method which returned a single serialized object.
This worked fine.

I added another method to 1.asmx which returned a collection of the
same serialized objects, and then got the FileNotFoundException.
Eventually I found that every method in 1.asmx was generating this
exception.

I looked around here for an hour or so and tried the permissions
thing, which did not change anything in my case, and then tried making
another ws (2.asmx).

In order to eliminate the possiblity that there was something mucked
up recently that prevented me from making new web services, I
un-commented the HelloWorld in 2.asmx and tried it. Everything worked
fine. I then copied the methods from 1.asmx into 2.asmx and got the
exception (on any method call).

Then Commented out the method(s) that returned serialized collections,
and the other methods again work. So there must be something wrong
with my serialized collections that is not being caught at compile
time, and, worse, won't even generate a useful error message.

Just thought I'd share. :)
Have a good day.
Tom

(If you want to email me, put in there instead.)



"Jun Chen" <junpacbell.net> wrote in message news:<uDjHoLsQDHA.2176TK2MSFTNGP12.phx.gbl>...
> I have same problem, have you fixed it, matt?
> What I can say to Microsoft? same problem now even I create any Webservice
> with my VS.NET 2003
>
> -Jun Chen